Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: HDD does not show up in My Computer

04 Oct 2012   #31
NeverSayDie

 
 

If you are able to see the drive, here are the first two techniques to try in order to recover your pictures folder. If you don't see the drive, completely shutdown the computer and turn it off then boot into PartedMagic again to see if it shows up.

boot the computer into PartedMagic like you did before.

Click the MOUNT DEVICES button which is down by the START button. Here's a picture...
http://litten.com/images/mount1.jpg

You want to click the green MOUNT buttons next to the bad drive and the drive that you want to copy to. If you aren't sure which drive is which then post a picture and we'll try to tell you.

Your original internal drive that I assume you are copying to has 3 partitions that can be mounted, you want to mount the largest which is probably called ACER. Be patient as it can take a few moments to mount sometimes.

Once you have mounted both the bad drive and the drive that we are copying to, you will notice that the File Manager window opened also when you clicked the MOUNT DEVICES button. In it you will see folders representing your drives. The File Manager window should be displaying the contents of the /media folder and your drives will be folders called sda1 and sdb1 (though yours may have different names that you get by looking next to the MOUNT button).

Double click the folder for your bad drive and if you see your files and folders then simply select what you want to copy to the new drive and right-click and choose COPY. Then navigate to the folder that represents the new drive and right-click and choose PASTE just like if you were in Windows Explorer.

Let us know if this works, you have any questions or if it does not work for you or you can't see the files on the bad drive.
If you have any problems or questions, take a picture and post it like you've been doing.

I'll type up directions for the next thing to try and post them shortly.

James


My System SpecsSystem Spec
.
04 Oct 2012   #32
NeverSayDie

 
 

I have to meet a client so here is the next thing to try if the above post did not work...

Since that bad drive seems to like a fresh start before it works, reboot it into PartedMagic before trying this.

First, mount only the drive you are copying to(probably the ACER one) using the MOUNT DEVICES button like I described in the previous post. Leave the mount devices and the file manager windows open, we'll be back to that.

Next open the Terminal window (the picture of the monitor down by that mount devices button in the lower left of the desktop).

In the terminal type
Type testdisk and press enter.
Choose No Log and hit enter
Make sure that your bad disk is highlighted
Choose Proceed and hit enter
Select Intel and hit enter
Select Advanced and hit enter
Make sure that the partition is highlighted and
Select List and hit enter

IF IT SAYS NO PARTITION AVAILABLE TRY THIS
Hit Q a bunch of times until you are out of TestDisk and go into it again but this time at the step
Select Intel and hit enter
Choose EFI GPT instead of Intel and hit enter and see if that allows you to see the partition.


If you see your files and folders we can copy them from here.
There are directions at the bottom of the screen in TestDisk. I like to do a test first and try to copy just one file or folder to see if it works.

Select a file or folder that you'd like to try copying by highlighting it.
Press the semicolon key to select it
:
and then press upper case C to copy all selected files
SHIFT-C
Now it wants to know where to copy the file to.
Highlight the second line which is .. (two dots) and press the right arrow key and it will take you up a level.
Highlight the media folder and press the right arrow key.
You should see the disk that you mounted in there. It's probably called something like sda1 (look at what it was called when you mounted it like /media/sda1)
Highlight the sda1 folder (or whatever your disk is called) and press the right arrow key.
Press
C
and it should copy the file there.
Leave everything open and look in the file manager window to verify that the file was copied. In the file manager window, look inside the folder for your mounted drive (sda1 in our example but yours may be something else) and see if you see the file that you copied there. If it is there, go back to the TestDisk window and select more files and folders that you want to copy and when you choose to copy them it will put them on the drive you already chose.

Again, let us know if this works, you have any questions or if it does not work for you or you can't see the files on the bad drive.
If you have any problems or questions, take a picture and post it like you've been doing.

James
My System SpecsSystem Spec
04 Oct 2012   #33
ComputerBiff

Windows 7 64bit
 
 

For some reason the drive is not showing up, so i can't mount it. I have a few work things to do tonight so i'm inbetween, i think i may leave it till tomorrow so it has my full attention. I will try to reboot first then try again, if that fails i'll try tomorrow. What time zone are you on?
My System SpecsSystem Spec
.

04 Oct 2012   #34
NeverSayDie

 
 

I am in UTC-4 and I usually do not look at forums until I take care of my paying customers in the morning which is usually abou 17:00 UTC.

If you can't get the disk to appear using the two techniques I've outlined in the previous posts then you can try putting it back in the enclosure and see if that allows you to use those techniques. Try plugging it in before booting and plugging it in after booting.

If that does not work then it is too far gone for me to help you in the forum and you'll have to contact a data recovery professional.

Your errors indicate physical damage and not logical damage. If it were logical damage, we would see the drive consistently in PartedMagic. When I've seen this type of behavior before it has usually (but not always) been caused by being bumped while plugged in and doing a write operation. It can also be what is called 'weak heads' where it cannot detect the data. These are both problems that need to be addressed in a clean room environment. The precision involved in these parts is incredible and microscopic.

I have had some success using the techniques that I've mentioned but in those cases the hard drive was visible at least sporadically.

I'll be monitoring this thread so keep me posted as to how things progress

James
My System SpecsSystem Spec
09 Oct 2012   #35
ComputerBiff

Windows 7 64bit
 
 

James,

Apologies, i haven't yet abandoned all hope. I have been very busy with work and i won't be able to resume until thursday/friday. Thanks again for helping me.
Will give you an update once i have done the previous threads.
My System SpecsSystem Spec
09 Oct 2012   #36
NeverSayDie

 
 

I know how it is

No problem, I'm still getting notifications for this thread.

James
My System SpecsSystem Spec
14 Jun 2013   #37
Richman1

Windows 7 Ultimate x64
 
 
What happened

Man, I was waiting on pins and needles for the next epesode of this saga as it was the most riveting I have read in a while and it screeched to a hault ending in a thud...clunk.....clank . What a letdown. This should teach me to get my hopes up.
My System SpecsSystem Spec
Reply

 HDD does not show up in My Computer




Thread Tools Search this Thread
Search this Thread:

Advanced Search




Similar help and support threads
Thread Forum
Homegroup. One computer will not show.
I have three computers connected to my wireless network. Two laptops and one desktop PC. After successfully connecting them all to the same homegroup, I found that although the two laptops can see each other and share files, neither can see the PC. On the other hand, the PC can see both laptops...
Network & Sharing
No show pix but they are in my computer...
Hello, I saved from some websites 3 pictures. In the past these pix went automatically to My Pictures, then when I had to send them somewhere as attachments, I clicked on their "Browse" button and done. BUT, this time the 3 pix didn't show in My Pictures folder. After searching a long while I...
General Discussion
How to show the name of the computer instead of the word “computer”?
How to show the name of the computer instead of the word “computer”? “Rename” is an option! Is there a better practice to show the name of the computer with other way? Does renaming the computer affect software installed or other functions? Is it safe to rename it? Consequences? ...
General Discussion
My Computer monitor doesn't show anything when I turn my computer on.
First of, my monitor exhibited signs of flickering during start-up, but only minor ones and would just stop at the 'Welcome' screen of windows so I didn't give it much thought. Iv'e been using it with the cpu the same time I bought the monitor. But after some time, the flickering got worse. It...
Graphic Cards
Age of Empires CD will not show up on computer.
I have just bought a used copy of Age of Empires 3, but when I put the Cd in my disk drive, nothing happens and I get no messages of any sort. I have A windows 7 laptop in good working order, and with the requirements to play the game. Can any one tell me if a game disk can become damaged enough...
Gaming
Win 7 SP1 does not show in computer properties
Strange problem. Using win 7 premium x64 SP1 shows a successful install in the update history. Win update shows 'up to date' when checking. The only anomaly is when I check the properties page of the 'Computer' from the start menu it does not show under the Windows Edition section of the page. ...
Windows Updates & Activation


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 01:15.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App