Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Windows 7 Refuses to Boot


01 Oct 2012   #1

Windows 7 Home Premium 64 bit
 
 
Windows 7 Refuses to Boot

I have a tower system based on an ASUS M5A78L running Windows 7, and it is refusing to go past the ASUS Boot Screen. I also have a dismountable USB based Seagate backup drive that if I remove before booting results in the boot process completing, but not if it is present. I have had USB problems in the past, but these seem to have gone away with driver updates and so on

I have done the obvious and checked the boot order in the boot set-up, which refers only to the Hard Drive and the DVD in boot priority.

Has anyone got any ideas about why this has suddenly started to happen. As the boot does not cmplete I don't think that I have any debug dumps.

Sorry if this is in the wrong place - it was not obvious where to put it

My System SpecsSystem Spec
.

01 Oct 2012   #2

Microsoft Community Contributor Award Recipient

Windows 7 64 Bit Home Premium SP1
 
 

Two things occur to me:
  1. A partition on the external drive is marked ACTIVE but does not have an OS installed on it. (And the boot order is the external drive before the hard drive.)
  2. The boot order is set to boot from the external drive first, but the drive does not spin up fast enough to be read.
The fastest workaround for both is to set the boot order to HDD first. Keep in mind that the external USB drive will not show up in the boot order unless it is connected first (but you can't get that far if it is connected, I know). You might see what happens if you connect the USB drive when you are already in BIOS. Or use another USB device that does not cause the problem, like a thumbdrive.

Can you connect and use the drive after you are already in Windows? Youll need to do that to check for the ACTIVE flag in Disk Management.

Let us know if any of the above is true.
My System SpecsSystem Spec
01 Oct 2012   #3

Windows 7 Home Premium 64 bit
 
 

The boot order, going by the BIOS setup, is internal HDD followed by DVD. I have excluded the external drives (I thought) from that order. However, if the situation is as you say and the drive is in the boot order but I am not seeing it there, then I am not sure what to do.

Yes - I can see the external drive once I am booted. If it makes any difference, I have two external USB drives linked, and I can see them both after boot.

So - what next, please?
My System SpecsSystem Spec
.


01 Oct 2012   #4

Microsoft Community Contributor Award Recipient

Windows 7 64 Bit Home Premium SP1
 
 

What do you mean: "I have two external USB drives linked"?
My System SpecsSystem Spec
01 Oct 2012   #5

Microsoft Community Contributor Award Recipient

Windows 7 64 Bit Home Premium SP1
 
 

What to do:
Boot into the BIOS settings, then connect the USB drive. Then go to the boot order and see if the USB drive shows up. If it does be sure it is after the HDD.

If that is OK, then boot into Windows, connect the USB drive, go to Disk Management, and see if any of the partitions on the USB drive are marked ACTIVE.

Tell us what you see in both cases.
My System SpecsSystem Spec
01 Oct 2012   #6

Windows 7 Home Premium 64 bit
 
 

TVeblen - thanks for your interest. To answer your questions:

I have two external USB drives linked - one I use for backup, and a second for misc storage purposes. I have disconnected the second.

I tried the boot up into BIOS settings, and then mounted the USB drive - no effect on the boot order shown - HDD followed by CD.

Having booted up the Disk Management information for the USB drive shows Healthy (Primary Partition), and shows only a single partition.

Does that suggest anything?
My System SpecsSystem Spec
01 Oct 2012   #7

Windows 7 Home Premium 64 bit
 
 

Further to the above, sometimes the boot splash screen does not recognise the interrupt keys (F8 in this case) and does nothing. There seems to be a link between USB devices and this problem. If I disconnect almost all USB devices, that seems to fix the problem most of the time. USB Driver problem?
My System SpecsSystem Spec
02 Oct 2012   #8

Windows 7 Home Premium 64 bit
 
 

Yet more on the above:

I have been watching the boot up sequence with USB drives disconnected, and it goes something like this (I have abbreviated or shortened some bits):

Entering setup
Press 4 to activate ... etc
Press F8 for ... etc
Press ALT F2 for ... etc
Initialising USB Controllers .... Done
A line about installed memory
USB Devices: 1 Keyboard. 1 Mouse. 1 Storage Device
Auto detecting.... etc - HDD
Auto detecting.... etc - CD
Then details of the drives...... etc
Auto detecting USB Mass Storage Devices ..
Device #01 :

There it stops and goes no further

At that time I have no USB storage devices attached, and actually no USB keyboard (I am using a wired keyboard). See line about USB devices detected

When I re-attach the USB drive the number of storage devices detected goes up to 2. So - is there something wrong with the USB driver(s) that are detecting a drive that does not exist and somehow hanging trying to access it?
My System SpecsSystem Spec
02 Oct 2012   #9

Microsoft Community Contributor Award Recipient

Windows 7 64 Bit Home Premium SP1
 
 

From your tests we can determine that you do not have boot order or ACTIVE partition problem (your Disk Management info is normal). So we can scratch those off.

One thing that occurs to me is that the "linked" setup on the hard drives is a cause. Have you tried booting with both drive connected?

The next thing that occurs to me is that the settings in BIOS have changed. This can happen for various reasons other than user intervention. So we can test that to see if it has an effect.

The first test is to reset the BIOS defaults:
  • Go through your BIOS settings and note the current settings. You may need to set some of these back afterward. A digital camera is a good way to do this. On an older motherboard there will be an option to set the SATA controller to either IDE (legacy) mode or AHCI mode. When you restore defaults the default setting will be IDE. If you installed Windows in AHCI mode then you will want to change this back before trying to boot into Windows. Windows will either not boot or it will load the legacy IDE drivers, which you don't want. Just be sure to re-enter the BIOS immediately after restart.
  • Next go to the EXIT Tab in BIOS Settings and select "Restore BIOS Defaults" (or similar wording). You must Save & Exit to keep the changes. The computer will restart.
  • Immediately go back into the BIOS settings and change the SATA setting (if necessary). Leave all other changed settings alone (for now).
  • Now test to see if the problem persists.
If you get no joy from that then you may need to clear the BIOS "CMOS" settings so they can be rewritten. This will allow the system to initialize the hardware fresh and create a new log (checksum).


To do this:

  • Note all your current BIOS settings
  • Shut down the computer > remove the power cord.
  • Remove the 3v battery.
  • Move the CLRTC jumper from pins 1-2 to 2-3.
  • Touch a metal part of the case and Press and Hold the reset button for approx. 30 seconds to discharge all power from the board.
  • Put the CLRTC jumper back on pins 1-2.
  • Replace the 3v battery > replace the power cord > boot.
  • Immediately go back into BIOS and reset all your preferred settings. If the CLRTC worked you will need to reset the date and time.
Also note that both procedures above are relatively safe. These procedures are not the same as flashing the BIOS which can cause great damage if done improperly. These are standard procedures.


Give those a try and see if it solves it.
My System SpecsSystem Spec
02 Oct 2012   #10

Windows 7 Home Premium 64 bit
 
 

TVeblen

Thank you - your first solution seems to have worked - resetting BIOS defaults. The only thing I hade to do was to remove the USB drive from the boot list. I will keep an eye on it for a few days, but thank you very much.
My System SpecsSystem Spec
Reply

 Windows 7 Refuses to Boot




Thread Tools



Similar help and support threads for2: Windows 7 Refuses to Boot
Thread Forum
Cloned drive refuses to boot unless set to SLAVE Backup and Restore
Windows refuses to show Boot Menu/Start from Microsoft Logo Backup and Restore
Acer Aspire 5742 refuses to boot General Discussion
Solved Desktop refuses to boot properly after shutdown BSOD Help and Support
System refuses to boot after memory upgrade Hardware & Devices
Computer refuses to boot, and I don't have Windows 7 disk General Discussion
Windows 7 refuses to boot up BSOD Help and Support

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 01:09 AM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33