Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: External Hard Drives

20 Sep 2009   #1
Phuxake

Windows 7 64bit
 
 
External Hard Drives

I have two external hard drives which i store and run stuff from.... This has never been a problem while running xp.

I've been sitting on this problem for a while looking for a solution or waiting untill i have seen someone else with a similar problem in hope that there will be a fix. So far, no luck.

The Problem:

This is pretty hard to explain as the problem is pretty random.... From boot up sometimes none or one of my hard drives show up. Mostly they both appear.
Upon Windows startup Sometimes only one external hard drive will appear, then about 10 mins later windows will try to autorun the other as soon as it is eventually recognised.
Sometimes they're no problem untill you try to move large files from one drive to another or from one drive to my hard drive. It will start to move them and then freeze half way through claiming that the files dont exist. You then go to explorer to look, the drives are showing and so is every folder but the folders show as empty.
Both hard drives lights are off indicating they are off.
The only way to fix it is a system restart.

One is a maxtor basics 500gig and the other is a Seagate 1tb. I am running the trial version of windows 7.

I have played with the power manegement and nothing has been told to be switched off..... this hasn't helped.
I've tried unplugging, changing cables, exorcism..... none has affected it.

The only solution a can imagine now is reverting back to xp and cancelling my order for windows 7.

Please tell me there is something blatently obvious that i have missed.


Thank you.


My System SpecsSystem Spec
.
20 Sep 2009   #2
zigzag3143

Win 8 Release candidate 8400
 
 

P

hi and welcome to sevenforums

Are they both USB?
My System SpecsSystem Spec
20 Sep 2009   #3
Phuxake

Windows 7 64bit
 
 

Thank you for the fast reply.

Yes they are both usb, not running off a hub and they both have their own power supply.
My System SpecsSystem Spec
.

20 Sep 2009   #4
Dinesh

Windows® 8 Pro (64-bit)
 
 

could you please fill out your system specs by clicking here?
My System SpecsSystem Spec
20 Sep 2009   #5
zigzag3143

Win 8 Release candidate 8400
 
 

P

Great. lets go into device manager and make sure the USB is working. type device manager in search, and go to the usb section. it should look like ethe screenshot with not unknown devices (they have yellow triangles on them).

If there are any unknown devices let us know.

Ken
My System SpecsSystem Spec
20 Sep 2009   #6
Phuxake

Windows 7 64bit
 
 

ok I have quickly filled in a few specs but i'll have to do the rest tomorrow.

@ zigzag, there are no unknown devices. I have updated all of my drivers as well. Even when the drives stop responding they still show on my device manager.
My System SpecsSystem Spec
21 Sep 2009   #7
johngalt

 

Then time to check to see if USB is being halted / not initialized. Are the drives on when you power up Windows? If so, power them off, power up Windows, then power up the drives.

Also, check to see if your BIOS has enabled legacy USB detection - if so, turn it off and see if it makes a difference.

Finally, check the power settings for all your USB ports to see if Windows is auto shutting them down - if so, try disabling that 'feature' and seeing if that works.
My System SpecsSystem Spec
21 Sep 2009   #8
Phuxake

Windows 7 64bit
 
 

Rightho.......... The drives do power up on startup so i turned them off then started windows. Wow that was a painfull 30 minutes when i switched them on. The maxtor didn't startup but the seagate was instantly recognised, however when i tried to access it windows explorer stopped responding.

I have now disabled legacy detection, both drives (if i leave them on) show in explorer with no delay now, so i think thats one part of the problem solved. thanks for that. The large file transfer problem still remains, both of the hard drive lights go out, even the one i wasn't using.
That also caused pretty much everything to stop responding and i had to do a forced restart...... but then windows froze in the 'shutting down' screen.


I am debating on fetching a hammer from the shed.



Edit: Oh yeah i switched everytthing to 'never shut down' in the advanced power manegement settings yesterday.
My System SpecsSystem Spec
21 Sep 2009   #9
Phuxake

Windows 7 64bit
 
 

Good news everyone: The hammer worked!

j/k

Anyway i have solved the problem and as i anticipated it was blatently obvious..... in fact i'm almost too embarrassed to reveal the solution.
I discovered that my bios is about 3 versions out of date. One simple update later and i have this cursed machine doing exactly what i want it to do again.

Thank you all for your help!
My System SpecsSystem Spec
22 Sep 2009   #10
Dinesh

Windows® 8 Pro (64-bit)
 
 

Glad to hear that you got it sorted.
My System SpecsSystem Spec
Reply

 External Hard Drives




Thread Tools




Similar help and support threads
Thread Forum
All Flash Drives & External Hard Drives NOT ACCESSIBLE?
I set up a new computer. Windows 7 Pro 64x Everything was fine but then I connected a flash drive to it and I get: Location Not Available H:\ is not accessible. Access is denied If I go into the properties to the “security” tab, it says “you do not have permission to view or edit this...
Hardware & Devices
Flash drives and external hard drives
I have windows 7 pro and recently I have not been able to open up a new folder on any external hard drive or flash drive that I use with my computer. When I use these same flash and external hard drives in another computer it works fine, my initial thought is, there is something disabled in my...
Hardware & Devices
Run two external hard drives?
I can only run one at a time instead of two. I would like to copy my 1.5tb over to my 2tb so I have a back up. My laptop only holds 200GB of remaining data so I can't use that hard drive or I would. Anyone have a clue on this? Thanks and really could do with the help.
Hardware & Devices
External Hard Drives Gone After a Restart
After a reboot my two external hard drives have vanished from my PC. I've had one of them going on five years and the other for only six months. I really can't believe they would just break after a simple restart. Especially two of them at once. Folder Options are set to detect hidden...
Hardware & Devices
External hard drives what to get?
Okay im not really looking for brands or models im asking about desktop vs. Portable, At my local best buy they have both in my price range they are 1TB drives, im looking to have something that i can plug into multiple computers and access the files and backup multiple computers to it, i am also...
Hardware & Devices
External hard drives
I was talking to a friend in Poland, who needs an external HD but knows nothing about them. The current is much higher there than in the US, so he was wondering about the risks of frying his electronics. What does anyone have to say about this? He wanted a drive that was USB powered, to reduce...
Hardware & Devices


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 22:47.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App