Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: How Can I Fix Long Monitor Startup Delay

08 Oct 2012   #1
billybag

windows 7 64bit
 
 
How Can I Fix Long Monitor Startup Delay

My monitor remains in powersaver mode until windows logon screen comes up. This started happening a while ago and i have been putting off asking baout it. I have searched google but have found no answers. I am unable to browse bios or anything and it is really annoying.

Primary Monitor (Monitor in question): Dell ST2420L
Secondary Monitor: NS-46L780A12 (Insignia Television)
Graphics Card: GeForce GTX590
Windows 7 64-bit

Steps to reproduce problem:
1. Turn on computer
2. Monitor does not display until logon info needs to be put into windows

If anymore info is needed, let me know.


My System SpecsSystem Spec
.

08 Oct 2012   #2
TVeblen

Microsoft Community Contributor Award Recipient

Windows 7 64 Bit Home Premium SP1
 
 

Does it do this if you disconnect the Insignia TV?
My System SpecsSystem Spec
08 Oct 2012   #3
billybag

windows 7 64bit
 
 

It does. I have also tried switching HDMI ports and switching to VGA instead of HDMI. No changes
My System SpecsSystem Spec
.


08 Oct 2012   #4
TVeblen

Microsoft Community Contributor Award Recipient

Windows 7 64 Bit Home Premium SP1
 
 

Does anything show up on the TV if you disconnect the Monitor?
My System SpecsSystem Spec
08 Oct 2012   #5
billybag

windows 7 64bit
 
 

At startup? no
My System SpecsSystem Spec
08 Oct 2012   #6
TVeblen

Microsoft Community Contributor Award Recipient

Windows 7 64 Bit Home Premium SP1
 
 

It sounds like the video card is not sending a signal to the monitor until Windows kicks in. This is highly unusual. I will see if I can find any info and get back if I find anything.
My System SpecsSystem Spec
08 Oct 2012   #7
billybag

windows 7 64bit
 
 

Thanks a bunch. I can do some googling of my own too once i get out of work.
My System SpecsSystem Spec
08 Oct 2012   #8
TVeblen

Microsoft Community Contributor Award Recipient

Windows 7 64 Bit Home Premium SP1
 
 

Try this:
Start > Control Panel > Appearance & Personalization > Display
Click "Detect Displays"
Select the monitor (not the TV) and then make it your "Primary Display".

See if that does it.
My System SpecsSystem Spec
08 Oct 2012   #9
Sardonicus

Windows 7 Home Premium 64 bit
 
 

Try booting into the Safe Mode, reboot.
My System SpecsSystem Spec
11 Oct 2012   #10
billybag

windows 7 64bit
 
 

Im unsure what booting in safe mode is going to accomplish... the monitor is still going to be in hybernation mode and it is going to be difficult to start it in boot. I will have to look up the exact keystrokes since i cant see anything on my monitor...

my keyboard also takes a while to startup too i think. its hard to tell since i cant test it because i cant see whats going on!
My System SpecsSystem Spec
Reply

 How Can I Fix Long Monitor Startup Delay




Thread Tools





Similar help and support threads
Thread Forum
Win 7 x64, Long delay in launching All Applications
Problem solved, caused by Avast 7, fixed by installing latest Avast 7 RC(Beta 7.0.1412) Hi, I am using Windows 7 x64 on a pretty fast machine(2600k, 8GB RAM, GTX580), and suffering from a very weird problem, this problem appears only on a fresh install of Win 7, it was fine on my previous...
Performance & Maintenance
Slow SSD Boot with long OtherKernelInitDuration delay
I built my first SSD based PC last week and was blown away by how fast it booted into Windows. After a few days, however, my boot times became noticeably slower, rising from around 18 seconds to 42 seconds according to Windows Diagnostics-Performance logs. On further inspection, I discovered...
Hardware & Devices
Long Delay Between POST and OS Integration
This is probably an Intel problem but since Intel no longer supports my MoBo, here goes. Intel 82801GH I/O Controller Hub (ICH7DH) SATA Controller in IDE mode. W7, SP1, Home Premium, 32 bit. Plextor DVDR PX-L890A ATA Device. HD and CD-ROM both connected to black connectors on Intel D975XBX2 MoBo....
Hardware & Devices
Extra Long Delay In Connect Time?
I can't figure out why I have such a delay in my computer being able to connect. Once I start up, the white bars will show instantly, sometimes with the yellow mark in them, sometimes not. Even if the white bars show up instantly I still cannot connect. It takes like 30 to 60 seconds until I can. I...
Network & Sharing
Long delay from downloads/uploads
Hi to all, Regulars here will probably have seen this problem before, but I read through the first several pages and didn't see it addressed there. I just got a Win7 computer (Toshiba portege r700-s1310) and when I try to download a file or upload anything, either, I get a 30 second (or so)...
Network & Sharing
Incredibly long delay from long on to desktop
I just installed a clean version of Win 7 Pro on my Thinkpad X200. Everything is great except for one small problem: there is a 25-30 second wait between the time i enter my logon pw and the time my desktop appears. This is highly unusual for several reasons. First, it doesn't "appear" as though...
Installation & Setup

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 18:24.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App