Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.



Windows 7: WD external not showing any files or folders, Sure it has stuff on it

10 Oct 2012   #1

Windows 7 Home Premium x64
 
 
WD external not showing any files or folders, Sure it has stuff on it

Hi, I've had this Western Digital 1 TB External Hard drive since mid 2010 and have had no issues till now.

It has 700-800 gb of stuff, basically all my stuff on it. Earlier I was setting up a lan game so I plugged my external into a friends brothers laptop to copy the game across. It all worked fine and ran smoothly up until I left. (he has a bad history of viruses )

When I restarted my laptop and plugged in the external hard drive microsoft security essentials detected the virus "dorkbot!ink" and I let it be removed. I then went to access the wd external and when clicked on it opened and there were no files or folders apart from a folder called "RECYCLER" and a file called "Datainfo.cfg". At this point I assumed that the virus had deleted all my files on the hard drive with the "Recycler" and was "fake" showing my hd was full with "Datainfo.cfg".

The only reason I'm not sure is because when I deleted the "RECYCLER" folder and "Datainfo.cfg" (I shouldn't have deleted these ) the hard drive still seemed to have the data on it (It showed full in My Computer). Also when I was playing itunes I can still play songs that were on the external hd which wouldn't work if the directory was gone would it?.

I'm not sure how to access it all again if it's possible, what should I do now?
I'd appreciate any help or tips people could give me.

P.s In folder options all hidden files are set to show so they're not hidden

I've attached a couple of pictures if that helps

My System SpecsSystem Spec
.

10 Oct 2012   #2

Windows 7 Home Premium 32 bit
 
 

OK. Try this.

Download the executable portable version of Re-Enable II from Downloads

Run it. In the program GUI click on Tools> Scan and delete Autorun.inf.

This will scan all all the drives and show all the Autorun.inf files.

Name:  Re-Enable.jpg
Views: 9
Size:  92.9 KB

Select only the Autorun.inf files on your external drive recognised by its drive letter (say G: ) and click on "Delete Selected"

In the second step though there is a "Reset folder/files attributes" in the Tools menu as a matter of abundant caution, I would prefer to do it manually by the attribute command.

Start > Run > type cmd and click on OK.
If your external drive is G:
Enter this command: attrib -h -r -s /s /d g:*.* (Press ENTER)
Check to see whether all your folders and files are accessible.


My System SpecsSystem Spec
10 Oct 2012   #3

Windows 7 Home Premium x64
 
 

Hmm, I sorta understand what you're getting at with the autorun.

When I did the scan to find the "Autorun.inf" files when it completed there were only a few on the actual disk, and none of those had to do with any software or anything that seemed to be the hard drive or had to do with running it.

I used the attribute command and none of the files reappeared.

If the autorun on the hard drive is buggy or possibly deleted, I can see how it might not display any of the content on the hard drive (I'm not sure why the disk would even show up at all)

I used the recovery program "Recuva" to see if I could restore any lost data if it was deleted. After the scan finished I couldn't see anything deleted that was still on the hard drive to my knowledge. I'm trying it again to see if there are any deleted files that are needed to run the hard drive properly.

I appreciate the help, now it might just be something wrong with the files that run the hard drive rather than everything being deleted. I may not have to format it yet.
My System SpecsSystem Spec
.


10 Oct 2012   #4

Windows 7 Home Premium x64
 
 

Yay, resolved.

The virus must have changed all the files and folders into "protected operating system" files/folders, which were still hidden on the hard drive and for some reason I had not unchecked that box in folder options.

After it had changed the files/folders it made shortcuts to them all and that's what was deleted at startup making it appear blank. Once I could see all the files I just had to make new non hidden folders with the same names as the Hidden ones and copy all the files from them across.

No more plugging in my external with all my stuff into everyones pc/laptop from now on.
My System SpecsSystem Spec
10 Oct 2012   #5

Windows 7 Home Premium 32 bit
 
 

Good to know that.
My System SpecsSystem Spec
Reply

 WD external not showing any files or folders, Sure it has stuff on it





Thread Tools



Similar help and support threads for2: WD external not showing any files or folders, Sure it has stuff on it
Thread Forum
Files Disappearing from Folders on external (USB) disks General Discussion
Video files not showing up in folders Media Center
Solved computer showing folders and files that no longer exist? General Discussion
Make folders/subfolders on external for image files? Backup and Restore
Windows not showing files moved to external drive. General Discussion
Folders and Files Not Showing Up Until Refreshed General Discussion
browse in software showing folders but not files General Discussion

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 09:36 AM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33