Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: USB 3.0 not working?


13 Oct 2012   #1

Windows 7 64 bit Home Premium
 
 
USB 3.0 not working?

Ok so my USB 3.0 isn't working. When I plug in my iphone it doesn't charge it or show up on computer, but it does when I plug into my other usb ports
Do I need specific drivers or something?
It worked on my old install of windows, Then I installed a SSD and now it doesn't?

My System SpecsSystem Spec
.

13 Oct 2012   #2

Windows 7 Ultimate x64 SP1, Windows 8.1 Pro x64
 
 

Yes you must install USB 3.0 drivers.You can get them from here.

http://www.gigabyte.us/products/prod...px?pid=4315#dl

Do you have any exclamation points displayed in the Device manager?
My System SpecsSystem Spec
13 Oct 2012   #3

Windows 7 64 bit Home Premium
 
 

Quote   Quote: Originally Posted by pbcopter View Post
Yes you must install USB 3.0 drivers.You can get them from here.

GIGABYTE - Motherboard - Socket 1155 - GA-B75M-D3H (rev. 1.1)

Do you have any exclamation points displayed in the Device manager?
well where would i extract the driver?
My System SpecsSystem Spec
.


13 Oct 2012   #4

Win 7 Pro 64-bit 7601
 
 

on Desktop? then inside the folder there should be some kind of installer that does the leg job. Called "Setup" or somesuch.
My System SpecsSystem Spec
13 Oct 2012   #5

Windows 7 64 bit Home Premium
 
 

still doesnt work..
My System SpecsSystem Spec
13 Oct 2012   #6

Win7 Pro 32-bit, Win8 Pro 32-bit
 
 

Encountered a similar problem with my Gigabyte Mobo. What I had to do was Google for Renesas USB 3.0 drivers -- and then, using the "dev" info from Device Manager for the USB 3.0 hub, select the correct drivers AND firmware update from the site. Once I applied the firmware update and then used the downloaded drivers, I got full USB 3.0 support.
My System SpecsSystem Spec
14 Oct 2012   #7

Windows 7 64 bit Home Premium
 
 

Quote   Quote: Originally Posted by Mark Phelps View Post
Encountered a similar problem with my Gigabyte Mobo. What I had to do was Google for Renesas USB 3.0 drivers -- and then, using the "dev" info from Device Manager for the USB 3.0 hub, select the correct drivers AND firmware update from the site. Once I applied the firmware update and then used the downloaded drivers, I got full USB 3.0 support.
could you please link me?
My System SpecsSystem Spec
14 Oct 2012   #8

Microsoft Community Contributor Award Recipient

Windows 7 Ultimate 64
 
 

Also double check in bios that usb 3.0 is enabled.
My System SpecsSystem Spec
14 Oct 2012   #9

Windows 7 64 bit Home Premium
 
 

Quote   Quote: Originally Posted by linnemeyerhere View Post
Also double check in bios that usb 3.0 is enabled.
It is.. I need a link to what the guy said above I'm not sure which one
My System SpecsSystem Spec
15 Oct 2012   #10

Microsoft Community Contributor Award Recipient

Windows 7 Ultimate 64
 
 

Here's a link but I can't tell you which one or where you want to go from here. The good news is any driver update or changes if not liked you can always roll it back and start again.
USB Driver | Renesas Electronics America
My System SpecsSystem Spec
Reply

 USB 3.0 not working?




Thread Tools




Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 09:14 AM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33