Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: CD Drive Issue: Burning @ 99% and Loop Locks


13 Oct 2012   #1

Windows 7 Home Premium x64
 
 
CD Drive Issue: Burning @ 99% and Loop Locks

I know this is going to sound strange, but my problem is something that started all at once.

Drives are often split between CD Read, CD Write, DVD read, and DVD right (others may pertain as well). I'm assuming something with the CD Read portion is what's going on. Here's the best I can explain it:

I have a TSSTcorp DVD+-RW TS-T633A SCSI CdRom Device. In My Computer, when properly working, shows my CD Drive (F:) and DVD Drive (G:). From what I understand, these are technically the SAME drive, just different ways the system looks at how it can read the data. When I put a DVD in, it will read/write from the DVD portion, and when I put in a CD (+/-) it should show up in the CD portion, which it usually did.

Now, if I put a DVD in, they work. The drive reads, burns, and has no issues with DVDs at all. If I put in a CD, it takes FOREVER for it to be recognized. However, when it finally does, it appears in the DVD portion of My Computer and says the standard 702MB/702MB free. The icon even changes to the CD-R label one.

Next, I can attempt to burn a CD-R as an Audio CD with Windows Media Player (for simplicity purposes). My drive has NO PROBLEM burning the files to the disc, (and no, max speed and 4/8x speeds haven't made a difference), yet when it reaches 99% it hangs. The drive slows down indicating the actual burn-process has finished, yet the last % is usually a Verification Step. It never completes and my drive keeps making 2 distinct pitch sounds roughly every 10 seconds (like the sound it makes right before it ejects when you hit the "eject" button).

If I wait long enough, WMP will show in the Burn screen to "Insert a Blank Disc" for burning even though the disc it just finished won't eject or finish it's current process. If I try and Right-click the DVD drive (which now shows the original icon and that no disc is in), I can click Eject. But then I get an error saying "An Error occurred while ejecting 'DVD Drive (G:)'." I can then shut down my computer, which will take roughly 10 minutes while the drive continues doing whatever, instead of the normal 20 seconds or so.

If I burn in iTunes, after awhile I just get an Unknown error (4000) and it'll eject the disc. I also had an Explorer error that said, "Application Not Found" if I tried to open my CD Drive (F:). I also have/had a Virtual Drive at Drive D and an External 1.5TB HDD (I:) and a USB Flash Drive that uses Drive E when it's plugged in.

To remedy the situation, I've tried several things such as:

-Deleting the Upper/Lower Filters @ HKEY_LOCAL_MACHINE>SYSTEM>CurrentControlSet>Control>Class>{4D36E965-E325-11CE-BFC1-08002BE10318} and @ ControlSet001 and 002.

-My Windows 8 x64 Release Preview install seems to read the CDs a bit quicker, but I still get the hang.

-I tried Disabling the Device Driver in Device Manager for the Drive, Uninstalling the Driver, and then Rebooting the computer.

-I tried Updating the Device Driver (I'm already using the current version) and I also Upgraded the Firmware on the Drive, to no avail.

-Fixed the "Application Not Found" error by deleting "F" folder @ HKEY_CURRENT_USER>Software>Microsoft>Windows>CurrentVersion>Explorer>MountPoints2. It probably had something to do with Drive Letter assignments and my Virtual Drive being off and the system reassigning my CD Drive to F and it kept getting the error.

Other than that, I can't find anything else on this. I tried going to Dell's website and running the Diagnostics for it, but it kept wanting a CD to test with, but my system just can't detect it so I kept skipping the CD segments. It did fine on DVD segments, but afterwards it said it noticed what MAY be a hardware issue on the initial tests of the physical parts of the drive. That didn't help because it said that for all 5 or 6 test areas =/

Anyone have any thoughts?

My System SpecsSystem Spec
.

Reply

 CD Drive Issue: Burning @ 99% and Loop Locks




Thread Tools



Similar help and support threads for2: CD Drive Issue: Burning @ 99% and Loop Locks
Thread Forum
USB Flash Drive power issue? (connect/disconnection loop) Hardware & Devices
Infinite startup loop issue General Discussion
Burning iso file issue General Discussion
Windows 7 reboot loop issue. General Discussion
Quality issue after burning a DVD from a YouTube video Music, Pictures & Video
Win7 with BR burning/encoding issue General Discussion
Win7 locks up/laggs hard due to graphics/video issue General Discussion

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 07:38 PM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33