Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: I think I killed my SATA Drivers

04 Nov 2012   #1

Windows 7 Ultimate x64
 
 
I think I killed my SATA Drivers

Now, I've been trying to set my SATA Controller into IDE mode. I've seen all these ways of changing the registry to get it to switch from the AHCI to IDE, but none of them seemed to work. I saw this one program from this one website (mydigitallife.info I think) that said it would easily change the bit from AHCI to IDE and vice versa. It seemed to work, it said to restart. I restarted, and it seemed it had worked (it had booted much farther than usual) but then it blue screened just like it does without it. But then I tried to go back to AHCI and it blue screens again. The odd thing is, in AHCI mode, it would blue screen at the same time as IDE mode without running the program, but in IDE mode it got further. I tried startup repair, all it could come up with was that there was a bad driver (that helps a lot....). I tried repair from the windows install disc, it said the version of repair on the disc was not compatible with the version installed. The most it could do was repair my old windows partition on a separate drive (I thought I made that completely un-bootable). So now I am stuck.

You think there is any easy way to fix this? Maybe installing the default Windows drivers or repairing the drivers somehow? Or do you think it would be better to try to do a Windows 8 upgrade? Would it keep all my programs and settings somewhat they way they are?

My System SpecsSystem Spec
.

Reply

 I think I killed my SATA Drivers




Thread Tools



Similar help and support threads for2: I think I killed my SATA Drivers
Thread Forum
Win 7 and SATA drivers Installation & Setup
Replacing SCSI storage drivers with IDE or SATA drivers Drivers
USB/Net drivers killed by Windows 7 auto update, unfixable? Drivers
SATA Drivers for XP 64-Bit? Drivers
Sata -IDE drivers Drivers
SATA Drivers Installation & Setup
SATA Drivers? Drivers

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 07:10 PM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33