Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: New Turtle Beach PLa Headset not detected

04 Nov 2012   #1
Spetznaz586

Windows 7 Home premium 64 bit
 
 
New Turtle Beach PLa Headset not detected

Hey, yesterday i bought a new turtle beach PLa headset for a PS3, but on the back it said that they are PC compatible. When i plugged them in, they worked fine for the first night, but the next morning, my computer doesnt detect the headset being plugged into the usb port, I've updated, and re installed the drivers with no success, and when i go into the sound icon for playback devices, theyre are shown but underneath it says Not plugged in, i have no idea on what to do, so any help would be greatly appreciated, Thanks!


My System SpecsSystem Spec
.
04 Nov 2012   #2
Spetznaz586

Windows 7 Home premium 64 bit
 
 
Possible solution

I did a computer restore after a while, it seems to have fixed the problem, my computer wasnt recognizing my mouse either so i panicked and did a restore. I think i may have installed/downloaded something dodgy
My System SpecsSystem Spec
Reply

 New Turtle Beach PLa Headset not detected




Thread Tools Search this Thread
Search this Thread:

Advanced Search




Similar help and support threads
Thread Forum
Turtle Beach Santa Cruz
Apologies in advance if this topic has been covered recently. I looked. I've got an old Santa Cruz PCI audio card mostly installed in Windows 7 SP1. If it matters the system is an Abit IC7G (P4 Northwood, with no PCIe). Works fine for playback, but the card's inputs for recording (line, aux...
Sound & Audio
I cant hear Audio on my Turtle Beach x31 headset...
Hey, sorry if I posted this in the wrong category So I bought the cable for the Turtle Beach x31 headset so I could use it for my PC. Well the mic works but I cant hear anything through the headset. I'm not sure how to fix it so now I'm here. Any fixes? Thanks! Edit: I tried plugging in...
Sound & Audio
Turtle Beach Z60 Headset Refuses to Play Surround Sound
Currently I have just gotten the Turtle Beach Z60 Surround Sound Headset for Christmas. I have plugged the USB into the front of the PC Tower and have configured it correctly. However, when it told me to configure the headset's speakers for surround sound, it wouldn't play any of the test sounds....
Sound & Audio
Problems With Turtle Beach Ear Force Z2 Gaming Headset
Ok, so I just bought this headset a few days ago. There's nothing wrong /w it, but I am having a few issues and couldnt find an official TB support forum after Googling. My first issue is that sometimes the audio plays through both the headset and the speakers of my laptop. This is annoying when...
Sound & Audio
Turtle Beach Montego DDL + 5.1 vs Windows Seven
Like I said I have a Montego DDL, everything worked fine on XP with of course the corresponding XP drivers, however now using Seven with Vista drivers I'm having difficulties with my surround speakers. I can't get the surround speakers to do anything using windows media 12; however i've never been...
Sound & Audio
Turtle Beach AA SRM Crashes
I installed the Turtle Beach Audio Advantage SRM external USB sound card and as soon as it re-booted back, it crashed the system. I used the Vista drivers from the site. I disabled onboard drivers in safe mode and it crashed as well. No Windows 7 drivers available from TB at this time. ...
Sound & Audio


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 03:25.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App