Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: USB ports problem - seeing unidentified devices, disconnecting mouse

19 Jan 2013   #1

Windows 7 Home Premoum 64bit
 
 
USB ports problem - seeing unidentified devices, disconnecting mouse

Problem:
I have Logitech Performance MX mouse. It used to work fine until somebody installed other mouse on my computer. Since then mouse was randomly disconnectign and reconnecting every minute.

I managed to fix that now mouse is stabile but even though all drivers are installed it is seen as HID mouse and not my Performance mouse - so i cannot for example see its level of batter load.

The other problem is there is loads of extra identified USB controlers and mouses even tho i have just connected 1 mouse, 1 keyboard by other USB port + 1 external HDD. Thats just 3 USB slots total.

If i put pendrive into computer, then mouse keeps disconnecting again.
If i turn on 'shield scannign devices' then after puttign USB into drive i have 3 seconds to click 'not scan it' if i do that, it wont be disconnecting. Yet turning off scanning makes mouse disconnecting on putting extra pendrives.


Here is what i tried so far:
@ USB Driver - General Fix for Problems [after reboot everything comes back gryed out, again 10s of mouses]
@ Turning off windows shell scan [to not auto scan devices].
@ Chaning ports, upgrading bios etc.
@ RUnning windows 7 USB problem fixer. It is turning off upper and lower shell that sometimes seem to help but after reboot all gets back to original state.

Here is screens of my drivers/devices:
http://i.imgur.com/LUmlv.png
http://i.imgur.com/1g5bQ.png
http://i.imgur.com/uebIp.png


All drivers are updated.

This is very annoying.

My System SpecsSystem Spec
.

19 Jan 2013   #2

Windows 7 Home Premoum 64bit
 
 

1 morei nterestign thing:
if i put USB pendrive to any usb port mouse will disconnect and be 'unknown device' but if i put pendrive to USB 3.0 port [port where i never installed anything] it will work.

is there any way to fully reset all USB port setups and make them clear? i have jusm ouse keyboard and hdd. and it seems some reg file stored corrupted data and it cannot be uninstalled in device manager.
My System SpecsSystem Spec
Reply

 USB ports problem - seeing unidentified devices, disconnecting mouse




Thread Tools



Similar help and support threads for2: USB ports problem - seeing unidentified devices, disconnecting mouse
Thread Forum
Solved Mouse Consistently Disconnecting Hardware & Devices
USB 3.0 ports not reading 2.0 devices Hardware & Devices
All USB ports don't recognized usb drives but do see other devices Hardware & Devices
Mouse keeps disconnecting and reconnecting Hardware & Devices
USB ports only recognizing certain devices Hardware & Devices
USB 3.0 Ports Not Working with USB 3.0 Devices Hardware & Devices
USB Mouse disconnecting and reconnecting Hardware & Devices

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 09:30 PM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33