Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Problem with USB port

18 Oct 2009   #11

Windows 7 Professional x64
 
 

I wonder if Windows 7 was trying to find the driver and before it found it you tried to use the drive. Now that it has found it everything is okay. It's a possibility. Glad everything is good now.


My System SpecsSystem Spec
.

19 Oct 2009   #12

Windows 7 Ultimate x64
 
 

Hate to be a party pooper but "Unknown Device Is Back Again"

This is becomming very, very frustrating. I think I will go back to Vista for awhile
My System SpecsSystem Spec
19 Oct 2009   #13

Windows 7 Ultimate x64 SP1
 
 

Quote   Quote: Originally Posted by Timewarpone View Post
Hate to be a party pooper but "Unknown Device Is Back Again"

This is becomming very, very frustrating. I think I will go back to Vista for awhile
10 usb ports seem to be quite a few. I would recommend seeing if your motherboard manufacturer has a BIOS update or just unplug the USB device and plugging it into a different port.

Good luck!

Snarks
My System SpecsSystem Spec
.


19 Oct 2009   #14

win XP/Win7
 
 
USB device problem with win 7.

I have a Gigabyte Mobo, I have unplugged all devices, updated the Mobo bios and I still get the "Unknow device" with the yellow triangle. Even with all the USB ports cleared I get that error in the Device Manager. We have to keep at it and get a solution.
My System SpecsSystem Spec
19 Oct 2009   #15

windows 7 hp 64bit
 
 

hey i had the same thing but it was my wireless network that said unknow device go back in to device manager go down to usb controllers and click on every usb root hub and go to properties and look for power managment and untick allow computer to turn this device off to save power this is what was up with mine hope it's same for you to
My System SpecsSystem Spec
19 Oct 2009   #16

Vista Ultimate X64/ Windows 7 Dual-boot
 
 

Keep in mind that front USB ports on many machines are notoriously underpowered...
This unfortunately happens with all manuf.
My System SpecsSystem Spec
20 Oct 2009   #17

Windows 7 Ultimate x64
 
 

Well I don't know what to say or believe any more. Right now the "Unknown Device" disappeared again from the device manager and I am not even using the USB port that started it all. I realize that I have 10 available usb ports but I only have 2 printers, 1 web cam a USB wireless keyboard/mouse combo a document scanner and a removeable flash drive and a memory card reader. My Dell monitor (1908fp) has a built-in 4 port usb hub which is also hooked up to the back of the case but I never use it. I keep forgetting it is there. All usb devices. They are never used at the same time except for the Microsoft USB wireless/mouse combo. Everything is hooked up to the rear of the case except when I use the flash drive or memory card reader in the front of the case. How about the next time "Unknown Device" appears in the device manager I uninstall it?? Is it worth a try?? Also my motherboard BIOS driver is up to date
My System SpecsSystem Spec
20 Oct 2009   #18

Win7 Build 7600 x86
 
 

Quote   Quote: Originally Posted by Timewarpone View Post
Well I don't know what to say or believe any more. Right now the "Unknown Device" disappeared again from the device manager and I am not even using the USB port that started it all. I realize that I have 10 available usb ports but I only have 2 printers, 1 web cam a USB wireless keyboard/mouse combo a document scanner and a removeable flash drive and a memory card reader. My Dell monitor (1908fp) has a built-in 4 port usb hub which is also hooked up to the back of the case but I never use it. I keep forgetting it is there. All usb devices. They are never used at the same time except for the Microsoft USB wireless/mouse combo. Everything is hooked up to the rear of the case except when I use the flash drive or memory card reader in the front of the case. How about the next time "Unknown Device" appears in the device manager I uninstall it?? Is it worth a try?? Also my motherboard BIOS driver is up to date
Even if they are not being used, they will suck up energy.

Have you tried disconnecting that monitor hub.
Hubs are known to present problems.

I haven't read through the whole thread, but did you already updated your bios?
It might even be a design flaw or malfunction of the board.

Hard to tell.
My System SpecsSystem Spec
20 Oct 2009   #19

win XP/Win7
 
 

I tried to untick the box in power management, the yellow warning is still there.
Windows has stopped this device because it has reported problems. (Code 43)
My System SpecsSystem Spec
22 Oct 2009   #20

Windows 7 Ultimate x64
 
 

I think I finally fixed my USB problem (I Hope) I upgraded my Motherboard BIOS to the latest version. I disconnected my USB Hub and no longer using it. I also didn't realize I had a another USB 2 port hub in one of the PCI slots that was wired to the motherboard. It came with the motherboard when I purchased it (ASUS P5K-E). I discovered that this extrenal USB port is not compatible with 64 windows. I ran safe mode and there was a critical error in the event viewer. Also there were 2 other warnings that my USB mouse/keyboard (Microsoft product) was marginally compatible with 64 bit windows 7. I tried to download the correct drivers from the Microsoft web site for the mouse/ Multimedia keyboard and it seemed to do the trick. I would have never known about the USB problems without running safe mode. I guess sometimes the windows update drivers don't always work. I stopped the automatic upgrades from Windows update so nothing is updated with me knowing about it. Go to Device & printers in control panel and right click on the PC Icon then "Device Installation Settings" and make your choices about what to receive from Windows update. So far so good. "Unknown Device" is now gone for 72 hours now. I hope for good.
My System SpecsSystem Spec
Reply

 Problem with USB port




Thread Tools



Similar help and support threads for2: Problem with USB port
Thread Forum
USB port problem Hardware & Devices
Sata Port Multiplier Problem. Drivers
Dual Monitor DVI port problem Graphic Cards
USB Port Problem Hardware & Devices
Port problem since 7 Network & Sharing
IE 8 and port 80 problem Browsers & Mail
Problem in Opening Port System Security

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 07:09 PM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33