Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Peripherals Issue (Run as Administrator)

25 Feb 2013   #1
BuzWeaver

 
 
Peripherals Issue (Run as Administrator)

After loading Razer Keyboard/Mouse Drivers and or loading LogiTech Mouse drivers, everything works great till I reboot. The only work around we were able to come up with was to go into the particular software shortcut, either Razer or Logitech Right Click>Properties>Compatibility>Run this program as administrator. Reboot. Open the software by Right Clicking>Run as administrator. This process has to be done "each" time the computer is rebooted "and" the kicker, its often times intermittent.

The Microsoft Tech said its a Peripheral Compatibility issue, Logitech and Razer say its a Win7 issue, so the classic conundrum. After working with each of these, the long story short is the only way the Razer BlackWidow Ultimate Keyboard/Razer Tiapan or the LogiTech G700 will work is by the following the method mentioned above.


My System SpecsSystem Spec
.
27 Feb 2013   #2
ICIT2LOL

Desk1 7 Home Prem / Desk2 10 Pro / Main lap Asus ROG 10 Pro 2 laptop Toshiba 7 Pro Asus P2520 7 & 10
 
 

Hello BuzzWeaver mate have you tried updating the USB ports drivers software through the Device Manager?
My System SpecsSystem Spec
27 Feb 2013   #3
BuzWeaver

 
 

Yep, and it said The Best Driver Software For Your Device Is Already Installed.
My System SpecsSystem Spec
.

27 Feb 2013   #4
ICIT2LOL

Desk1 7 Home Prem / Desk2 10 Pro / Main lap Asus ROG 10 Pro 2 laptop Toshiba 7 Pro Asus P2520 7 & 10
 
 

Hum wondering Buzz have you tried hooking up a wired keyboard and / or mouse? - simply out of curiosity to see if the problem stays the same.

Thing is like you say they are both telling you it is the other that is at fault which is pretty poor support in my mind.

Anyway see if the above does any better even another wireless set up as I am tending towards something to do with the OS because I have never had a mouse or KB that sets off this sort of conflict.

Just as an afterthought I am wondering if this maybe an issue with the motherboard USB drivers

Just for reference they are here -

http://www.asus.com/Motherboard/RAMP...RMULA/#support
My System SpecsSystem Spec
28 Feb 2013   #5
BuzWeaver

 
 

I've tried different peripherals and it does the same thing. It really appears as though its a Win7 issue, where its happening I don't know. I couldn't even tell you when or near about when it became more pronounced.
My System SpecsSystem Spec
28 Feb 2013   #6
essenbe

Windows 7 Enterprise X64/Windows 10 Enterprise X64/Windows 10 Pro X64/Linux Mint
 
 

I'm not sure I can help you. I have a Logitech G510 keyboard and a G500 mouse. Both are wired, but the logitech software does not require me to do that. Try and see if this helps. Hold down the windows key (the one with the flag on it) and press 'R' which should give you a run box. Type msconfig in the box and click OK. Click the startup tab, and place a check mark next to both items. That will require them to load at startup of the computer, you will have to provide admin permission and reboot. See if that helps.
My System SpecsSystem Spec
28 Feb 2013   #7
BuzWeaver

 
 

Yep Essen, I've done all that. Actually I've exhausted all my Windows knowledge along with my brother-in-law and guys on the CyberTech Forum as well as my gaming guild mates. Everyone has had a crack at resolving this, coming here was my last ditch effort, well, that and a Format Reload, which I prefer to avoid.
My System SpecsSystem Spec
28 Feb 2013   #8
ICIT2LOL

Desk1 7 Home Prem / Desk2 10 Pro / Main lap Asus ROG 10 Pro 2 laptop Toshiba 7 Pro Asus P2520 7 & 10
 
 

Well Buzz looks like the bottom of the ditch mate and it is going to sound like the bleeding obvious but have you tried reseating the RAM sticks a memtest or even checking the PSU out (at least for volts) I am thinking just maybe the USB ports are not getting enough juice to them?
My System SpecsSystem Spec
02 Mar 2013   #9
BuzWeaver

 
 

I'm finished bug hunting and researching. I appreciate the input. As for now everything is working, although I'll have to run the Razer Synapse in Admin mode each reboot.
My System SpecsSystem Spec
Reply

 Peripherals Issue (Run as Administrator)




Thread Tools Search this Thread
Search this Thread:

Advanced Search




Similar help and support threads
Thread Forum
Peripherals Shut Down with computer still on.
So I ran virus scans I doubt this is the problem, but the monitor goes black in a middle of a game most the time when playing leauge or hearthstone. Sometimes when browsing I think one time while doing nothing. Usually happens anywhere from 1 to 5 hours and happens frequently 3-4 times a day, some...
Hardware & Devices
Windows 7 not detection any bluetooth peripherals.
I have searched dozens of forums post even remotely pertaining to this issue but the solutions posted never fix my issue. So here is the story and I will be honest cause I'm pretty sure my problem is of my own making. Bought sony DRBTN200 bluetooth headphones for my sony xperia V ultra and...
Drivers
USB cables could power PCs, peripherals
Read more at source: USB cables could power PCs, peripherals | Business Tech - CNET News
News
How to change an icon in printers and peripherals?
How to change an icon in printers and peripherals? Hello, How does the management of devices and printers icons, the icon is awarded based on the pilot? Manage the register? do you think it is possible to change such an icon? Because I installed 2 printers of the same type (MPT) but 2...
Hardware & Devices
Administrator Rights issue
I tried to install Soni drivers in my dell inspiron. since it does not have admin rights it throws an exception so i have enabled the administrator rigths. this was the steps to do... 1. In command prompt c:> net user Administrator /active:yes Now I am able to login through...
Drivers
USB External Drive / Peripherals Issues
Hi, I am having issues with data transfers using a external HDD. My current operating system is Windows 7 Ultimate. I have used the drive on other machines that are not running windows 7 and it operates flawlessly. But when connected to the windows 7 machine I can read the first directory with no...
Hardware & Devices


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 05:50.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App