Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: CD ROM Drive is not working, just changed it please help

06 Mar 2013   #1
Laura88

Windows 8 64 bit
 
 
CD ROM Drive is not working, just changed it please help

I found out recently my CDROM drive was bad, did not show in My Computer, did not open. I replaced it with a new drive, it opened one time. Will not open again, does not show a light, nor run any disk. When i force eject it, it just spins and spins, pauses then continues continuously. This is not on my PC but on my moms, she has a Dell Inspiron One I think. I checked the connections again this morning, they seem to be tight, I unplugged and replugged to make sure to no avail. Please help, I have been researching, downloading, checking. This is getting really frustrating. In my computer all I show is C:\ and Q:\


My System SpecsSystem Spec
.
06 Mar 2013   #2
TVeblen

Microsoft Community Contributor Award Recipient

Windows 7 64 Bit Home Premium SP1
 
 

Do I understand correctly that you have tried this optical drive in both yours and your mom's computer and it is not recognized in both?

Is it the same software disk you are trying in the drive in both computers? What happens with a different disk?
My System SpecsSystem Spec
06 Mar 2013   #3
Laura88

Windows 8 64 bit
 
 

No I am trying to fix my moms computer. It's her CD ROM that went bad in her computer, that I replaced.
My System SpecsSystem Spec
.

06 Mar 2013   #4
VistaKing

Windows 7 Ultimate 32-Bit & Windows 7 Ultimate 64-Bit
 
 

Does the CD-ROM show up in BIOS ?

Note   Note
Press F2 on the Dell splash screen to get to the BIOS
My System SpecsSystem Spec
06 Mar 2013   #5
TVeblen

Microsoft Community Contributor Award Recipient

Windows 7 64 Bit Home Premium SP1
 
 

If you can test to be sure the CDROM drive works in another computer that would narrow down the list of possible causes considerably. If you can't (laptop for instance) then we can try other things.

The first thing to check is the old Upper filters problem.
The CD drive or the DVD drive does not work as expected on a computer that is running Windows Vista

Tell us what you find.
My System SpecsSystem Spec
06 Mar 2013   #6
Laura88

Windows 8 64 bit
 
 

I deleted the filters I found, per another forum, it did not work.
Can you explain more on BIOS
My System SpecsSystem Spec
06 Mar 2013   #7
VistaKing

Windows 7 Ultimate 32-Bit & Windows 7 Ultimate 64-Bit
 
 

Hi Laura can you provide me the Service Tag number of the machine please
My System SpecsSystem Spec
06 Mar 2013   #8
Laura88

Windows 8 64 bit
 
 

18l7nq1
My System SpecsSystem Spec
06 Mar 2013   #9
TVeblen

Microsoft Community Contributor Award Recipient

Windows 7 64 Bit Home Premium SP1
 
 

On a Dell I think the key is F2.
Restart the computer and just as it is starting up, repeatedly press the F2 key. This should open up the BIOS Settings.

On the first page of the settings (Main) there should be a list of connected devices. Check here to see if the CDROM is listed.

Note: the mouse will not work in older BIOS. You use the arrow keys to navigate. When done checking use the TAB key to move over to the EXIT Tab and use "Exit discarding changes" to reboot the computer.
My System SpecsSystem Spec
06 Mar 2013   #10
VistaKing

Windows 7 Ultimate 32-Bit & Windows 7 Ultimate 64-Bit
 
 

This being the ALL-IN-ONES and uses standard SATA an SATA power cables did you try plugging it into a regular PC ? The BIOS after you pressed F2 you should get to a screen with the menu items of MAIN , ADVANCED , SECURITY , BOOT and EXIT . If you go to MAIN settings do you see anything with the word SATA displayed should be something like SATA 0 is your hard drive SATA 1 should be your optical drive
My System SpecsSystem Spec
Reply

 CD ROM Drive is not working, just changed it please help




Thread Tools Search this Thread
Search this Thread:

Advanced Search




Similar help and support threads
Thread Forum
External Hard Drive (F) Drive Letter changed to G - Can't change back
My External Hard Drive (My Book) was always Drive letter F. I went to sleep and woke up to find Windows 7 Pro had updated and rebooted and I was welcomed by my login screen. Consequently now my My Book external HDD now reads as Drive letter G. I went into Administrative Tools > Computer...
Hardware & Devices
I changed permissions of a drive but now 'drive is not accessible'
I was trying to deny access of an external hard drive to other users on my PC but I have somehow managed to deny access to everyone including myself. I right clicked on the drive then: > Security > Advanced > Change Permissions > Edit My memory is a bit fuzzy what I then did, but I think I...
Network & Sharing
External Hard Drive - Drive Letter changed - unable to change back
I have a USB external hard drive that I keep all my documents etc on (had it for years) I upgraded from Vista Home to & Home Premium then had to upgrade recently to Professional to run my Sage. Through all these upgrades my ext. drive ran fine. Occasionally the drvie letter would change if I...
Hardware & Devices
logon background changed but not working
hi guys. as per title, ive tried ALL the steps here ; http://www.sevenforums.com/tutorials/5382-log-screen-change.html the changes are said to be successful according to the softwares, but when i tested by restarting or ctrl+alt+del, it doesnt work; the logon background is still the standard...
Customization
Accidentally changed hard drive with OS to dynamic drive.startup fail.
Hi. My laptop is Acer with Windows 7 home premium 64 bit OS. It contain only 1 single partition disk that is c drive only. Recently, i accidentally convert the c drive which contain OS into dynamic disk. After i restart the laptop, it shows the following: BootMgr is missing Please press Alt,...
Installation & Setup
imap stopped working when I changed network
Hi, I recently did a fresh install of Windows 7 Enterprise 64bit at work. I installed it behind a nat:ed machine (internal IP), so nothing special about that one. I chose home network as the network type as I would be using the computer at home from now on. However to my surprise, when I got...
Network & Sharing


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 17:31.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App