Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: USB Devices Not Working (Code 39)

10 Mar 2013   #1

win 7 x64
USB Devices Not Working (Code 39)

Hi Guys -

Not sure what's changed over the last couple of weeks, but none of my external USB hard-drives or thumb-drives now work.

The same symptoms for my iomega, maxtor & WD external hard drives, and TDK / Transcend thumb-drives: -
  • plugin usb drive
  • "ba-dong" sound from Windows
  • no drive showing in Windows Explorer
  • go to Device Manager - yellow icon for usb drive
  • uninstall driver
  • re-install driver
  • "driver is up to date" message (tried online drivers & C:\Windows\winsxs)
  • no drive showing in Disk Management

In Device Manager, right clicking the USB drive > Properties > General Tab shows "Windows cannot load the device driver for this hardware. The driver may be corrupted or missing. (Code 39)"

I've tried all the suggestions on -

How To Fix Error Code 39 (Windows cannot load the device driver for this hardware)

Windows 7 - Notices but does not 'see' external usb hard drive

Have tried a System Restore, both from Windows when booted up, and from DVD on startup - System Restore fails each time, some message about Anti Virus maybe running (which didn't make sense when doing a System Restore from Disk)

I've checked there are no Upper / Lower values in the Registry key as per the links above, and also tried copying usbstor.sys / .inf / .pnf from Windows\System32 to Windows\inf.

And have uninstalled usb root hubs from Device Manager (to the pointwhere I only have the keyboard or mouse left, so I can reboot from the start menu)

Any ideas, any ideas at all would be bloody great.....!

Many Thanks,

My System SpecsSystem Spec

11 Mar 2013   #2

Windows 7 Ultimate 32-Bit & Windows 7 Ultimate 64-Bit

Is the USB ports inside the BIOS enabled ?
My System SpecsSystem Spec
11 Mar 2013   #3

win 7 x64

Hi VistaKing -

Yep - BIOS is enabled for USB, and finds a load of them on startup -

bios > integrated peripherals >

usb controller = enabled
usb device legacy support = enabled

Thanks, D
My System SpecsSystem Spec

11 Mar 2013   #4

Windows 7 Ultimate 32-Bit & Windows 7 Ultimate 64-Bit

You tried Uninstalling the USB controller from within Device Manger and restarting the PC and let Windows reinstall the drivers ?
My System SpecsSystem Spec
12 Mar 2013   #5

win 7 x64

Yep, done everything on the links above,

Disabled, Uninstalled Disks, Uninstalled root Hubs, no dice.

Restarted every time when I get to the point of keyboard / mouse left.

My System SpecsSystem Spec
12 Mar 2013   #6

Windows 7 Ultimate 32-Bit & Windows 7 Ultimate 64-Bit

When you install the driver do you have any " " inside Device Manager ?
My System SpecsSystem Spec
12 Mar 2013   #7

win 7 x64

Yes, with any usb drive I plug in, Yellow ! Triangle is shown in Device Manager > Disk Drives, next to the USB device.

As per my previous post - uninstalling / reinstalling the driver has no effect on this, still a yellow triangle.

My System SpecsSystem Spec
12 Mar 2013   #8

Windows 7 Home Premium 32 bit

Hi darren13,

Please go to my post #4 in this thread

Carry out the procedure detailed under 2. Replace the USB related files:

After rebooting plug in your USB device. Does it work now?

If not uninstall and reinstall the driver and check.
My System SpecsSystem Spec
12 Mar 2013   #9

win 7 x64

Hi -

Still the same after trying the above -

'ba-doom' when plugging in usb device, and yellow triangle in Device Manager....

My System SpecsSystem Spec
13 Mar 2013   #10

Windows 7 Home Premium 32 bit

And so I would believe that it may not be an issue of corrupted driver ( unless the driver in the Windows Repository itself is corrupted in someway.)

You seem to have done almost everything, including searching for the driver in winsxs.

Now I remember that once A Guy recommended to the OP to power cycle the PC and it worked.. So do it now.

1. I think yours is a desktop. Shut down your PC and pull out the plug from the Mains socket. Leave the PC off for about half-an-hour so that it dissipates all charges that might have built-up. For a good measure press the Power Switch on your desktop for about ten seconds. Then connect the mains power and boot your PC. (If it is a laptop, you will not only remove the mains power completely, but also remove the battery pack.) This worked magically for many users.

2. If that does not fix your problem, try the Microsoft USB Fix Tool. USB Fix It: Official Microsoft Tool To Repair Removable Device Issues

3. Finally carryout all the procedures I had outlined in my post I had referred in my previous post. You had done only the procedure 2. Now do 1. Removing all non-present devices and 3. Rebuilding the infcache.1 file.

If all this doesn't help as I said in that post,

"If after this complete USB rebuild, the problem is not resolved a repair install, I would think, is the only option left. "

I think that this has also been stated in the first article you had referenced in your first post.

If you do fix it by any other means, please let us know.

Note: Whenever a system malfunctions for reasons not known, it is customary to check the system for any malware. Have you done it?
My System SpecsSystem Spec

 USB Devices Not Working (Code 39)

Thread Tools

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 03:56 PM.
Twitter Facebook Google+

Windows 7 Forums

Seven Forums Android App Seven Forums IOS App

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33