Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: BitFenix USB3.0 Front Panel Giving USB2.0 Speeds

19 May 2013   #1
Boozad

W7 Pro x64 SP1 | W10 Pro IP x64 | W8.1 Pro x64 VM | Linux Mint VM
 
 
BitFenix USB3.0 Front Panel Giving USB2.0 Speeds

This one has been bugging me for a while and I was wondering if anybody could help me. I bought my rig (full spec to the left) a few weeks ago, it's an interim rig as my kids will be having it shortly when I upgrade to a full gaming rig, and I wanted to add USB3.0 ports to the front of the case so I installed a BitFenix USB3.0 front panel that offers two USB3.0 ports.

It installed fine but I've never got USB3.0 speeds out of it, both of my Kingston Data Travelers get 9/10mbs as does my Hitachi Touro Mobile external HDD. My motherboard is an ASUS F2A85-V Pro and I have the panel connected to the 19-pin header on the board. The header is an ASMedia XHCI controller and I've updated both firmware and drivers for it, although I did have to get these from elsewhere as ASUS don't have the most up-to-date drivers.
I'll have one more go at uninstalling it later and reinstalling using the motherboard disc, but beyond that I'm completely stumped.


My System SpecsSystem Spec
.
19 May 2013   #2
bobafetthotmail

Win 7 Pro 64-bit 7601
 
 

Hmm, did you check the BIOS if it has options for that? To access the BIOS, reboot your PC and as soon as you see its usual white text or an asus logo press Del a few times.

I'm having a look at the manual for your mobo. On the page about bios options of the USB you should have:

Legacy Usb support, that is for supporting old USB 1.1 devices. This shouldn't change anything.

Legacy USB 3.0 support, that is supposed to allow use of USB 3.0 on "legacy" operating systems, try enabling/disabling it and see if something changes.

Ehci hands-off, that is another thing that you can try enabling-disabling, theoretically Win7 shouldn't need it, but who knows, Bios on these details is always a tinkering-to-make-it-work affair.
My System SpecsSystem Spec
19 May 2013   #3
Boozad

W7 Pro x64 SP1 | W10 Pro IP x64 | W8.1 Pro x64 VM | Linux Mint VM
 
 

I did check in the BIOS first time round and didn't remember anything amiss so I've checked again and all looks like it's supposed to. The only thing that's disabled is the USB 3.0 Battery Charging Support which I'd never use. I've also toggled EHCI hand-off with no joy.

I'll keep plugging away.
My System SpecsSystem Spec
.

Reply

 BitFenix USB3.0 Front Panel Giving USB2.0 Speeds




Thread Tools Search this Thread
Search this Thread:

Advanced Search




Similar help and support threads
Thread Forum
Using both front panel audio and back panel: solutions
This possibly should go in the hardware forum since it involves the motherboard as well but being a sound issue I assume here would be better. I have an Asus Xonar DG sound card on an Asus P7P55D-E LX motherboard (and AMD Radeon HD 7800 Series video card) running on Windows 7 Home Premium...
Sound & Audio
How to disable read audio panel and make the front panel primary?
Hello. I am having a not so common issue of a problematic REAR audio panel jack. The microphone pin got stuck and broken into the rear/back microphone jack and now the OS/driver thinks there is a microphone in the back panel but I just want to be able to make the microphone work on the front panel...
Sound & Audio
USB3 card - USB2 Iomega HD - autoplay issue from sleep mode
I am running a HP P6228p desktop Win7 64bit Home Premium with all MS and HP updates applied. I installed a 2-port Sabrent PCI USB3 card, installed the driver for it from the web (Win7 failed to find an appropriate driver on its own) and moved my Iomega USB2 external HD from a USB2 port where if...
Hardware & Devices
USB3 2.5" not working on USB2
Hi, i recently bought a USB3 2.5" 1TB toshiba drive and it works fine on my USB3 ports but it doesn't work on my USB2 ports. Non of the people i have asked seem to know why. i Have 3.5" usb3 2TB that works on both USB3 and USB2, so the only thing i can think of is that the 2.5" draws more power...
Hardware & Devices
Need Quality Usb3 card and front hub setup
I need a GOOD usb3 card and front bay hub for my computer. Bought a SIIG SuperSpeed USB 3.0 Bay Hub+Host Kit Model JU-H40411-S1 back in Nov but have had major problems with it from day one and now believe it was partially responsible for trashing my Enyo and SuperTalent RC8. Over a month now of...
Hardware & Devices
Only my external hard drive hits USB2.0 speeds
In the past month I have added a new external hard drive, replaced my main hard drive, and replaced my power supply. When I added the new external hard drive, I used a USB2.0 thumb drive to move some files also and I got normal speeds on it. A couple weeks after that (last week), I replaced my...
Hardware & Devices


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 08:24.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App