Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Two USB ports not working


24 Jun 2013   #1

Windows 7 Home Premium 64-bit
 
 
Two USB ports not working

Hello! I have a bit of a problem. I have an Acer Aspire 5733Z-4633 and upon receiving it, I reinstalled Windows 7 to get rid of all the bloatware and useless things that were taking up space on the hard drive. Upon doing this, two out of three of my USB ports stopped working for some reason. When I look at Device Manager, it says everything is up to date:


I didn't really care about this, considering I had the one that did work. By a stroke of horrible luck though, that USB stopped working too (completely a hardware problem though, no software involved with that breaking. I plugged something in and it literally ripped something out of the USB after I took the plug out). Now, I have these two USB ports that really should work, but they don't. I am almost certain that they worked fine before I reinstalled windows, so that rules out a problem with the hardware. But everything that I've read suggests that its a hardware problem, so I'm a bit confused with what could be going on.

My System SpecsSystem Spec
.

24 Jun 2013   #2
Dom

Windows Seven Ultimate
 
 

Almost a coincidence that my previous laptop was an Aspire 5735Z. Unfortunately I never encountered this issue when I did a clean install of Windows 7.
My first thoughts are wondering if you have installed all the drivers for your laptop? Windows Update does not always find up to date drivers concerning your model of laptop.
For the drivers, click here and enter your model.
The most important drivers are the ones in the category AHCI, AMT and Chipset.
Install the drivers, restart your PC and tells us what happens.
My System SpecsSystem Spec
24 Jun 2013   #3

windows 7 home premium
 
 

Agreed, reinstall your chipset drivers.

Have you done any of the windows updates?
My System SpecsSystem Spec
.


25 Jun 2013   #4

Windows 7 Home Premium 64-bit
 
 

No good guys ):

As for windows update, that was one of the first things I checked, and there are no available updates. Thanks
My System SpecsSystem Spec
25 Jun 2013   #5

Windows 7 Home Premium x64
 
 

I hesitate to suggest this......... but have you considered reflashing your BIOS?
My System SpecsSystem Spec
25 Jun 2013   #6
Dom

Windows Seven Ultimate
 
 

It seems you're not the only person to have experienced this problem on the 5733Z. I have Googled around a bit and other multiple users have the same issue

Someone did post a a troubleshooting method, and it was to determine whether you're experiencing hardware or software issues.
It was to download Linux, and install it to see if works on the OS. If it does not work for Linux, it is most likely a hardware issue.
And because other people have experienced the same issue, I would not be surprised if it was a hardware issue. It could be caused by a broken pin, or overheating, and the most likely solution is to have it repaired at your local computer repair shop. That is if it is of course a hardware problem, but I'm sure someone else may come up with an idea that I don't!

EDIT: Here's a helpful link if you want to keep Windows 7 installed.
My System SpecsSystem Spec
25 Jun 2013   #7

win 7 64
 
 

if its intel based try and get the drivers from the intel website, try a linux live cd and see if the ports work, if non of that works its more than likely a short on the bored
My System SpecsSystem Spec
Reply

 Two USB ports not working




Thread Tools



Similar help and support threads for2: Two USB ports not working
Thread Forum
Solved USB ports not working Hardware & Devices
Solved Front USB ports not working, but rear USB ports work Hardware & Devices
USB ports are not working Hardware & Devices
Not all USB ports are working Hardware & Devices
none of my USB ports are working Hardware & Devices
USB ports not working...PLEASE help! Hardware & Devices
USB ports not working Hardware & Devices

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 01:43 AM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33