Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Gigabyte 550 ti gpu no video after install

26 Jun 2013   #1
fspsyco

windows 7 home premium 64 bit
 
 
Gigabyte 550 ti gpu no video after install

So I just bought a new gpu and CPU for my pc and when I finished installing it and puting it back together and hooking it up I started it up and came to see that the screen was still black but it sounded like it booted up fine the card is the one in the title And the CPU is core 2 duo e7500


My System SpecsSystem Spec
.

26 Jun 2013   #2
TwoCables

 

The power supply may not have enough power to power your system with a 550 Ti in it.
My System SpecsSystem Spec
26 Jun 2013   #3
fspsyco

windows 7 home premium 64 bit
 
 

One thing I did forget to do was plug the cable for the fan into the power supply and I just did that also I did earlyer try to plug the old gpu in and see about trying to install the drivers and the screen was still black
My System SpecsSystem Spec
.


26 Jun 2013   #4
TwoCables

 

PSUs in pre-built computers aren't necessarily made to support video cards like this. What's the wattage rating on your PSU?
My System SpecsSystem Spec
26 Jun 2013   #5
Think Tank

Windows 7 Home Premium
 
 

If you're using HDMI, try switching to VGA and seeing if that helps - or the other way around. That might narrow it down a bit more.
My System SpecsSystem Spec
26 Jun 2013   #6
fspsyco

windows 7 home premium 64 bit
 
 

On the power supply its 250w
My System SpecsSystem Spec
26 Jun 2013   #7
Think Tank

Windows 7 Home Premium
 
 

Quote   Quote: Originally Posted by fspsyco View Post
On the power supply its 250w
Hmmm... That card takes a 400W. GeForce GTX 550 Ti | Specifications | GeForce That could have something to do with it.
My System SpecsSystem Spec
26 Jun 2013   #8
fspsyco

windows 7 home premium 64 bit
 
 

So basically I have to go out and get a new power source before I can use it hmm is there any way to use the old card in the mean time?
My System SpecsSystem Spec
26 Jun 2013   #9
TwoCables

 

Quote   Quote: Originally Posted by fspsyco View Post
On the power supply its 250w
Yeah, that's nowhere near enough. To make matters worse, that's a cheap 250W PSU.

I want to help you select the new PSU because they are not all created equal. The world of PSUs is extremely convoluted.


Quote   Quote: Originally Posted by fspsyco View Post
So basically I have to go out and get a new power source before I can use it hmm is there any way to use the old card in the mean time?
The old card? Do you mean the onboard video?
My System SpecsSystem Spec
26 Jun 2013   #10
fspsyco

windows 7 home premium 64 bit
 
 

What I mean is I have an older gpu that I have been using which was a gforce gt 7600 256mb and when I truer using it earlyer the screen stayed black
My System SpecsSystem Spec
Reply

 Gigabyte 550 ti gpu no video after install




Thread Tools





Similar help and support threads
Thread Forum
BSOD watching video clip... Gigabyte ATI R9 280x Catalyst 14.10
I had 2 cards in this build working fine then all of sudden windows stopped booting after splash up...long story short when I removed the second card that was being crossfired too in slot 4 and left the 1st card in slot one windows loads just fine. Now having taken that card out and already sent it...
BSOD Help and Support
Strange Duck this Gigabyte R7-260 video card
I asked for suggestions for a video card on an earlier post http://www.sevenforums.com/graphic-cards/321029-graphics-card-suggestions-please.html and decided to purchase a Gigabyte R7-260x (PCIe 3.0), knowing it was overkill for my intended purpose; but having the necessary plug-ins.. The Intel...
Graphic Cards
Gigabyte GM-M6880 mouse - Can't install software
Hello, Im trying to install software for my new M6880 mouse but I can't :@ When I run setup I get this error: Could not open the file named: C:\blabl bla bla bla SETUP.INF The file is there though :s What can be the problem?? Thanks!
Software
Gigabyte GM-M6880 mouse - Can't install software
Hello, Im trying to install software for my new M6880 mouse but I can't :@ When I run setup I get this error: Could not open the file named: C:\blabl bla bla bla SETUP.INF The file is there though :s What can be the problem?? Thanks!
Hardware & Devices
USB2.0 HD Transfer over Gigabyte Network to Gigabyte NAS
I have a Western Digital 1 TB USB 2.0 that I have connected to a computer that has Gigabyte connection to my NAS which can handle Gigabyte speeds. I am only getting 30.1MB/s. Is there any settings I can do to windows so that it can send faster? I have Windows 7 Ultimate 64-Bit.
Network & Sharing
Windows7 install issues with Gigabyte
Hi, has anyone had installation issues when using Gigabyte based systems? I have been trying to install windows7 RC on a system using a GA-73PVM-S2H motherboard with no luck, it will progress to the first restart ok but crashes just after the restart. I have tried only using 2g ram, SATA HDD...
Installation & Setup

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 21:57.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App