Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Hot-plug external drive = forcibly dismounts internal drive. Why??

11 Jul 2013   #1
GeneralEclectic

W7 Pro, W7 Ult, W7 Enterprise
 
 
Hot-plug external drive = forcibly dismounts internal drive. Why??

Hello all, This is an ASUS P5P43TD-Pro socket 775 Q8400, latest BIOS release. Works normally in all known other aspects. Windows 7 Enterprise, x64. 16GB memory. BIOS settings all "auto", i.e. no OC or anything of the sort. On-board LAN, Serial, parallel, IEEE all disabled. NVidia 220 video card, also set for defaults. There are six internal SATA ports (native ICH10R), with five fixed internal drives connected. The sixth port goes to an external SATA tray intended for hot-plugging bare drives. The BIOS does not distinguish between fixed and removable drives as some newer BIOSs permit. All you get to set is IDE emulation or AHCI. The drives are all set for AHCI to enable hot-swapping. The SATA driver in Windows is the Intel RST recommended by ASUS for this board. I have not allowed it to update to more recent versions. All this stuff basically works, but there's one screwy problem I can't seem to resolve. Out of the four drives that typically get hot-plugged into the external bay, three of them work exactly as you'd expect them to. The OS detects them and mounts them with a drive letter (H:, which is the next in line). No problem. ONE of the four drives causes this weird problem where it actually causes a dismount of one of the fixed drives. Not only a dismount, but it disappears from the list of devices too. And to make it even stranger, the new drive mounts with the correct drive letter (H), even though it knocks off the drive designated E! Aaargh. But it gets even stranger -- I've deliberately set a number of applications to have open file handles on E:, both local and network. Like six open file handles. Even *those* are forcibly closed when this problematic drive is detected, even though, as I said, it eventually mounts to drive H. Good grief. And yet stranger, as soon as I go to Device Manager and force hardware redetection, the original Drive E is redetected and the handles are restored. Does anyone have an idea what could be going on here and how to cure it? I've considered a secure erase on the problem HDD, thinking that its serial number is at the root of this conflict. Anyone think that this might work? [For some reason, the paragraph breaks are deleted from this post. It WAS originally somewhat more readable with them, but after three attempts to insert breaks, it looks like that's not going to happen.]


My System SpecsSystem Spec
.
11 Jul 2013   #2
Faladu

Windows 7 Ultimate Retail Box (64-bit installed) + Service Pack 1
 
 

That's a first time hearing an issue like that, I am puzzled as well, I'd look at BIOS settings and drivers as cause or bad drive electronics on the ONE.

Is there something different about that one?

I would have your co. pay for another drive in that situation and probably perform destruction procedures on the one not working, or DoD procedures to wipe it if it's under warranty before RMA'n it.
My System SpecsSystem Spec
11 Jul 2013   #3
GeneralEclectic

W7 Pro, W7 Ult, W7 Enterprise
 
 

They're all Seagate 7200.11 series. Nothing unusual about any of them. When they're mounted, the file systems are always okay, as in marked with a clean dismount and remount. All are NTFS with default parameters. All of these drives will work normally on other systems hot-plugged the same way, so it's doubtful that there's anything wrong with the drives themselves.

BIOS settings are basically all AUTO. The BIOS has many performance options, but none of those are selected. This machine runs 24/7 without a hitch. It had been up for over 60 days at the last reboot for Windows Updates.

This behavior is as if Windows "remembers" the weird drive as being associated with E: and tries to put it there even though there's already an E: Actually, now that I think about it, there's a similar misbehavior with mapped drives in Windows 7 sometimes -- occasionally a mapped drive set for automatic assignment will override an existing mounted drive, causing it to disappear, though it doesn't drop off Device Manager list, only the list of mounted drives. This looks exactly the same, only it's with a physical drive. I'm talking here about mapped drives on other machines. That particular phenomenon has not happened on this one.

[Hmmm. Now para breaks are working. I give up!]
My System SpecsSystem Spec
.

13 Jul 2013   #4
GeneralEclectic

W7 Pro, W7 Ult, W7 Enterprise
 
 
Solved, I think

I've resolved this, I think. Time will tell. What I did was shut down the machine and install the problem drive in the hot-swap bay. Then booted. BIOS enumerated the drives in order (the problem drive was last in the list) and Windows assigned drive letters in the correct order. IOW, the problem drive was assigned H at boot.

Then I hot-removed the drive, waited a bit and reinstalled it. And for the first time ever, Windows assigned it H on a hot-plug.

Wish I knew exactly what was going on behind the scenes here, but it looks like whatever was causing the conflict was somehow purged from the registry.
My System SpecsSystem Spec
Reply

 Hot-plug external drive = forcibly dismounts internal drive. Why??




Thread Tools Search this Thread
Search this Thread:

Advanced Search




Similar help and support threads
Thread Forum
Back up on external drive or internal drive
I don't have Windows 7 yet, but I'm just about to install it, but I figure it may be safe to do a back up first. I'm about to do an upgrade from Vista 64-bit to Windows 7 64-bit. I did find these recommendations: "An image backup of your hard drive offers an easy, dependable way to do just that,...
Backup and Restore
how to make your internal hard drive into and external hard drive ?
I have an internal hard disk not in use ,and I would like to make it as external disk ! I looked on the net and I found I should have the " encelsure " butt I think I wont find it here in my city . So is there another way ? like usb -esata cable ?
Hardware & Devices
save file on external drive not the same as internal drive
Why do files moved to an external drive not behave the same as those same files in an internal drive? I noticed that if I do anything to a file that is in an external drive, that file can not be saved under the same name (read only). In order to do so one must save it internally and then copy or...
General Discussion
Windows 7 - BSOD when i plug my External Hard drive
Hi everyone, I am in need of someone helping me to find a solution cause I have found nothing at all to fix it. The issue is that every time I plug in my Seagate Freeagent Go external hard drive I get BSOD a few moments after. This only started happening yesterday after it froze, it was...
BSOD Help and Support
Internal Hard Drive acting like an External Hard Drive
Hi guys, I'm new on any sort of forums so go easy if it's a stupid question..but here goes. Me and my brother built me a new computer from scratch (he did the building - i did the watching). To cut a long story short - I purchased an internal hard drive from Overclockers UK. It's a Samsung...
Hardware & Devices
External drive shows as internal
I have a Rosewill RX-DU100 Sata drive dock. Whenever I plug a HD into it on any of my W7 Pc's, it shows up as an internal drive. That's great for me as I use Carbonite and they only backup internal drives. I was wondering why W7 sees it as an internal and I could fool Windows into thinking other...
Hardware & Devices


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 10:19.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App