Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: USB device not removed from Device Manager after being unplugged

19 Jul 2013   #1
KeyHoe

win 7 x64 Home Premium
 
 
USB device not removed from Device Manager after being unplugged

I have a USB device that is not removed from the Device Manager after I unplug it. The laptop is a Samsung 700Z5B, win7 x64, updated with all MS patches, I'm not 100% sure if the BIOS is up to date, having trouble finding that info.

If I have just restarted the computer I can use my USB device just fine. From that point I can remove it once or twice, but after that it won't work again until a restart of the computer.

This seems to be the only device that is having this trouble. The hardware the USB connects to is a Moates Quarterhorse and it has an FTDI chip AFIK. I have not found anyone else having this issue with a Quarterhorse so I am thinking it might be an issue with my laptop as opposed to the Quarterhorse hardware.

Any thoughts or possible direction?


My System SpecsSystem Spec
.
21 Jul 2013   #2
ICIT2LOL

Desk1 7 Home Prem / Desk2 10 Pro / Main lap Asus ROG 10 Pro 2 laptop Toshiba 7 Pro Asus P2520 7 & 10
 
 

Ok KeyHoe how are you removing this device - the safe way or the unsafe way. You should be using the method of clicking on the arrow in the systems tray (right hand side of the taskbar) as shown next to my Kaspersky K it will open up and show what devices are plugged in click on the one you want to remove and wait for it to say safe to remove - easy .


Attached Images
USB device not removed from Device Manager after being unplugged-tray.png 
My System SpecsSystem Spec
21 Jul 2013   #3
KeyHoe

win 7 x64 Home Premium
 
 

I'm not removing it the safe way for sure, I rarely have a chance to do that under normal use. This device attaches to the computer on my truck and allows me to tune the motor. So when I am driving I'll have my laptop plugged in to this device and as soon as I turn off the ignition, this device no longer has power.

I could try removing it the safe way as a test but that's not always practical.
My System SpecsSystem Spec
.

21 Jul 2013   #4
ICIT2LOL

Desk1 7 Home Prem / Desk2 10 Pro / Main lap Asus ROG 10 Pro 2 laptop Toshiba 7 Pro Asus P2520 7 & 10
 
 

Quote   Quote: Originally Posted by KeyHoe View Post
I'm not removing it the safe way for sure, I rarely have a chance to do that under normal use. This device attaches to the computer on my truck and allows me to tune the motor. So when I am driving I'll have my laptop plugged in to this device and as soon as I turn off the ignition, this device no longer has power.

I could try removing it the safe way as a test but that's not always practical.
Ok KH if you are just shutting off the computer then there isn't a problem it is when you are removing the device from the computer while the truck is still running. If you are not shutting down the computer then you do run the risk of corrupting data on the attached device.

Mind you I think playing with the truck's settings while you are driving sounds not a great idea unless you pull up and do it then. Plus I guess if there were any power surges from the truck's generating system then I would have concerns for the computer mate unless you have some sort of surge or spike protection between it and the truck's electrical system.
My System SpecsSystem Spec
24 Mar 2015   #5
Trapezius

WINDOWS 7 HOME 64
 
 
any resolutions to this?

I also have one of these FTDI Chip devices. My PC is doing the SAME thing.
Plug it in and the virtual com port is created... Removing the device changes nothing. When I shut down the PC, it WILL HANG. you cant detech any new plug and play either (hang)

Would be great if anyone ever figures this out.
Thanks

p.s. I am using a uDMX micro from DMXking.com
My System SpecsSystem Spec
24 Mar 2015   #6
KeyHoe

win 7 x64 Home Premium
 
 

I have not figured out the problem but I was able to connect with a Mac that was hosting a VM of Windows in Parallels Desktop to my device. I found it strange that connecting in that manner I was able to get it to work.

For the laptop I am using an having trouble with, I wonder if that means a USB chip on the motherboard is not playing nice with drivers. I was using the same drivers in the windows VM as I use with my laptop. I know this laptop won't work and I am hoping to get a new laptop soon, hope that one will work.
My System SpecsSystem Spec
25 Mar 2015   #7
Trapezius

WINDOWS 7 HOME 64
 
 

Solved. I got it working.

I have an Asus notebook. I visited the Asus website and downloaded the latest BIOS. I also downloaded and installed the USB drivers from their site. These drivers are for the USB ports themselves. I also ran CCleaner from www.piriform.com/ccleanerThere is a registry scan that comes with it. I figured that if there was any unused items in the registry, it would clear it out.

So, I did do a few things. One or more of the three things fixed it.

End result is that the USB device, when plugged in makes a familiar sound and it appears in the device manager. When I unplug it, I hear the same sound 1 second later and it is gone from the device manager. PERFECT

Hope this helps someone.
My System SpecsSystem Spec
25 Mar 2015   #8
ICIT2LOL

Desk1 7 Home Prem / Desk2 10 Pro / Main lap Asus ROG 10 Pro 2 laptop Toshiba 7 Pro Asus P2520 7 & 10
 
 

Yes that's good then and if you want my advice for the future if you ever do a clean install and "tweak" the registry for any reason - I know CCleaner will ask you to save the result of the scan - is to back up the registry then if you happen to make any mistakes it can be merged back to the machine.
Registry - Backup and Restore very simple to do and takes hardly any tie at all.

A bit OT but this is a good tutorial if you want that bt extra out of your machine and don't mind losing a bit of the "bling" like transparency Optimize Windows 7

it uses some reg tweaks but tweaks themselves are very safe but backing up the reg ensures you can put right nay mistakes you make by hitting the wrong keys
My System SpecsSystem Spec
25 Mar 2015   #9
KeyHoe

win 7 x64 Home Premium
 
 

I am glad to hear that helped your situation. I had looked for all the updates I could but they just weren't making them for my lappy any longer. However, based on what you said, I hope to have better results when I do get a new lappy.
My System SpecsSystem Spec
Reply

 USB device not removed from Device Manager after being unplugged




Thread Tools Search this Thread
Search this Thread:

Advanced Search




Similar help and support threads
Thread Forum
Realtek HD Audio Manager: Device has been plugged/unplugged issue
I have the latest Realtek HD Audio Manager installed, but I have this rather wierd issue. Whenever I'm watching any video (music or otherwise) the Audio Manager pops up and keeps saying I plugged and then unplugged a device from the audio jack. The manager keeps saying it's "Headphones", but I...
Sound & Audio
Unknown device in device manager after Bios default settings are
applied. Sorry that last word didn't get in the subject line. So: http://i.imgur.com/QoSy2wX.png These two values are: USB\VID_0CF3&PID_3000&REV_0200 USB\VID_0CF3&PID_3000
Drivers
Unknown Device in Device Manager/Show Hidden Devices
I have a Toshiba laptop, model L505-ES5018. I had Windows 7 Home Premium 64 bit installed on here, but decided to reformat my hard drive using Windows 7 Ultimate 64 bit. After the reformat was finished, I ran Windows Update and it found several items to download and install for me. I noticed...
Drivers
Bluetooth device not in device manager, no hardware switch, Acer netbk
Model is Acer Aspire One D270. Internal bluetooth doesn't work. Nothing in device manager. Fn+F3 is meant to control it, but doesn't. May be because I've messed with some programs. Trying to re-install to factory settings. Any suggestions at all? thanks D:
Network & Sharing
Bluetooth Peripheral Device Driver Device Unplugged/Not Found
Hello! So I did some searching for a way to fix this problem but I believe that my problem is different than the Bluetooth Peripheral Device problem that most people have. I am NOT trying to connect a cell phone to my laptop. I am not trying to connect anything I don't think (unless my...
Drivers
Device Manager reports Unknown Device & explorer crash
How do i figure out what driver or even component windows wants software for when in the device manager under other devices it lists an unknown device and windows update cannot find anything. Oh and is it appropriate for me to use this topic to ask another question regarding explorer.exe as...
Drivers


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 16:59.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App