Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Weird problem with USB Flash Drive


09 Aug 2013   #1

Windows 7 Home Premium 64 bit
 
 
Weird problem with USB Flash Drive

I'm using a kingston DataTraveller Locker+G2 usb flash drive which works perfectly when plugged into my PC, if I demount the device using the recommended way and then subsequently plug back in I can't access the data in the locker without rebooting the PC again. Windows Explorer shows the two drives as G and H, G has the software to run the device but H is shown as empty. The device works OK on another PC. Any ideas ?

My System SpecsSystem Spec
.

09 Aug 2013   #2

Windows 7 Professional x64 Sp1
 
 

Question, on the other pc where it works does MY Computer look the same as it does on your computer when plugged in? On the other machine does going to start-computer look the same there for the flash drive as it does on your computer?
My System SpecsSystem Spec
09 Aug 2013   #3

Windows 7 Home Premium 32 bit
 
 

A random thought.

Control Panel > AutoPlay Check "Use AutoPlay for all media and devices" on top if not checked. Problem resolved?

If not try to restore your system to a point well back in time when your device was functioning as it should. ( Of course I am assuming that System Restore is functional on your system. And of course you have to reinstall all programs you installed after that time, not to mention that one such program could have derailed the auto play or whatever else. )
My System SpecsSystem Spec
.


10 Aug 2013   #4

Windows 7 Home Premium 64 bit
 
 

Thanks for the replies, just to clarify I've only had the Kingston usb flash drive a couple of days and it has never worked 100% on my laptop but works 100% on my pc, both explorer screens look the same apart from the number of and lettering of the drives and the auto play is ticked on both machines. When freshly booted the Kingston works 100% on the laptop it's only when the flash drive is removed using recommended method and then I put it back in and log into it again I can see both drives G and H but can't open drive H which is where the data is stored, explorer reports " please insert a disk into Removable Disk (H)". The laptop is very slow to detect usb devices.
My System SpecsSystem Spec
10 Aug 2013   #5

Windows 7 Professional x64 Sp1
 
 

Do you have any other issues with USB devices on the laptop?
My System SpecsSystem Spec
10 Aug 2013   #6

Windows 7 Home Premium 64 bit
 
 

Nothing more than it's slow at detecting usb devices compared to my pc.
My System SpecsSystem Spec
Reply

 Weird problem with USB Flash Drive




Thread Tools



Similar help and support threads for2: Weird problem with USB Flash Drive
Thread Forum
Solved weird drive letter problem? Hardware & Devices
Solved Problem with Bootable Flash Drive General Discussion
Flash drive problem Hardware & Devices
Weird hard drive problem General Discussion
Flash Drive Problem Hardware & Devices
corsair flash drive 16 gb problem Hardware & Devices
Weird problem when cd's removed from drive. General Discussion

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 03:06 PM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33