Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: 2.5" HDD in external enclosure not detected


23 Aug 2013   #1

Windows 7 Ultimate x86 build 7600 (XP, 98SE, 95, 3.11, DOS 7.10 on VM) + Ubuntu 10.04 LTS Lucid Lynx
 
 
2.5" HDD in external enclosure not detected

I have a 2.5" 120GB hard disk in an external enclosure (unbranded Chinese make).
This external disk is detected perfectly on both my laptops, but it is not detected in my desktop. There is no indication that it is present when I plug it in.
I have checked the USB port, which is working fine (my flash drives and external DVD drive work fine)
I have also tried connecting the HDD to all the USB ports in the desktop.

One more thing is that, this same HDD used to work fine on the desktop when it was in another (previous) enclosure (broken now)

Anyone have any idea's as to why this might be happening.

My System SpecsSystem Spec
.

23 Aug 2013   #2

Microsoft Community Contributor Award Recipient

Windows 7 Professional 64bit
 
 

Hi,

It could be the circuitry in the enclosure that has failed, which is pretty common.

The test for this is to try the drive in another working enclosure or a desktop computer.

Another one is to try a shorter USB cable.

Hope this helps

Cheers

Dave
My System SpecsSystem Spec
23 Aug 2013   #3

Windows 7 Ultimate x86 build 7600 (XP, 98SE, 95, 3.11, DOS 7.10 on VM) + Ubuntu 10.04 LTS Lucid Lynx
 
 

Quote   Quote: Originally Posted by Northernsoul55 View Post
Hi,

It could be the circuitry in the enclosure that has failed, which is pretty common.

The test for this is to try the drive in another working enclosure or a desktop computer.

Another one is to try a shorter USB cable.

Hope this helps

Cheers

Dave
Hi Dave,

As I've already stated, this external enclosure works perfectly on both of my laptops. Its the desktop that has the problem.
My System SpecsSystem Spec
.


23 Aug 2013   #4

Microsoft Community Contributor Award Recipient

Windows 7 Professional 64bit
 
 

Ooops...my bad.

Have you tried:

http://www.sevenforums.com/tutorials/165554-usb-driver-general-fix-problems.html

It could possibly be because your computer is automatically turning off the power to a USB Root Hub:

1. Go to Control Panel > System > Hardware tab > and click on the "Device Manager" button.
2. In the Device Manager window, find the item/items labelled "Universal Serial Bus controllers."
3. Open it, and double-click the first item called "USB Root Hub."
4. In the USB Root Hub Properties dialog, click on the "Power Management" tab.
5. "Allow the computer to turn off this device to save power" is checked by default. Uncheck this box, and click "OK."

Cheers

Dave
My System SpecsSystem Spec
23 Aug 2013   #5

Windows 7 Home Premium 32 bit
 
 

Try a double-headed (Y) USB cable.

Name:  10-08-2013 20-05-42.jpg
Views: 22
Size:  9.6 KB


My System SpecsSystem Spec
23 Aug 2013   #6

Windows 7 Ultimate x86 build 7600 (XP, 98SE, 95, 3.11, DOS 7.10 on VM) + Ubuntu 10.04 LTS Lucid Lynx
 
 

Quote   Quote: Originally Posted by Northernsoul55 View Post
Ooops...my bad.

Have you tried:

http://www.sevenforums.com/tutorials/165554-usb-driver-general-fix-problems.html

It could possibly be because your computer is automatically turning off the power to a USB Root Hub:

1. Go to Control Panel > System > Hardware tab > and click on the "Device Manager" button.
2. In the Device Manager window, find the item/items labelled "Universal Serial Bus controllers."
3. Open it, and double-click the first item called "USB Root Hub."
4. In the USB Root Hub Properties dialog, click on the "Power Management" tab.
5. "Allow the computer to turn off this device to save power" is checked by default. Uncheck this box, and click "OK."

Cheers

Dave
Dave,

Will check that out once I reach home.

Quote   Quote: Originally Posted by jumanji View Post
Try a double-headed (Y) USB cable.

Attachment 282819
I already am using a Y cable for the HDD
My System SpecsSystem Spec
23 Aug 2013   #7
Microsoft MVP

Windows 7 Ultimate X64 SP1
 
 

Go to Control Panel\All Control Panel Items\AutoPlay and check Restore Defaults, reboot and test. Reboot with the drive attached as well.

Obvious question, have you tried other USB ports?
My System SpecsSystem Spec
23 Aug 2013   #8

Windows 7 Ultimate x86 build 7600 (XP, 98SE, 95, 3.11, DOS 7.10 on VM) + Ubuntu 10.04 LTS Lucid Lynx
 
 

Quote   Quote: Originally Posted by Britton30 View Post
Go to Control Panel\All Control Panel Items\AutoPlay and check Restore Defaults, reboot and test. Reboot with the drive attached as well.

Obvious question, have you tried other USB ports?
Gary,

I have already checked it on all the USB ports in the desktop.

Will check out the other suggestion when i get home.
My System SpecsSystem Spec
23 Aug 2013   #9

Win8/8.1,Win7-U64, Vista U64, uncounted Linux distor's
 
 

If you plug a usb flash drive into these same usb ports does win explorer see it? If other boxes (2 laptops) see the ex hhd then it must be a configuration setting in the desk top OS.
My System SpecsSystem Spec
23 Aug 2013   #10

Windows 7 Ultimate x86 build 7600 (XP, 98SE, 95, 3.11, DOS 7.10 on VM) + Ubuntu 10.04 LTS Lucid Lynx
 
 

Quote   Quote: Originally Posted by madcratebuilder View Post
If you plug a usb flash drive into these same usb ports does win explorer see it? If other boxes (2 laptops) see the ex hhd then it must be a configuration setting in the desk top OS.
Steven,

As I said,

Quote:
I have checked the USB port, which is working fine (my flash drives and external DVD drive work fine)
My System SpecsSystem Spec
Reply

 2.5" HDD in external enclosure not detected




Thread Tools



Similar help and support threads for2: 2.5" HDD in external enclosure not detected
Thread Forum
External HDD enclosure not shutting down Hardware & Devices
External HDD with enclosure question Backup and Restore
External HDD Enclosure Question Hardware & Devices
Problem with External Enclosure Hardware & Devices
Win 7 does not recognize 2 TB in external enclosure? Hardware & Devices
External HD Enclosure help? Hardware & Devices
External HDD Enclosure Problem Hardware & Devices

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 02:33 PM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33