Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: 16Gb installed RAM (4Gb usable)

27 Aug 2013   #1
Absalom76

WINDOWS 7 ULTIMATE
 
 
16Gb installed RAM (4Gb usable)

Hello all!
I noticed when poking around in my computer settings and hardware information, that my RAM is showing (16Gb), but only 4Gb are "usable". I have been looking all over creation to find out why, but to no avail. I am utilizing:

Windows 7 Ultimate 64-bit OS,
AMD Phenom II x6 1090T,
ASRock 970 Extreme3 mobo,
4 (4Gb) sticks of G.Skill Ripjaws DDR3 ram,
and a
NVIDIA GeForce GTX 460 graphics card

I have tried all sorts of things, from tweaking the volts a bit (which showed 8 Gb usable out of 16 installed and crashed the computer),
to putting one stick in the mobo at a time, and booting with each stick (this gave me 5 short beeps when trying to boot two of the sticks individually). As a side note, When I have all RAM in it shows all 4 in my bios and on my System Properties.

I now have the 2 sticks in (that didn't cause the 5-beep error) which is 8Gb, and it's only showing 4 Gb usable.

On another note, from time to time when booting, I get an error that says to, "reboot, and select a bootable device" even though the HDD has not been changed or manipulated in any way. If all of these things are able to be addressed through a tweaking of my bios, I can't seem to find an easy way to do it anywhere!

My apologies if I missed a thread that pertained to this issue, but I have a bit of a Frankenstein computer on my hands here and could use some advice!
Thank you in advance!




My System SpecsSystem Spec
.

28 Aug 2013   #2
ICIT2LOL

Desk1 8 Pro / Desk2 7 Home Prem / Main lap Asus ROG 7 Pro
 
 

Hello and welcome Absalom mate try a memtest first up maybe you have some bad sticks or slots even .

You need to make a bootable disk then set the BIOS to boot from the optical and then let it run for at minimum of 8 passes unless you get errors straight away see RAM - Test with Memtest86+
My System SpecsSystem Spec
28 Aug 2013   #3
AddRAM

Windows 7 Professional x64 Service Pack 1
 
 

But have you talked with ASRock about it ?
My System SpecsSystem Spec
.


29 Aug 2013   #4
Absalom76

WINDOWS 7 ULTIMATE
 
 

I have not talked with ASRock about it. Right now, I have 8Gb inserted and 4Gb is usable. I have actually done a memory test with the Windows program that comes with my OS, and it didn't come up with anything. It even automatically ran check disc. Basically the "monster" runs, but not to full capacity. THANKS FOR THE REPLIES!
My System SpecsSystem Spec
29 Aug 2013   #5
AddRAM

Windows 7 Professional x64 Service Pack 1
 
 

Go into task manager/performance/resource monitor/memory all the memory should show up and tell you where it`s being used.
My System SpecsSystem Spec
29 Aug 2013   #6
Absalom76

WINDOWS 7 ULTIMATE
 
 

Quote   Quote: Originally Posted by AddRAM View Post
Go into task manager/performance/resource monitor/memory all the memory should show up and tell you where it`s being used.
If I plug in all my sticks of RAM, all 16Gb show up, however only partial memory is "usable" (normally 4Gb) no matter how much I have plugged into the mobo
My System SpecsSystem Spec
29 Aug 2013   #7
AddRAM

Windows 7 Professional x64 Service Pack 1
 
 

Did you do what I told you ?

Post a snip of it.
My System SpecsSystem Spec
29 Aug 2013   #8
Absalom76

WINDOWS 7 ULTIMATE
 
 

Quote   Quote: Originally Posted by AddRAM View Post
Did you do what I told you ?

Post a snip of it.
I will be doing a memtest overnight as they request that you let it run that long. I will reply with my findings as soon as I have more info! thank you for the advice! I will keep you posted!
My System SpecsSystem Spec
29 Aug 2013   #9
AddRAM

Windows 7 Professional x64 Service Pack 1
 
 

A memory test will do nothing for your problem.

And who is THEY ?
My System SpecsSystem Spec
30 Aug 2013   #10
ICIT2LOL

Desk1 8 Pro / Desk2 7 Home Prem / Main lap Asus ROG 7 Pro
 
 

Hiyya AddRam I said at the beginning I think it was that the memtest should be run for at least 8 passes but stop if it showed errors straight away.

I don't know exactly who THEY are but suspect it might be in the tutorial but without reading through it again can't be sure.

I only advised that if only to rule out bad sticks or slots and then go from there.

Absalom mate are the sticks all the same - are they a set of four or two sets of two (matched sticks) or are they just a mixture of different numbered sticks (not all exactly the same numbers on each one of them) ?
My System SpecsSystem Spec
Reply

 16Gb installed RAM (4Gb usable)




Thread Tools





Similar help and support threads
Thread Forum
6GB RAM installed, only 4GB usable - 64-bit OS
I've read a number of threads on this topic and have the same problem, but mine seems to be intermittent. I was recently advised to reseat the memory modules and having done that (about 2 weeks ago) System Properties reported 6.00 GB usable, as expected, and my system was running great. ...
Hardware & Devices
8gb Installed Ram - Only 3.74 Usable (HELP!)
I have a Gateway NV53A Laptop. Windows 7 Home Premium - 64 bit AMD Turion II P540 Dual-Core 2.40 GHz 8GB installed memory and only 3.74 is usable! I have updated the bios with the latest release from Gateway, then went in and checked and it shows "memory 8192", meaning it is seeing the full...
Hardware & Devices
16GB DDR3 1866 installed. (7.97GB usable) 7 Ultimate
So, i'm using 7 ultimate, and I've recently installed16GB of G.skill DDR 1866 mhz memory (2 8GB sticks). I've gone into the BIOS and manually set the speed to 1866, and the system is only showing about half of it as "usable" So the first thing I checked was of course the ram itself. I've reseatted...
Hardware & Devices
16GB (15GB Usable) help.
Hey guys, so the other day I found out one of my Modules was faulty (Corsair Vengeance 16 GB kit) and i took it out and tested the rest and the board DIMM slots, everything else was great. So today i received my replacement 4GB Module and at first it was saying 16 GB (12 GB usable) in System, I...
Hardware & Devices
RAM: 4GB installed and only 2.93 usable.
I have 4GB installed and only 2.93 usable. I tried the solution given by rektalstab 1)Run 2)type "msconfig" 3)Go under the "boot" tab 4)click "advanced options" button 5)UNCHECK! "Maximum memory" 6)Reboot
Hardware & Devices
6GB ram installed 5.5 usable ?
Hi everyone I installed 6 GB of ram today and at first it only showed 2 GB usable memory then I tweaked around with the settings and got it up to 5.5 GB How can I get it to its full capacity 6GB ? my motherboard I think does not support memory mapping and I re-installed the OS Win 7...
Hardware & Devices

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 20:27.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App