Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: USB ports dont work after computer format.

01 Sep 2013   #1
Aarbron

Windows 7 Ultimate x64
 
 
USB ports dont work after computer format.

i believe the title says it all.after i formatted my pc some of the ports didnt work.in the device manager window under the "other devices" root there are 3 yellow warning signs about "ethernet controller","SM bus controller" and "universal serial bus (USB) controller".i tried to update them but it keeps saying that windows couldnt find the solution in the web.


My System SpecsSystem Spec
.

01 Sep 2013   #2
maxie

windows 7 home 64bit
 
 

Hi there .. Going by your System specs it states you have a Desktop ... Do you know the Model Number ? If it is Custom built you can find the Motherboard Model Number by going to .. Start type in start in the search box write in CMD right click on it and Run as Adim when the prompt open type the following ... wmic baseboard get product,Manufacturer,version

That will tell you the Manufacturer of your Motherboard and Model Number .. Then go to their webstie and download the Chipset Driver and any other Drivers you need
My System SpecsSystem Spec
01 Sep 2013   #3
Pauly

Win7 Ultimate X64
 
 

Also going to device manager and checking for any devices with a caution symbol next to them will give you an idea of any other equipment thats not functioning/doesnt have drivers installed
As Maxie suggests getting your chipset drivers & usb 3 drivers if req`d from your mobo manufacturers website is the first step
My System SpecsSystem Spec
.


01 Sep 2013   #4
Aarbron

Windows 7 Ultimate x64
 
 

i did everything,the ports work now.thx a million!
My System SpecsSystem Spec
01 Sep 2013   #5
maxie

windows 7 home 64bit
 
 

Most welcome .. Glad you got it sorted
My System SpecsSystem Spec
Reply

 USB ports dont work after computer format.




Thread Tools





Similar help and support threads
Thread Forum
usb ports on mobo dont work
Hey everyone, so I have searched, updated windows, Intel and gigabyte drivers, and the only thing that came of it is that 2 of my 6 usb ports on the mobo work now. The other 4 don't. They power my astro mixamp but don't produce sound, and when I turn on my pc with my mouse and keyboard in the ports...
Hardware & Devices
This is a tough one - ports dont work after a router change with LAN
i have 2 window 7 PC's connected by a router / modem . I run an application within the LAN only that lets a mouse move between the 2 PC's when i changed the router this app no longer works. Windows firewall is off. If disconnected my other firewall, same thing the porrts the application...
Network & Sharing
Front USB ports not working, but rear USB ports work…
This is a brand new custom built PC for web browsing for a motel lobby. Win7 Home Premium AMD A4-3300 Llano MSI A55M-P33 FM1 Rosewill FBM-02 MicroATX Mini Tower Running latest BIOS and latest drivers downloaded directly from manufacturer's website. I tried switching between all 3...
Hardware & Devices
USB 3.0 ports refuse to work as USB 3.0 ports
A few days ago I installed a USB 3.0 card (to be precise, this one: 2-Port USB 3.0 SuperSpeed PCI-E Controller Card - Free Shipping - DealExtreme). It uses the very common NEC µPD720200 USB 3.0 controller. I installed the required drivers for Windows 7, and the card worked fine for the first...
Hardware & Devices
speakers dont work when connected to my computer!!
i recently got a new computer case and installed windows 7. everything is working fine except for my sounds plugs and my LED's (that's going to be another thread). I've had a foxconn a88gmv for a while now (plugging in speakers in the green jack worked before). i have a coolermaster haf x (this is...
Sound & Audio
USB ports dont work anymore on my HP Dv6 laptop
Out of nowhere! I first noticed my Blackberry wasnt syncronizing automatically as it used to, after I upgraded to BB 6.0. I tried the portable HDD which didnt do anything and no flashdrives were regognized. I tried to uninstall BB6.0 (unsuccessfuly) It froze. Just coulndt do it. When trying to...
Drivers

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 01:39.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App