Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Computer crashes after the Windows sign appears during startup

09 Sep 2013   #1
WeeScottyc

Windows 7 home premium 64 bit
 
 
Computer crashes after the Windows sign appears during startup

About an hour ago, I took the side panel off my computer to get rid of some dust inside the case. Once I had finished up, I started up the computer again to find the message 'reboot with proper start up device' or something a long those lines. I proceeded to put the disk of Windows 7 into the disk tray and load in up. After windows had finished loading files, the computer appeared to start up as normal, but just blanked screened after the windows logo appeared. This now occurs every time I start up the computer. Any help would be greatly appreciated.

The reason this is in hardware and devices section, is because when I go into the EFI BIOS, it doesn't have the HDD as listed component in the boot priority.


My System SpecsSystem Spec
.
09 Sep 2013   #2
Terronium 12

Windows 10 Technical Preview - x64
 
 

Something you can try right away is shut down everything (make sure to flip the power switch on the PSU or unplug it and discharge any left over power by pressing the power button) and disconnect and reconnect the SATA power and data cables. If that doesn't work, try a new SATA port. If that doesn't work, try a new SATA cable.
My System SpecsSystem Spec
09 Sep 2013   #3
WeeScottyc

Windows 7 home premium 64 bit
 
 

Hi, and thanks for the reply. I have already tried changing SATA port, but have not tried changing the cable. How would this be done? I'm not very comfortable with the wiring!

Ok, I managed to do this, and now the HDD is being recognised on the BIOS boot priority list. However, when I put the HDD as boot priority, it comes up with a different error now - 'a disk read error occurred'
My System SpecsSystem Spec
.

09 Sep 2013   #4
Terronium 12

Windows 10 Technical Preview - x64
 
 

I can't tell much from your available specs, but if you put together the system yourself then you'll easily be able to find a new SATA cable inside your motherboard's packaging. If it's pre-built you'll have to purchase one.

Before worrying about that you mentioned earlier you were able to run what I assume to be Startup Repair (correct me if I'm wrong, please) which seems to indicate it's just the BIOS having a bit of trouble reading the HDD. Does it show up at all when you scroll the available boot devices?
My System SpecsSystem Spec
09 Sep 2013   #5
WeeScottyc

Windows 7 home premium 64 bit
 
 

I have managed to change the SATA cable, and now the HDD appears in the boot priority. I am seeing this on the EFI BIOS settings page that is brought up when pressing delete when my computer starts up. I put the HDD to priority boot, but now the error 'a disk read error occurred' is appearing
My System SpecsSystem Spec
09 Sep 2013   #6
Terronium 12

Windows 10 Technical Preview - x64
 
 

Boot into the Recovery options and run Startup Repair. You may have to run it several times.
My System SpecsSystem Spec
09 Sep 2013   #7
WeeScottyc

Windows 7 home premium 64 bit
 
 

Is this done from the BIOS screen? Or must I press something else during booting up?
My System SpecsSystem Spec
09 Sep 2013   #8
Terronium 12

Windows 10 Technical Preview - x64
 
 

You'll need to use your W7 installation disc.
My System SpecsSystem Spec
09 Sep 2013   #9
WeeScottyc

Windows 7 home premium 64 bit
 
 

Ok, I'll try now
My System SpecsSystem Spec
09 Sep 2013   #10
Terronium 12

Windows 10 Technical Preview - x64
 
 

Remember, when you get to the "Install Now" screen, hit the "repair your computer" link beneath it.

Let me know how it goes.
My System SpecsSystem Spec
Reply

 Computer crashes after the Windows sign appears during startup




Thread Tools Search this Thread
Search this Thread:

Advanced Search




Similar help and support threads
Thread Forum
Windows 7 delay before the password insert box appears on startup
Windows 7 delays before the password insert BOX appears on startup. This happened after i cleaned the registry for skype and then reinstalled skype. How can i fix it?
General Discussion
blue screen appears on startup of windows followed by system hang
hi there..can some please help me regarding the blue screen error that appears on my windows.. when i start my laptop it goes fine until just before the desktop appears and after that the system hangs and does not respond to anything..i have to force shut down my laptop and it doesn't start after...
BSOD Help and Support
Did not let me sign in to the windows startup screen
My password did not work on the windows startup screen. I ended up boot in safe mode, and doing a memory test, and now it works fine. But I know a memory test would not of fixed it? Am I going to be getting this error again? Is this a sign of something about to break down on me? or by...
General Discussion
Computer unusable due to frequent crashes, even on startup.
I haven't identified a pattern, but now I get crashes too frequently to use my 2006 Gateway desktop. I just did a clean install of Windows 7 yesterday, with no success in resolving my crashes. Seeking help. Thanks in advance. See below and also attached files. Problem signature: Problem Event...
BSOD Help and Support
BDOD on boot up Windows 7 x64 (crashes when the Windows logo appears)
Hi there, This thread is not much of question but rather an answer to anyone who encounters a similar problem. Therefore, I do not know if this is the best place to post this. You are welcome to move this thread. Here was my problem: I had recently formatted my PC and reinstalled Windows 7...
BSOD Help and Support
Windows logo no longer appears during startup . .
i've had my computer for about 2 months now. running windows 7 premium and recently when i boot up my computer, after it displays the bios menu, it skips the windows logo screen and goes straight to the welcome screen. i havent noticed any issues other then this however i did notice strange noises...
General Discussion


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 07:24.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App