Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: USB2 to IDE & SATA adaptor

21 Sep 2013   #11
alphanumeric

Windows 10 Education 64 bit
 
 

Quote   Quote: Originally Posted by keithr View Post
Yes, I connect up the HDD to the adaptor, then power it up before plugging into the USB port. The disk I am currently using is SATA, so appears as master.

Regarding drivers, when I first plugged it in I got a message saying installing new device driver software.....your device is ready to use.

When looking in Device Manager, a new "USB Mass Storage Device" appears when the adaptor is plugged in, which claims to be using a Microsoft driver dated 21/06/2006, version 6.1.7601.17577. What is that?

Perhaps another clue is that when my broadband cycles on and off, I get a pop up saying ""Additional log on information may be required. When I open that up it says "Your requested host could not be reached. Click on the link below to retry

A further clue perhaps - When connected to my Win7 laptop using the same router with ethernet cable as before, it works fine with no issues.

Search
It requires drivers to operate but they are already in the windows driver store. Windows already has them so you don't need any additional drivers to install manually. When someone says you don't need drivers for that device, it usually means Windows already has them. I can understand your confusion though, I could have explained it better in my other post.

This is kind of a shot in the dark but try turning off AutoPlay in control panel. Then plug it in. Windows may be trying to run something in the root directory of that drive when you plug it in. Turning off AutoPlay will stop that. Like I said though this a shot in the dark, what is actually going on here has be perplexed.


My System SpecsSystem Spec
.
21 Sep 2013   #12
patio

Vista Ultimate X64/ Windows 7 Dual-boot
 
 

Is there an OS installed to this external HDD ? ?
That would explain the hiccups.
My System SpecsSystem Spec
22 Sep 2013   #13
keithr

Windows 7 Home Premium 64 bit
 
 

Quote   Quote: Originally Posted by madcratebuilder View Post
Have you ever been successful at connecting this ide-sata adapter? The first adapter I purchased was defective out of the box. If you can plug in a usb stick or other usb devises and they are working then this may be a problem with the adapter and not the computer software.

Yes this device operates ok, it just that it has this peculiar effect on my broadband connection. Other USB devices work fine.

I just tried disconnecting the ethernet cable to my router, and amazingly the same effect happens. The LED's indicating broadband and internet both cycle off then on.... I just cant understand how this is possible
My System SpecsSystem Spec
.

22 Sep 2013   #14
keithr

Windows 7 Home Premium 64 bit
 
 

Quote   Quote: Originally Posted by patio View Post
Is there an OS installed to this external HDD ? ?
That would explain the hiccups.

No there is nothing on the disk.
My System SpecsSystem Spec
22 Sep 2013   #15
alphanumeric

Windows 10 Education 64 bit
 
 

Quote   Quote: Originally Posted by keithr View Post
Quote   Quote: Originally Posted by madcratebuilder View Post
Have you ever been successful at connecting this ide-sata adapter? The first adapter I purchased was defective out of the box. If you can plug in a usb stick or other usb devises and they are working then this may be a problem with the adapter and not the computer software.

Yes this device operates ok, it just that it has this peculiar effect on my broadband connection. Other USB devices work fine.

I just tried disconnecting the ethernet cable to my router, and amazingly the same effect happens. The LED's indicating broadband and internet both cycle off then on.... I just cant understand how this is possible
The LED's on your router cycle on and off even with the network cable disconnected? If that is true it has to be the power pack that supplied external power to the drive.
My System SpecsSystem Spec
24 Sep 2013   #16
keithr

Windows 7 Home Premium 64 bit
 
 

I think the best way out of this is to get another adaptor. Any recommendations?
My System SpecsSystem Spec
24 Sep 2013   #17
alphanumeric

Windows 10 Education 64 bit
 
 

This is what I have, Rosewill.com - Computer Case, Power Supply, Computer Accessories, Networking, Peripherals. Price, Quality, and Services. I bought it at Newegg. It works and I have no complaints.
My System SpecsSystem Spec
25 Sep 2013   #18
ICIT2LOL

Desk1 7 Home Prem / Desk2 10 Pro / Main lap Asus ROG 10 Pro 2 laptop Toshiba 7 Pro Asus P2520 7 & 10
 
 

Hmm have got three of these devices and never had a problem at all - but I do find it doesn't work as well through a 3.0 USB port than a 2.0. I don't remember seeing it anywhere but maybe something to do with the USB drivers?
My System SpecsSystem Spec
Reply

 USB2 to IDE & SATA adaptor




Thread Tools Search this Thread
Search this Thread:

Advanced Search




Similar help and support threads
Thread Forum
Ext.HDD usb2 problem..
Hi All . I just did a fresh reinstall wds7 ... and have problem with my Ext.HDD usb port won't recognige : Here are the screenshot ..: Updated drivers already . Try HDD on other pcs ..open fine .
Hardware & Devices
SATA adaptor card
Have just got a PCI to 4-port SATA I Raid Controller - will this allow me more SATA ports or is it purely for a RAID set up - I have looked but I am not savvy enough to work it out.:o
Hardware & Devices
USB2.0 problem.
Erm, i had Win7 32 ultimate and everything worked like it had to, but after I installed win 7 64 ultimate, my built-in webcam and microphone doesn't work anymore -.-. Something is wrong with my USB device, it says: http://www.upload.ee/image/963176/mmmm.png Cannot update, windows can't find any...
Hardware & Devices
USB2 very slow
Hi, I got Win 7 64 bit with a Asus P7P55D-E motherboard and a Intel i5 2,66 GHz, a Seagates 1 To Baracuda 7200 RPM... When I plug my external HDD or a USB stick, i got a transfert rate between 100 Kb/s to 3 Mb/s... It's really slow when a USB2 can handle 480 Mb/s... When I try to cancel a...
Performance & Maintenance
Can't Access SATA Hard Drive using USB Adaptor
I cannot get my Windows 7 x64 laptop to access my SATA Hard Drive connected via a USB adaptor. Upon connecting for the first time or after you have uninstalled the USB Mass Storage device, it successfully installs the drivers. But you cannot see the drive listed in "My Computer" nor access it. ...
Hardware & Devices
can't detect USB2.0
Hi I have recently upgraded my machine from vista premium to Windows 7 my laptop doesn't detect USB2.0. Not being very comp lit how do i resolve this? Any help much appreciated. :D
Hardware & Devices


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

İ Designer Media Ltd

All times are GMT -5. The time now is 05:55.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App