Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Strange USB Drive Showing in Device Manager


27 Sep 2013   #1

W7 Pro x64 SP1 / W8.1 Pro x64 / W10 Tech Preview x64 VM
 
 
Strange USB Drive Showing in Device Manager

I was just farting around earlier doing a bit of maintenance and the usual checks when I expanded Disk drives in Device Manager. My SSD, Caviar Black, Caviar Green and Hitachi USB external drive all showed up fine, but I also have a weird 'ghost' drive showing up in there too which has a very strange name.

Strange USB Drive Showing in Device Manager-capture.jpg

I have no other storage device attached via USB at all for definite, and the only thing I can think of is whether this is a leftover from when I tried to apply ASUS USB 3.0 Boost to a Kingston Data Traveler while trying to get USB 3.0 speeds out of my front ports (which didn't work). That may or may not be the case, and I've no idea how long that weird drive has been showing up as I haven't checked the Disk drives expanded for a while, I was just wondering if anybody had any idea as to what could have caused that to be showing up?




My System SpecsSystem Spec
.

27 Sep 2013   #2

W7 Pro x64 SP1 / W8.1 Pro x64 / W10 Tech Preview x64 VM
 
 

I decided to uninstall the drive as it couldn't be real, so I made a Restore Point and uninstalled it through Device Manager. I rebooted and Windows installed the weird drive again.

Name:  Capture.JPG
Views: 76
Size:  21.8 KB

Now I'm really confused. I can account for every USB peripheral that's plugged into the rig and they're all accounted for in Device Manager too. Opening Computer doesn't show an extra drive either. This is going to bug me until I get to the bottom of it.

Name:  Capture 2.JPG
Views: 75
Size:  74.6 KB


My System SpecsSystem Spec
27 Sep 2013   #3

W7 Pro x64 SP1 / W8.1 Pro x64 / W10 Tech Preview x64 VM
 
 

The drive also shows up as Disk 3 in disk management. Now I'm pretty sure it's to do with one of my USB sticks, but how it's showing up when the drive isn't even plugged in is beyond me.

Strange USB Drive Showing in Device Manager-capture-3.jpg


My System SpecsSystem Spec
.


27 Sep 2013   #4

windows 7 home 64bit
 
 

Hi there ... Have seen this before some USB sticks show up as Drives .. Nothing can be done about that .. How ever when its not plugged in that is a different matter
My System SpecsSystem Spec
27 Sep 2013   #5

W7 Pro x64 SP1 / W8.1 Pro x64 / W10 Tech Preview x64 VM
 
 

I'm pretty sure this will have happened when I was messing around trying to get my front USB 3.0 ports working at 3.0 speeds. I wonder if I uninstall my eXtensible Host Controller it will stop seeing the drive?
My System SpecsSystem Spec
27 Sep 2013   #6

windows 7 home 64bit
 
 

Cannot say for sure mate .. I guess its worth a try though
My System SpecsSystem Spec
27 Sep 2013   #7

Windows 7 Home Premium 32 bit
 
 

Hi Boozad,

While I can't say what exactly is the weird device - in one case atleast and if I remember correctly, it was a camera connected through USB port that left an imprint - you can do a drive cleanup to remove all non-present devices as in my post USB Thumb Drives not recognised (not drive letter) and check whether the device disappears.
My System SpecsSystem Spec
28 Sep 2013   #8

W7 Pro x64 SP1 / W8.1 Pro x64 / W10 Tech Preview x64 VM
 
 

Thanks Jumanji, I'll give that a try later. There are just a couple of things I want to try first that I think may have caused the issue on the first place.
My System SpecsSystem Spec
28 Sep 2013   #9

windows 7 home 64bit
 
 

Hi there ... Have managed to find the old thread ... This is just one there are several ..

Flash stick showing as "Local Disk"
My System SpecsSystem Spec
04 Oct 2013   #10

W7 Pro x64 SP1 / W8.1 Pro x64 / W10 Tech Preview x64 VM
 
 

Right, I've looked at both suggestions (thanks Jumanji and Maxie) but neither solved the problem. RemoveDisk didn't find anything to be removed and the drive isn't showing up in Explorer as a Local Disk.

I've looked into ASUS USB 3.0 Boost (turned it off in Task Scheduler) and even tried uninstalling the drive through Device Manager with both of my Data Travelers plugged into my front USB ports then removing them but it still remains.
I've plugged my Touro Mobile into my front USB 3.0 ports and everything worked fine (the last time I plugged it in there it said the disk needed formatting which I obviously didn't do as it's my backup disk).

My Data Travelers don't open Autoplay when I insert them and don't show in Windows Explorer either, but I can Safely Remove (labelled ASUS BOT) them so that's a bit weird but I'm no longer convinced they're anything to do with the non-existant drive.
I will persevere but this one really has fried my grey matter.
My System SpecsSystem Spec
Reply

 Strange USB Drive Showing in Device Manager




Thread Tools




Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 03:55 PM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33