Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: SATA hardisk detected as IDE in BIOS. Please help

03 Oct 2013   #1
vinmicrosoft

Win 7 Ultimate
 
 
SATA hardisk detected as IDE in BIOS. Please help

Friends,
I need your help to resolve this issue.

I am trying to install new WD SATA hard disk in my dektop . But Bios recognized as IDE. So its not properly detecting in System.

Here is my cofiguration

Motherboard - ASRock -Wolfdale1333-D667
IDE - 80 GB Samsung - Master - windows 7 installed
IDE - DVD writer - Slave

My new wd SATA hardisk model - WD5000AAKX - WD Blue / SE / SE16 (SATA II) -500 GB

What i already did:

Checked with another data cable to detect HD correctly
Tried all SATA port on my mobo
Set Enhanced option on BIOS


Please please someone help me.


My System SpecsSystem Spec
.
03 Oct 2013   #2
DocBrown

Win7 Enterprise, Win7 x86 (Ult 7600), Win7 x64 Ult 7600, TechNet RTM on AMD x64 (2.8Ghz)
 
 

Maybe Win7 is not recognizing it yet if it is not initialized or formated. Can you do a Disk Management screen snip ?

Disk Management - Post a Screen Capture Image
My System SpecsSystem Spec
04 Oct 2013   #3
vinmicrosoft

Win 7 Ultimate
 
 

Hello DocBrown

Thanks for reply .

however new hard disk did not displaying in Disk management as you mentioned.
I also tried to remove power cable of my IDE hard disk and IDE dvd then booting with single new SATA hd but its still displying as IDE in bios.

Here is the pic attached . Please have a look.


Attached Images
 
My System SpecsSystem Spec
.

04 Oct 2013   #4
Britton30
Microsoft MVP

Windows 7 Ultimate X64 SP1
 
 

Does the new HDD have your w7 on it?
Try entering BIOS and set the OS drive as the first drive in Drives priority. cheack that the SATA dirvers are installed ans et (in BIOS) to SATA mode, enable AHCI.

Disk Management - Post a Screen Capture Image
My System SpecsSystem Spec
04 Oct 2013   #5
vinmicrosoft

Win 7 Ultimate
 
 

Hello Britton30

New WD hd is fresh and just came 2 days ago as part of of Replacement and i am trying to install operating system. I could not set priority for new hard disk as its not displaying properly in BIOS.See my first pic.

I am unable to find option to enable AHCI in my BIOS but i set as Enhanced. You can see that in second pic.


Hope it will help.


Attached Images
  
My System SpecsSystem Spec
04 Oct 2013   #6
Britton30
Microsoft MVP

Windows 7 Ultimate X64 SP1
 
 

What other options are there for Type in the top picture and options for ATA/IDE Configuration?. It does show a SATAII Hard disk connected.
My System SpecsSystem Spec
04 Oct 2013   #7
vinmicrosoft

Win 7 Ultimate
 
 

Hello Britton30,

Here is Pic of hard disk setting in BIOS. I currently set Enhanced . Hope this help.


Attached Images
 
My System SpecsSystem Spec
04 Oct 2013   #8
Sardonicus

Windows 7 Home Premium 64 bit
 
 

What's most important is what's being displayed under the Windows Computer Management controller description, IDE or SATA.
If Windows states SATA, then you should get SATA II speed.....if IDE, then IDE speed.

Name:  Capture.JPG
Views: 36
Size:  69.9 KB


My System SpecsSystem Spec
04 Oct 2013   #9
Britton30
Microsoft MVP

Windows 7 Ultimate X64 SP1
 
 

Try it on Compatible then check Device manager/IDE ATA/Atapi Controllers as suggested
My System SpecsSystem Spec
05 Oct 2013   #10
vinmicrosoft

Win 7 Ultimate
 
 

Hello Sardonicus, Britton30

here is screenshot of my device manager.

Is jumper setting needed for this situation?


Attached Thumbnails
-panel.png  
My System SpecsSystem Spec
Reply

 SATA hardisk detected as IDE in BIOS. Please help




Thread Tools




Similar help and support threads
Thread Forum
SATA-1 & SATA3 Bios doesn't see SATA-1
I had a pc with SATA-1 drive installed windows7 64 bit, it was working fine untill I decided to attache the another hard drive SATA-3 with server 2003 loaded on it. I wanted to copy some data from SATA-3 and then wipe it off and use as additional storage, But the PC stop booting from windows7...
Hardware & Devices
PCI-E Sata Card not detected and not working
Hello, right heres my problem I built my own computer, got a raid array, around 12 HDD/SSD's, and since i have so many drives i needed to buy a sata controller to get extra sata ports at 6GBPS, so i brought: StarTech.com 4 Port PCI Express SATA III 4 Port PCI Express SATA III (6Gbps)...
Hardware & Devices
hardisk not detected
I had 3 hard drive installed on my computer: 1. ata hard drive 40 giga.(contents data only). 2.160 sata hard drive, seagate giga.(contents Win XP) 3. sata hard drive, seagate 250 gigabytes.(Contents of Win 7) I usually work with Win 7, A few days ago my win 7 error, I run a repair of windows...
Hardware & Devices
Sata Drive Not Detected By Windows 7
Hey there, I recently bought two new sata3 drives and set them up in a raid stripe and installed win7, all work fine. I added an older sata2 drive, it shows in the bios but Windows 7 cant see the drive.. not in disc management or device manager... I had a similar problem with my other...
Hardware & Devices
e-sata HDD not detected outside W7
Well, this is probably no fault of Windows... Nevertheless is was a shock to notice that my backup drive was not detected by my Acronis rescue DVD, when I had sort of a crash... It does show up in the bios. The Acronis forum has nothing on this issue. Anything I may not have thought of guys and...
Hardware & Devices
Samsung 500gb Sata not getting detected
Samsung 500gb Sata not getting detected It shows in the bios but not on windows it doesnt show in disk management also so i cant format it how to i make it work there? MB- Intel D945GCLF HDD- SAMSUNG SATA MODEL: HD502HI
Hardware & Devices


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 07:12.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App