Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: EVGA GTX 660 SC black screen issue on startup

07 Oct 2013   #1
Razor505

Windows 7 Home Premium x64
 
 
EVGA GTX 660 SC black screen issue on startup

I have been getting random black screen issues on startup, where after the Windows logo the screen goes black and there is no sound either.
Specs:
CPU: AMD Athlon ii x4 635
PSU Corsair CX 500
RAM: 4GB DDR3
GPU: EVGA GTX 660 SC


My System SpecsSystem Spec
.
07 Oct 2013   #2
TVeblen

Microsoft Community Contributor Award Recipient

Windows 7 64 Bit Home Premium SP1
 
 

Which nVidia driver are you running?

Could use a better description of what is happening too. Normal Windows startup is:
  • Black Screen "Starting Windows"
  • Coalescing squares
  • Black Screen
  • Blue Splash Screen "Welcome"
  • Desktop
Where in the process the problem occurs is important.

Is it freezing? Or taking a long time to move to the next step?
My System SpecsSystem Spec
07 Oct 2013   #3
Razor505

Windows 7 Home Premium x64
 
 

I am using the newest nVidia drivers and all I get is a complete black screen after the window logo.
My System SpecsSystem Spec
.

07 Oct 2013   #4
TVeblen

Microsoft Community Contributor Award Recipient

Windows 7 64 Bit Home Premium SP1
 
 

The black screen portion of the startup sequence is where drivers are loaded. If the system freezes during that portion then you most likely have a piece of hardware or it's driver that is problematic.

Start by disconnecting all externally connected components (USB, Wireless) and testing.
Then disable components on the motherboard one at a time and test.
Then remove any non-essential devices (first from Device Manager, then physically) and test.

Of course, if you can think of any recent changes that occurred about the same time as the freezing, that will make it easier to track down.
My System SpecsSystem Spec
Reply

 EVGA GTX 660 SC black screen issue on startup




Thread Tools




Similar help and support threads
Thread Forum
Windows 7 Startup issue - Screen going black
For several months my laptop (HP Pavilion dv6) has been going black about 20% of the time that I start it up. It is more likely to occur when my laptop has only been turned off for a couple hours or less. The startup process starts as normal, but then goes to black, with the exception of a...
General Discussion
chkdsk ran 8 hrs, then black screen, then weird startup screen, then..
... after 15 minutes of hanging in that weird startup screen, considering whether to hard reboot or not, it went into start repair (still there now)... To make a long story short, I suspected something wrong with my hard drive due to a software giving me an i/o error, after some research (I am...
Performance & Maintenance
windows 7 startup issue with black screen
i am was installing drivers on my laptop(sony vaio windows7 ulitmate 32 bit) and in between the installation,the system display a message to restart the computer to complete the installation.i clicked the restart button and after it displays a message windows failed to start. a recent hardware or...
General Discussion
Crash to bootscreen on startup, startup repair black screen
Upon booting my computer, I'm presented with the option to go into startup repair, or start normally. If I start normally, it loads the logo, but before it gets to the login screen, it crashes to the boot screen. If I select the startup repair option, it shows a loading bar, which completes, but...
BSOD Help and Support
Black screen on startup, showing cursor, doesn't go to log in screen.
I'm using I have a DELL4500S desktop, on startup it will not go to the login screen, the screen is just black with the cursor showing. I've tried restarting the computer, unplugging everything and restarting it. Nothing is working. When it first starts a pop up shows and says "This Application...
BSOD Help and Support
ATI black screen startup issue
Hi guys! So im having a set of issues first of all im using a hd4850 via hdmi to my samsung 46"lcd. I just got a new mobo asrock (k10n78d) and when I start up for the first time everything is good until it installs a video driver, it then reboots then stalls at a black screen right after the...
Graphic Cards


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 12:24.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App