Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: usb issue win 7

29 Oct 2013   #1
BLAZE86DUBZ

win 7 64 bit
 
 
usb issue win 7

i have an issue i have an older dell desktop studio 540 it came with windows vista when i purchased it then a year later win 7 came out so i bought a full version and installed in did a clean install its been runing great untill a week ago when i purchased a electrical unit for one on my toys when i went to go install it useing a usb it doesent recgnize it i updated all the drivers everythings up to date i dont know what to do next?? any advice


My System SpecsSystem Spec
.
30 Oct 2013   #2
fireberd

Windows 10 64 bit
 
 

Is the USB device you tried to install a "plug and play" or is it one that comes with a driver (or a driver you have to download from the internet)? If it comes with a driver, the driver must be installed first and the unit NOT physically connected to the PC until after the driver is installed. In this type of installation, if the unit is connected first the install will fail and/or the device will not be recognized.

More information, including exactly what you are trying to install, is needed for someone to try and help you. Also, what drivers did you update? Did you use Dell supplied drivers (Vista is applicable for Win 7) or from a 3rd party? In most cases the Dell drivers are needed.
My System SpecsSystem Spec
30 Oct 2013   #3
BLAZE86DUBZ

win 7 64 bit
 
 

Its a plug and play unit I had to go to the website and down load the program I installed the program first then tried to connect says could not recgnize so I went to device manager and where the usb is plugged in there is a yellow Mark next to it I tried to update the driver but it says the recommended one is being used so I went to the dell website to look for updated drivers bit since iinstalled win 7 64 bit from a clean install I can't use there drivers because it came with vista installed
My System SpecsSystem Spec
.

30 Oct 2013   #4
fireberd

Windows 10 64 bit
 
 

The Dell Vista drivers are applicable to Windows 7. I used to do user support on the Dell forums and we never had any problems with Vista drivers in Windows 7. Windows 7 basically is just "Vista improved". Actually the same drivers will work in Windows 8 (but maybe not Windows 8.1).

The Windows USB controller drivers are just the default built in Windows drivers, there are no 3rd party drivers for the USB hardware. Individual USB devices may or may not have drivers.

What exactly is the device you are trying to install?
My System SpecsSystem Spec
30 Oct 2013   #5
whs
Microsoft MVP

Vista, Windows7, Mint Mate, Zorin, Windows 8
 
 

For a test, I would uninstall the driver you currently have and plug the device in. Maybe the system can automatically find a generic driver.
My System SpecsSystem Spec
30 Oct 2013   #6
BLAZE86DUBZ

win 7 64 bit
 
 

Its a flybarless unit for a rc helicopter
My System SpecsSystem Spec
30 Oct 2013   #7
fireberd

Windows 10 64 bit
 
 

I don't know what model/brand of flybarless you have.

I found this on the BeastX unit and if you have it, there is a long procedure
BeastX Microbeast Flybarless Unit - D.I.Y. Soup
My System SpecsSystem Spec
30 Oct 2013   #8
BLAZE86DUBZ

win 7 64 bit
 
 

No I have a beast x that worked fine on my computer the one I'm haveing issues with is called Ikon fbl
My System SpecsSystem Spec
30 Oct 2013   #9
fireberd

Windows 10 64 bit
 
 

The installation seems to be reverse to most USB device installations.

I would fall back, with System Restore back to an available restore point before you first tried to install this. This will give you a "clean" start.

The instructions I see on the vendor's site is:
The first thing you will need to do is head to the iKON website and download the software for your windows computer (note “Windows Computer”, there is no Mac support). Once installed, getting the iKON to connect to the computer can be a little tricky, since everything needs to be followed in a specific order. To get it to connect, you first need to plug in the USB connector in to your computer, then connect the other end the iKON. Then you are going to need to power on the unit
My System SpecsSystem Spec
30 Oct 2013   #10
BLAZE86DUBZ

win 7 64 bit
 
 

I tried all that I just did a clean fresh install of windows 7 and still didn't work
My System SpecsSystem Spec
Reply

 usb issue win 7




Thread Tools Search this Thread
Search this Thread:

Advanced Search




Similar help and support threads
Thread Forum
Boot issue, 0xc0000098 ci.DLL file issue
OK so I hope this can be a quick fix and thanks for your help. * Randomly computer didn't start, get something telling me that the ci.dll file is missing or corrupt and error 0xc0000098 * safe mode and last know good configuration both result in bsod * Tried a few things, disconnect all...
BSOD Help and Support
net start command line issue - 64bit issue?
I am trying (in vain) to issue a net start command "net start - "C:\Program Files (x86)\uTorrent\utorrent.exe", on the command line. The error message is "the filename, directory name or volume label syntax is incorrect". I believe the 3 details are correct, as i am looking at the utorrent.exe file...
General Discussion
HP Multi Print/Scan Issue Re Install Issue?
I have an HP M1522 NF multi function peripheral attached to a PC running Windows 7. I needed to re install the drivers and software the other day but now it will only install the printer drivers and not the scanner drivers or any of the accompaying software?
Hardware & Devices
jpeg permission issue / possible encryption issue
Hello, I am new to the forums and have looked around just about everywhere I can think of for a similar topic and thus far have been unable to locate any help. If this has been previously covered, please point me in the direction and I will read up. So as for my issue.... I was running...
General Discussion
Interesting connectivity issue, just a browser issue
Opps, maybe not so unique since I just noticed an ENTIRE forum for browsers...perhaps moving this is appropriate...if so, please do. I will be reading up in there. Its interesting because I can't find any mention of it anywhere on this site. Specifically browser connectivity is lost after a...
Network & Sharing
8800GT Driver issue? Or maybe its a bios issue.
Hi all. I'm not sure where to start with this issue, it's bit spread out but it all started while I was gaming and the game froze and then the computer crashed. The freezing happened every once in a while, but the crashing had never happened. During the restart I see...
Drivers


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 19:44.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App