Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Problem with Verbatim USB 3.0 portable drive and USB 3.0 port

19 Nov 2013   #11
lumzi23

Windows 7 Home Premium 64bit
 
 

Quote   Quote: Originally Posted by MilesAhead View Post
Quote:
It is also worth mentioning that the drive dropped a couple of times while still its packaging.
Tough to rule out damage unless you try it on another machine.
Sorry, I edit my prev post. I tried it on another machine (my laptop on usb 2.0 [no usb 3.0]) and it seems fine.

Edit: It might be difficult to find a USB 3.0 machine but I will hopefully find one and test it.


My System SpecsSystem Spec
.
19 Nov 2013   #12
dsperber

Windows 7 Pro x64 (1), Win7 Pro X64 (2)
 
 

Quote   Quote: Originally Posted by lumzi23 View Post
That is not the variety I use.

I use the 2TB versions... available here in the USA.
My System SpecsSystem Spec
19 Nov 2013   #13
lumzi23

Windows 7 Home Premium 64bit
 
 

Quote   Quote: Originally Posted by dsperber View Post
Quote   Quote: Originally Posted by lumzi23 View Post
That is not the variety I use.

I use the 2TB versions... available here in the USA.
Yeah, mine is different from that one. Mine is a lot thinner.

Edit: I noticed that quite a lot of people seem to have a similar issue. It has something to do with 'eXtensible Host Controller" and the usb cables.
My System SpecsSystem Spec
.

19 Nov 2013   #14
dsperber

Windows 7 Pro x64 (1), Win7 Pro X64 (2)
 
 

Quote   Quote: Originally Posted by lumzi23 View Post
Quote   Quote: Originally Posted by dsperber View Post
Quote   Quote: Originally Posted by lumzi23 View Post
That is not the variety I use.

I use the 2TB versions... available here in the USA.
Yeah, mine is different from that one. Mine is a lot thinner.
Obviously the hard drive inside is different for the 500GB version vs. the 2TB version. Yours could also be a 2.5" style whereas mine could be a 3.5" style.

Anyway, I honestly don't think the problem lies with the drive (unless you damaged its USB 3.0 functionality fatally somehow when you dropped it, which seems impossible to believe).


Quote:
Edit: I noticed that quite a lot of people seem to have a similar issue. It has something to do with 'eXtensible Host Controller" and the usb cables.
Don't know. The drive comes with a USB 3.0 cable, and I've always used them without incident.

As far as Intel xHCI mode, the BIOS in my P8Z77-V Pro has "smart auto" as the default setting, which enables the feature as "optimized". I've not changed it from its default.

Dunno. I've used that 2TB version for the past few years without any problem whatsoever, in numerous different desktop and laptop machines some with built-in USB 3.0 capability and some where I had to add that PCIe USB 3.0 adapter card.

Sorry... can't help you with any more ideas.
My System SpecsSystem Spec
19 Nov 2013   #15
lumzi23

Windows 7 Home Premium 64bit
 
 

Quote   Quote: Originally Posted by dsperber View Post
Quote   Quote: Originally Posted by lumzi23 View Post
Quote   Quote: Originally Posted by dsperber View Post
That is not the variety I use.

I use the 2TB versions... available here in the USA.
Yeah, mine is different from that one. Mine is a lot thinner.
Obviously the hard drive inside is different for the 500GB version vs. the 2TB version. Yours could also be a 2.5" style whereas mine could be a 3.5" style.

Anyway, I honestly don't think the problem lies with the drive (unless you damaged its USB 3.0 functionality fatally somehow when you dropped it, which seems impossible to believe).


Quote:
Edit: I noticed that quite a lot of people seem to have a similar issue. It has something to do with 'eXtensible Host Controller" and the usb cables.
Don't know. The drive comes with a USB 3.0 cable, and I've always used them without incident.

As far as Intel xHCI mode, the BIOS in my P8Z77-V Pro has "smart auto" as the default setting, which enables the feature as "optimized". I've not changed it from its default.

Dunno. I've used that 2TB version for the past few years without any problem whatsoever, in numerous different desktop and laptop machines some with built-in USB 3.0 capability and some where I had to add that PCIe USB 3.0 adapter card.

Sorry... can't help you with any more ideas.
It's cool. I have tried changing my xHCI to 'enabled' from 'Smart Auto' but it did nothing. Others who had Renesas (sp?) controllers instead of intel were able to change in by disabling USB 3.0 power management functions in some Renesas utility program (I think it was a utility program at least). I can find no such option for my intel.
My System SpecsSystem Spec
Reply

 Problem with Verbatim USB 3.0 portable drive and USB 3.0 port




Thread Tools Search this Thread
Search this Thread:

Advanced Search




Similar help and support threads
Thread Forum
USB drive problem accessing database due to port shut down
When I have my USB drive connected to my router, no problem. When instead I have it connected directly to my PC (a laptop) (resulting in the same drive letter assigned to the drive as when connected to the router), the PC doesn't stay connected to the drive, such that after awhile I lose connection...
Network & Sharing
Verbatim external hard drive not picking up
I just bought a Verbatim 1TB external hard drive (USB 2.0, 3.5") and my PC with Windows 7 Home Premium 64bit is not picking it up. I have tested the USB port and it definitely works. I have tried searching for new devices. I have tried the hard drive on friend's PC also with Windows 7 and it...
Hardware & Devices
Portable Expansion Drive.
Hi, I have a Seagate USB3 500GB Portable Expansion Drive to accommodate my Back-ups and also any files I wish to 'transport' to another PC. I would prefer to leave the device connected to my PC except when I need to transport files. Will leaving it connected do any harm; should it be removed when...
Backup and Restore
Verbatim 1TB External drive not recognised on boot
Hi I have windows 7 with a Verbatim 1TB external drive, the system is not recognising the external drive. When I switch it off and back on again it then recognises it and loads it in My Computer. I have another external USB drive which works just fine. This problem started after I formatted the PC...
Hardware & Devices
USB Thumb Drive vs Portable HDD
Hi Everyone, I need your opinions on a purchase I'm planning to make soon. I'm in a bit of a fork as to what I'm going to get actually. A thumb drive would be more portable, so to speak rather than the portable HDD. An HDD would have way more space, however. I will mostly use this...
Hardware & Devices
New Portable Hard Drive
Just got myself a new portable hard drive made by Zynet. Every time I try to Initialize it, a box pops up saying The device is not ready? I have tried changing the USb sockets it is plugged into, to no avail? The HD is on, the pc recognises it, as it is showing up in the disk management screen....
Hardware & Devices


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 15:23.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App