Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: USB keyboard mouse failure at login

23 Nov 2013   #1
ParkerB

Windows 7 Ultimate x64
 
 
USB keyboard mouse failure at login

I know this has been brought up before but it has not been solved or at least none of the suggestions have worked over the last week I have been working of this problem. On one of my installs of Win 7 64 bit Ultimate is having an issue with the keyboard and mouse. They work fine in the UEFI but once I get too the login screen they do not work. I have tried changing the ports. The only USB ports on my board are the internal ports with a card on the back. Does not work. Tried a PS2 keyboard then mouse, did not work. Ran the system recovery. Cannot run because it is incompatible. Booted from the Win install disc, tried recovery console, safe mode, system restore, everything I can think of.

I added a new drive to the machine and did a fresh install. Everything works fine as is. I have tried to repair the original system drive. Cannot. I partitioned the SSD drive and tried to install windows on the partition but it will not because the partition is not a dynamic drive. I am afraid if I concert the drive I will lose all the data.

I can run the system with the new install and see everything on the original drive. Is there a way I can repair the MBR or whatever it is that is preventing the PC from recognizing input devices?

Any thoughts would be greatly appreciated.

Would it be possible to remove the user on the original drive when I boot from the other win 7 install?
Maybe force it to create a new user on start up?
I do move my personal folder out of the user folder and put it right in the C drive. No sub folders to get to it.

Just to be clear, I have proven several things.
It is not a problem with the USB ports. It fails in both USB 3.0 and 2.0. Every USB port has been tried.
I connected a jump drive to every USB port and can use the drive with the other install.
It is not the keyboard or mouse. They work fine. I have tried four keyboards and multiple mice.

Please help, I am out of ideas. I know I could have just started over in much less time but I cannot let it win.


My System SpecsSystem Spec
.
24 Nov 2013   #2
Ranger4

Windows 7 Home Premium 64 bit sp1
 
 

Have you checked Device Manager to see if it lists a keyboard & mouse installed. If so you may need to uninstall the drivers, then reboot & Windows should install the correct drivers.
The fact that you state these work when inUEFI, which I assume you mean when in the motherboard set up screen, it would seem to me that Windows has not loaded the drivers for these, so try the above & see if it helps.
My System SpecsSystem Spec
24 Nov 2013   #3
ParkerB

Windows 7 Ultimate x64
 
 

Thanks for your response. I cannot do that however. Since I can not login I cannot get to the desktop. And if I did I would not be able to navigate to the device manager. I tried to delete the drivers on the original drive while I was running on the second install but I cannot get access. I don't know why, I granted myself ownership and permission for full control.

Part of the problem likely is that the computer shut down while I was still logged in since I have three user accounts based on what I am doing. The login screen is only showing one. If I could somehow delete that user account it might force it to boot differently and it may work. Do not know how to do that when it is not the system drive at the time.
My System SpecsSystem Spec
.

24 Nov 2013   #4
Ranger4

Windows 7 Home Premium 64 bit sp1
 
 

Perhaps it might be worth installing Windows in Legacy mode & not UEFI. Have you tried that or do you have a particular reason to use UEFI.
My System SpecsSystem Spec
25 Nov 2013   #5
ParkerB

Windows 7 Ultimate x64
 
 

I only use UEFI because that is what the motherboard has set. I do not know how to set the PC to boot in legacy mode. If you can let me know how to do that I would happily try it.
My System SpecsSystem Spec
25 Nov 2013   #6
Ranger4

Windows 7 Home Premium 64 bit sp1
 
 

I really can't help you here as I do't know anything about ASUS motherboards. If you are fairly good with computers you could read through the mobo manual to see if you can reinstall in legacy mode.

Perhaps someone on the Forum with a lot of ASUS experience may be able to help you further. I really only offered this as possible solution.
My System SpecsSystem Spec
25 Nov 2013   #7
Ranger4

Windows 7 Home Premium 64 bit sp1
 
 

In the meantime I have seen that ASUS have a live support section in the USA. Search ASUS on the web & follow through on their website under "Contact us" & go from there.
They may be able to help you as it does seem that your keyboard & mouse drivers are not being loaded during the install of Windows.
Sorry I can't be of more help.
My System SpecsSystem Spec
Reply

 USB keyboard mouse failure at login




Thread Tools Search this Thread
Search this Thread:

Advanced Search




Similar help and support threads
Thread Forum
no keyboard and mouse at login screen
Powered up computer following day (worked fine) and the keyboard and mouse dont work at the login screen. The numlock key is lit but stuck. However the computer is not frozen because the cursor in the password field is blinking and if I press the power button, the screen changes and it does a...
General Discussion
Mouse and Keyboard Failure after Power Outage
I was playing a game on my PC several days ago during a thunderstorm, and unfortunately the power went out briefly. My computer is plugged in to a surge protector. When I restarted my computer, immediately I noticed that my USB wired mouse and keyboard were both not operating. The lights on both...
Hardware & Devices
Gigabyte GA-Z87X-UD4H Intermittent USB failure with mouse and keyboard
I upgraded my system at the beginning of January with an i7-4770K in a Gigabyte GA-Z87X-UD4H with 16GB of G.Skill Trident X memory. Almost immediately after build, I started running into a problem with my USB ports. The primary problem is that my mouse will often stop responding for a few seconds,...
Hardware & Devices
Mouse and Keyboard not working at login
This is my first build and I have not had any problem with it until this. The mouse and keyboard work in the Bios, but once it gets to the log in screen there is a pointer in the middle but nothing works. I had just installed the software for the keyboard from the Kensington website and it told me...
Hardware & Devices
Keyboard/mouse works on boot but not login
Hey guys! trying to recover from a system crash here.. One of the issues was me not being able to install/uninstall microsoft antivirus, since it seems some files were deleted which it needed. I tracked that issue to yet another issue what windows installer could not start, which suggested me to...
Hardware & Devices
USB Keyboard and Mouse not working after login
I have a Dell Inspiron 560s which is about 2 years old. The keyboard and mouse were working till 12 hours ago. This morning i realized that neither of them were working. The laser in the mouse and the lights on the keyboard stays on until the login process starts. The keyboard works in the BIOS....
Hardware & Devices


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 16:52.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App