Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Hardware removal icon missing from systray after Intel RST removed.

05 Dec 2013   #1
golem

Windows 7 Ultimate 64
 
 
Hardware removal icon missing from systray after Intel RST removed.

I have a P8Z77-V LK with two hot-swap bays. After a fresh install on this new system about 8 months ago I set BIOS to allow hot-swap of these two bays. Everything worked fine for a few months then I had the bright idea that, when prompted by Intel's Rapid Storage Technology to update, I would remove this utility simply to see if it was of any worth keeping. After this I noted I no longer see the manager icon in the systray for these bays but it does still pop up and work for any USB drives which are connected. As a test I did reinstall Intel RST but the swapping function remains broken for the bays.

I checked BIOS and all setting still seem to be correct; AHCI enabled along with hot-swapping for these drive bays. Is there a simple fix for this as I found the Win7 utility to be full adequate or should I simply opt for one of the available free utilities (HotSwap, etc.)?

Can also add that I do use dual-boot with the other bootable partition basically cloned and that one, not having ever removed Intel RST, still recognizes the removable bays as hot-swappable.

Any insight appreciated.


My System SpecsSystem Spec
.
06 Dec 2013   #2
TVeblen

Microsoft Community Contributor Award Recipient

Windows 7 64 Bit Home Premium SP1
 
 

It could be that IRST disables the redundant Windows services.

As a first step you could try running Windows System File Checker:
SFC /SCANNOW Command - System File Checker
My System SpecsSystem Spec
06 Dec 2013   #3
golem

Windows 7 Ultimate 64
 
 

Thanks for the reply TVelben!

I just ran the sfc scan in "verifyonly" mode and it found no integrity violations.

One more thing I can add is that I did placed on the desktop the following shortcut "%windir%\system32\RunDll32.exe shell32.dll,Control_RunDLL hotplug.dll" which allows me to manually open the Windows USB/Hotswap manager. Even with drives mounted in both of the HS bays the manager does not display either whereas it did prior to me removing IRST.

Now, in case I decide to add a hot swap utility would anyone like to suggest a decent "free" one compatible with Win7/AHCI? The last time I used the utility "HotSwap" it was with XP in IDE so not even sure if it's applicable. Going to research that now. I also have reservation that even a 3rd party utility may not recognize the hot swap enabled internal drives for the same reason Window doesn't.
My System SpecsSystem Spec
.

07 Dec 2013   #4
golem

Windows 7 Ultimate 64
 
 

Not wholly "solved" but I did decide to install the HotSwap! utility for a very seamless and even more feature rich work-around. Functions a charm just as it did when last used with XP.
My System SpecsSystem Spec
07 Dec 2013   #5
TVeblen

Microsoft Community Contributor Award Recipient

Windows 7 64 Bit Home Premium SP1
 
 

Good to hear. As long as you got it to do what you want it to do then it is all good.
My System SpecsSystem Spec
10 Dec 2013   #6
golem

Windows 7 Ultimate 64
 
 

I just wanted to add a curious update as an FYI.

Doing some housecleaning of the computer I decided I wanted to get rid of the IRST software package and simply install the associated AHCI driver. Now recall, I noted having remove the IRST package previously in an attempt to cure my missing hardware removal icon, which it did not, nor did reinstalling the software. This time around removal of the IRST package surprisingly put back in working mode the Windows hardware removal icon for all drives hot swap enabled in BIOS along with any connected external drives.

Now if I can find on the Intel website (which I have not been able to) just the AHCI driver that comes bundled with the IRST software I'd prefer to install it. Any subsequent checking to see if the Windows hardware removal utility remains would simply be out of curiosity as I've renewed my affinity for HotSwap! and will continue to use it instead.
My System SpecsSystem Spec
Reply

 Hardware removal icon missing from systray after Intel RST removed.




Thread Tools Search this Thread
Search this Thread:

Advanced Search




Similar help and support threads
Thread Forum
SD card reader works but no "removal of hardware" sound or icon
I have an Asus CM1630 desktop running windows 7, 64 bit. SD card reader works, after adding drive letter, but there is no hardware removal or insertion tone and the is no icon to safely remove the SD card. The SD card works fine when placed in an USB adapter and plugged into the USB port - there is...
Hardware & Devices
Power icon missing after removal ZeroAccess rootkit
I removed this nasty from my cousin's laptop about 5 months ago w/ a combination of RKill, Farbar's Service Scanner, Eset Sirifef tool & services repair, ComboFix, MBAM.... and a couple others. One of the residual problems was Action Center was missing from the notification area and I was able to...
General Discussion
Different ico in systray for Safely remove hardware
Hi, I have generate a few Windows 7 Enterprise X64 and on all devices the ico is like this: http://i61.tinypic.com/t7ldfa.jpg Except on one: http://i57.tinypic.com/11m8dvm.jpg Why? Some suggestions? Thanks very much !!
General Discussion
How to disable Systray icon "Safely remove hardware and eject media"?
In my Systray there is an icon "Safely remove hardware and eject media" which did not exist in WinXP. I guest this is for possible removing USB sticks from USB slots. However I should be able to remove USB sticks by just plugging them out. Per definition WinOS and hardware should be able...
General Discussion
Ms Removal Tool removed but how did I pick it up
We had the dreaded Ms Removal Tool which blocked Internet access and constant problems. Eventually my wife (her computer doesn't let me change anything although she's a PC novice) used Safe Mode with Networking and Malwarebyte Anti-malware and removed it. But I don't know how we picked it up in the...
System Security
Internet connection icon missing from systray
Hi, I turned on my Dell Laptop running W7 today and the "2 tv's and globe" icon showing that you are connected to the Internet is missing from the systray. Thankfully I'm connected to the Internet, however it is very annoying and mystifying that this icon has just disappeared. I've gone into the...
General Discussion


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 01:23.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App