Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Hard drive not found during installation

22 Dec 2013   #1
joeandmarg0

Windows 7 Home Premium 32bit
 
 
Hard drive not found during installation

Have acquired a Western Digital hdd,320gb SATA,which gives the following message when trying to install XP,"Setup did not find any hard disk drives on your computer.Setup cannot continue."
I ran Data lifeguard diagnostics and on the Quick test got"Completed without errors,Error status code 0000"
Then used the "Write zeros" to clean the drive and "No errors found,error status code 0000"
Finally ran the Extended Test and again"No errors found,code 0000"
So tried XP again and no go,same not found once more.
Then installed a Linux,FreeBSD,works normally.
Clean drive using Dban and installed Ubuntu 12 and it works just fine.
Installed the drive into another machine running XP and the drive shows in BIOS and Device Manager,which says the drive is operating normally{in Properties} BUT the drive does not show in Computer.
Because Linux use a different boot loader,GRUB,this seems to me,where the problem might be,but I really don't know.I have been in touch with WD to ask about the Master Boot Record,no luck so far.
Any more head scratching and I'll become a permanent redhead.
I've run out of ideas.
Joe Smith


My System SpecsSystem Spec
.

22 Dec 2013   #2
Golden

Microsoft Community Contributor Award Recipient

Windows 7 Ult. x64
 
 

Quote   Quote: Originally Posted by joeandmarg0 View Post
Installed the drive into another machine running XP and the drive shows in BIOS and Device Manager,which says the drive is operating normally{in Properties} BUT the drive does not show in Computer.
In Disk Management, does it have a drive letter? If not, create a primary partition on the drive and assign a drive letter to it.

In your original computer, does the drive show in the BIOS? How old is the drive? In the BIOS of your original computer, are you using AHCI or SATA controller for this disk?
My System SpecsSystem Spec
22 Dec 2013   #3
joeandmarg0

Windows 7 Home Premium 32bit
 
 

The drive is not recognised by Windows,only Linux.Therefore Disc Management does not exist,the only time the drive is visible in a Windows system is Device Manager and when right clicked in that situation all commands are greyed out except HELP,which is a waste of space.
The drive is available in both computers,the BIOS is,American Megatrends Inc.,Version R02-A2,05/10/2006,the motherboards are:Acer model ERC410M andtheir build is Acer Power F5 Standard.My computer,this one,is home built by me and I will not put the suspect drive in it.
Hope this answers your queries and thank you most sincerely for your response.
Regards,
Joe Smith
My System SpecsSystem Spec
.


23 Dec 2013   #4
Golden

Microsoft Community Contributor Award Recipient

Windows 7 Ult. x64
 
 

Try wiping, formatting to NTFS, and creating a Primary partition using bootable Partition Wizard. Now try installing XP as originally intended.
My System SpecsSystem Spec
23 Dec 2013   #5
Britton30
Microsoft MVP

Windows 7 Ultimate X64 SP1
 
 

It may be you need to press F6 during install and load SATA drivers for XP.
My System SpecsSystem Spec
25 Dec 2013   #6
joeandmarg0

Windows 7 Home Premium 32bit
 
 

Thank you both for your interest.The solution is embarrassingly simple,the floppy disc is corrupt.I pressed F6 at the appropriate time and assumed the relic worked as it used to.In my own defence,I haven't installed XP for years nor used the FDD since then either.I believe there is an alternative method of installing the drivers,will have to find it and try it.
Many thanks.
My System SpecsSystem Spec
Reply

 Hard drive not found during installation




Thread Tools





Similar help and support threads
Thread Forum
Hard drive sometimes found - sometimes not
My backup drive is a 500GB WD and has experienced no issues at all until I deleted one partition and resized the remaining one with (Partition Wizard 8). I thought it a bit odd when PW reported a 31MB unallocated space remaining, but on reboot the BIOS detected the drive and in Windows all the...
Hardware & Devices
Damaged Hard Drive? No operating system nor HD can be found
My computer crashed, I put in my recovery CD and it said "Operating system: Unknown on (Unknown) Local Disk" Then i went into the command prompt and put "diskpart", then "list disk", and it shows up like this: DISKPART> list disk DISK ### Status Size Free Dyn Gpt --------- --------...
Hardware & Devices
hard drive failed, system image not found on hard drive
hi all, i hope someone can help me out, i am a newbie to all this so bare with me. my hard drive failed over a month ago but i managed to do a system image with win7 to my new 2tb internal hard drive. i cannot get the image recovery to work as i says "no image can be found on hard disk". i am at...
Backup and Restore
Hard drive not found
Hello all, I have just finished assembling my first computer. I am trying to use the Windows 7 upgrade disk to install on my new hard drive as per the set of instructions I found here. I am having trouble though, when I get to the point where I select custom install them pick a drive to put the...
Installation & Setup
windows 7 setup cannot found the hard drive
Hello you! I want to thank you for the extraordinary work that you be trying to achieve. Congratulations. My question is: During the reinstallation of Windows 7, the operating system did not find the hdd. on some forum I visit they have to say download the drivers. but I do not know where to...
Installation & Setup
Hard drive not found
The system currently boots fine from the hard drive into Win XP. When I boot from the Win 7 install DVD it fails to find the hard drive, and as far as I can tell there are no special drivers required. I'm using an IDE drive--not SATA--with a Gigabyte GA-EP45-DS3L motherboard. I also tried to...
Installation & Setup

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 21:00.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App