Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Logitech Mouse works on some good USB ports, but not others

13 Jan 2014   #1
Saginaw

Windows 7 64 bit
 
 
Logitech Mouse works on some good USB ports, but not others

Hardware: Lenovo T430s
OS: Windows 7

I have a Lenovo T430s running Windows 7. It has 3 USB ports. Up until recently, I was using a wireless Logitech M310 mouse. Upon switching to a wired Logitech B100 mouse, I noticed that the wireless mouse works in all 3 USB ports, but the wired mouse works in only 2 of the 3 USB ports. I tried a USB memory stick and it works in all three. I tried a reboot and the wired mouse still works in only 2 of the 3 ports. I borrowed another Logitech B100 wired mouse and it also works in only 2 of the 3 ports (the same 2 as the other mouse). Does anyone know what it going on?


My System SpecsSystem Spec
.
14 Jan 2014   #2
badger906

Windows 7 Ultimate x64, & Mac OS X 10.9.2
 
 

im not sure if its a windows bug, hardware bug, driver bug or a usb thing, but i had the exact same problem.

I have different hardware to you (a cyborg v7 keyboard and a RAT9 mouse), but same results.
mine sometimes decides it no longer likes the port its in and will work fine in the other port it never used to. ive googled and googled and never got an answer to my situation.

however yours being a laptop and not a desktop (like mine) it maybe easier to point the finger.

does it work in the 2 usb port that are next to each other and not the 3rd thats on its own?

if this is the case chances are it has a different controller on the motherboard. it could be solved by upgrading your chipset drivers.
My System SpecsSystem Spec
Reply

 Logitech Mouse works on some good USB ports, but not others




Thread Tools Search this Thread
Search this Thread:

Advanced Search




Similar help and support threads
Thread Forum
2 HDMI ports but only 1 works
ok so i have 2 hdmi ports on the back of my pc, i plug my moniter into one it works, then the other, then it does not register its in. any help appreciated :D
Graphic Cards
Logitech G9 mouse works intermitenttly with Win 7 Ultimate x64 bit
Hi folks, I have been having some issues with my G9 mouse that I tried to solved on my own but it is getting a bit annoying so I guess is time to ask the Gurus. I dual boot with Vista Ultimate 64 bit & Windows 7 Ultimate 64 bit but I have the Logitech setpoint installed only on my Win 7 OS...
Installation & Setup
Logitech Webcam C170 won't work on my PC but works on others
Ok so I bought a Logitech Webcam C170 a few days ago and it just won't work. When I plug it in it just plays the "device failure" sound and doesn't light up the LED on the camera like it's supposed to do. On other computers it works. I have installed the drivers and software for the webcam. Here...
Hardware & Devices
Help with my G9x logitech mouse
Hey, I've been having problems with my g9x logitech gaming mouse. 2-3 days ago I plugged it in and the color wouldn't show to show that the mouse is on. I had to wiggle the usb for the mouse to turn on. This usually takes 5 to 10 minutes because I have to get it in the right position, because if I...
Hardware & Devices
anybody no of a good ftp server that works good with 7
hey all i am just asking about a nice easy to use ftp server for windows 7 as for the ones i have tryed out are well lets say crap keep crashing or not responding or don't work how they are ment to so i fort i would give it ago see if you guys can help me out once more
Network & Sharing
Logitech wireless mouse - crazy left mouse button
Hey all, I just installed Windows 7 earlier today. The install went fine, until right near the end. I had to click 'next' to a question, which I had already done a few times, but this time the tab was not responding. I tried again and again, then finally just hovered over the tab and pressed...
Hardware & Devices


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 04:36.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App