Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: i/o device error external hard drive please help me anyone

16 Jan 2014   #1
ppcit

Windows 7 Ultimate x32
 
 
i/o device error external hard drive please help me anyone

can anyone please help me? I divided 1TB WB Element to 4 part but they're not showing up on 'my computer' but i can safely remove the hardware, still the partition doesn't show up as usual just 'eject elements 1042'. can it get repair without losing the files? -1.jpg

-2.jpg

-3.jpg

Name:  4.jpg
Views: 33
Size:  93.5 KB

-5.jpg



please help me. much appreciated




My System SpecsSystem Spec
.

17 Jan 2014   #2
badger906

Windows 7 Ultimate x64, & Mac OS X 10.9.2
 
 

I dont want to cause panic.. but.. I/o errors are normally always related to knackered hardware.. I.e your hard drive.

theres a few things you can try first.

The standard Microsoft protocol is to first check that windows is fully up to date incase youre missing a key upated system file.
Next you could try uninstalling your usb drivers in device manager and reboot. (youll loose control of any usb device plugged in before the reboot).
It might not seem the most logical thing to try but it was suggested to me once and it did the trick for my issue.

Failing that Microsoft q and a also suggests shrinking the partitions if possible using disc manager.
My System SpecsSystem Spec
17 Jan 2014   #3
ppcit

Windows 7 Ultimate x32
 
 

thank you
i'll give it a try
My System SpecsSystem Spec
.


17 Jan 2014   #4
grazcy

windows 7
 
 

Same problem, didnt work. I trying partition recovery wizard on minitool partition wizard home edition. Still scaning now take 2days to finish.
My System SpecsSystem Spec
17 Jan 2014   #5
whs
Microsoft MVP

Vista, Windows7, Mint Mate, Zorin, Windows 8
 
 

That could be a connection problem - especially with the power cable. I have seen these kinds of problems when the disk does not get enough juice.
My System SpecsSystem Spec
17 Jan 2014   #6
grazcy

windows 7
 
 

Whs how to get enought power? Try to use minitool pratition to scan it for 2 days already! The hard disk light is flashing, u sure not enought power?
My System SpecsSystem Spec
17 Jan 2014   #7
whs
Microsoft MVP

Vista, Windows7, Mint Mate, Zorin, Windows 8
 
 

Maybe the power cable is somewhat loose or there is a glitch in the PSU. But that is only 1 possible cause. As I said, that was the case I have seen. But that was an external HDD on a USB powered hub. Once that was connected to an outlet powered hub, the problem was resolved.
My System SpecsSystem Spec
18 Jan 2014   #8
jumanji

Windows 7 Home Premium 32 bit
 
 

Hi ppcit,

Hard disks these days have extensive error-correcting capabilities; when you start seeing I/O errors, that means that the built-in error correction is no longer able to correct for the errors. That normally means the disk is very close to outright failing, if it hasn't already failed.

In your description of the problem, you said you partitioned the drive into four. Did the I/O error occur immediately after partitioning or was it partitioned much much earlier?

The second point I do not understand is why you used Seagate Seatools diagnostic/repair utility instead of Western Digital Data Life Guard Diagnostic for Windows. WD Support / Downloads / My Cloud Apps + Other Products / Data Lifeguard Diagnostic for Windows Go ahead and check your hard disk with this utility and check whether it is able to repair it. There are better chances with it, rather than SeaTools on a Western Digital.
My System SpecsSystem Spec
20 Jan 2014   #9
ppcit

Windows 7 Ultimate x32
 
 

Than you guys for replying

Hi jumanji,
The error was occured long after the partition.
I think it started with bad sector, so everytime I opened one of the partitions, my windows explorer froze for awhile and sometimes restarting itself, and I think that makes the bad sector problem even worse. I did the check now from the properties, but it just kept happening.

And what annoys me the most is the effect of those problem, they make the transfer datas speed so slow,
And at one point when I tried to copy thing to the HD, it just froze and when I tried to reconnect my laptop and the hd, that i/o thing happened

Any by any chance, will the tool you told me delete the files in the hd?
My System SpecsSystem Spec
20 Jan 2014   #10
jumanji

Windows 7 Home Premium 32 bit
 
 

No. That is the Western Digital's official tool to diagnose and repair (if possible) Western Digital HDDs.

That is why I didn't understand why you used the Seagate tool.

So go ahead and check your Western Digital HDD with Data Lifeguard Diagnostic for Windows.
My System SpecsSystem Spec
Reply

 i/o device error external hard drive please help me anyone




Thread Tools





Similar help and support threads
Thread Forum
External Hard Drive error ~$WV.FAT32
Hi, I'm having troubles on opening my hard drive. 1st, there was this Shortcut virus that affected my external, i thought it was just a simple virus cause it just creates shortcuts of your files instead of getting to it directly. So after a day, i decided to fix it my self. But as always...
Hardware & Devices
External hard drive not recognized on anything other than device mgr
My WD Elements external hard drive was working great until one day it failed to be recognized in explorer. I've tried it on multiple PC's and it does the exact same thing. It shows up in device manager as properly working and also even shows up in devices and Printers and BIOS and Windows will...
Hardware & Devices
My Passport External Hard Drive Initializing Error
Hi Everyone! So here the problem, I got a Western Digital My Passport 1 TB External Hard Drive with 700 GB of Important Data. Guess what? No backup and the Hard Drive is not functioning! ..and I need the Data Back and possibly the drive working too! I have tried the drive in several PCs so...
Hardware & Devices
External hard drive found as unknown device
I have a LaCie external hard drive which works fine on other pc's running Windows 7 Ultimate, but on this one it is an "unknown device". I have tried it in different ports but with the same result. I've checked with Windows Compatability and the exact model is listed there as being compatible. I've...
Hardware & Devices
Error 0x80070057 moving files to External Hard Drive? Help
Just bought a 250 GB Seagate External USB Hard Drive. While Transferring/Copying all the folders and files from my Desktop contents (12 GB) I received the following Windows(Not Seagate's) Error which was "0x80070057" ALSO:I made sure no file being transferred was IN USE by any process so...
Hardware & Devices
Error booting from external hard drive
Hello, I am trying to wipe my current XP installation clean and move on to Windows 7. I first tried to install the setup.exe (Custom install option of course) from within the XP OS, but soon discovered you cannot do that and wipe out my only partition on C: at the same time. I don't have a...
Installation & Setup

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 14:20.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App