Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Imaging Devices - Unknown Device

14 Feb 2014   #1
jmrpjb

Microsoft Windows 7 Home Premium 64-bit 7601 Multiprocessor Free Service Pack 1
 
 
Imaging Devices - Unknown Device

I have attached a view of what's listed in my device manager because there are two "unknown devices" listed under "Imaging Devices" and I have no idea what they are. The manufacturer is Creative Technology Ltd. but that's about all I know. Every time I start up my PC I get the message, "updating drivers" and then, "update failed" but the only thing that's not working properly is I can't seem to upload photos from my Canon Powershot any more. (That is in another post)

Does anyone know if these are connected?




Attached Thumbnails
Imaging Devices - Unknown Device-unknown.jpg  
My System SpecsSystem Spec
.
14 Feb 2014   #2
maxie

windows 7 home 64bit
 
 

Hi there .. Difficult to see that Screenshot .. Follow the Link below .. Looks like a Scanner HP ?

Screenshots and Files - Upload and Post in Seven Forums
My System SpecsSystem Spec
15 Feb 2014   #3
jmrpjb

Microsoft Windows 7 Home Premium 64-bit 7601 Multiprocessor Free Service Pack 1
 
 

Here's another attempt at the screenshot:Imaging Devices - Unknown Device-unknown.jpg

And a larger versionImaging Devices - Unknown Device-unknown2.jpg

(it doesn't appear any larger when I preview this post?)

Anyway, back to my 'unknown device'. As I indicated, the only thing that's not working properly (as far as I know) is my Canon Powershot but that can't be what 'unknown device' represents, can it?

And, just to let you know, I'm using a Brother aio printer, scanner, copier, fax and the web cam that came with the PC is working fine.

Any thoughts?

Thank you for your help.


My System SpecsSystem Spec
.

15 Feb 2014   #4
maxie

windows 7 home 64bit
 
 

Hi there .. Its very difficult to see .. Go to the Unknown Device select it right click then Property's Details if there is a Hardware ID there please post it .. I have really bad eye sight ..
My System SpecsSystem Spec
15 Feb 2014   #5
jmrpjb

Microsoft Windows 7 Home Premium 64-bit 7601 Multiprocessor Free Service Pack 1
 
 

There are 3 tabs for Unknown Device Properties
GENERAL
DRIVER
DETAILS
GENERAL - type: Imaging devices
- manufacturer: Creative Technology Ltd.
- Location: Unknown
DRIVER - Driver version: 2.0.36.0
- Digital Signer: Microsoft Win Hardware
Compatibility Pulisher
Driver Details:
C:\\Windows\system32\CtClsCol.dll
C:\\Windows\system32\DRIVERS\CtAudDrv.sys
C:\\Windows\system32\DRIVERS\CtClsFlt.sys
C:\\Windows\system32\drivers\ksthunk.sys
DETAILS
Property: Device class guid
Value: {6bdd1fc6-810f-11d0-bec7-08002be2092f}
My System SpecsSystem Spec
15 Feb 2014   #6
maxie

windows 7 home 64bit
 
 

Hi there ... I was hoping for a Hardware ID PCI Ven Numbers ... Do you have a Webcam ?
My System SpecsSystem Spec
15 Feb 2014   #7
maxie

windows 7 home 64bit
 
 

Imaging Device
Class = Image
ClassGuid = {6bdd1fc6-810f-11d0-bec7-08002be2092f}
This class includes drivers of still-image capture devices, digital cameras, and scanners.
My System SpecsSystem Spec
15 Feb 2014   #8
maxie

windows 7 home 64bit
 
 

Just read your other Post .. Looks to be the Camera is the problem ..
My System SpecsSystem Spec
15 Feb 2014   #9
jmrpjb

Microsoft Windows 7 Home Premium 64-bit 7601 Multiprocessor Free Service Pack 1
 
 

I was looking at some of the other, (similar problems) posts and one refers to the card reader driver. I'm leaning toward the problem being the card reader in my PC. When I insert the card I click it in (I hear the clicking sound) but then I can just pull it out without having to click it in again. (I hope you know what I mean). Also, I was able to see 2-1/2 pics out of about 20. I mean I was able to open them; the rest just remain icons which nothing will open (I.E., Paint, WMP etc.). So, this makes me think it's not the camera or the card, but the card reader.


Oh, one more thing. When I plug the camera in with a usb cable, nothing seems to happen. (Just to reiterate, when I insert the card, the list of programs changes to include CANON_DC (E but there's no file with pics in it.) The file where I used to find the pics wascalled DCIM but nothing like that appears now.
My System SpecsSystem Spec
15 Feb 2014   #10
maxie

windows 7 home 64bit
 
 

Hi there You have a DEll 2020 all in one ... I could not find any Drivers on Dell Website for your Card Reader .. How ever I think the one below might work .. If there is a problem with it ...


Driver Details | Dell US
My System SpecsSystem Spec
Reply

 Imaging Devices - Unknown Device




Thread Tools Search this Thread
Search this Thread:

Advanced Search




Similar help and support threads
Thread Forum
Device Manager - Finding Unknown Devices
Find and Identify Unknown Devices through Device Manager This guide will show you how to locate the unidentified hardware in your device manager by using Hardware Identification. The goal of this tutorial is to help identify an unidentified device.Prerequisite knowledge includes opening...
Tutorials
Audio USB Devices showing under Other Devices in Device Manager
Hi! I have two USB audio devices that I cannot seem to properly install drivers for. Focusrite Scarlett 2i2 & KORG MicroKONTROL I am in communication with both product tech support teams but so far they have not offered a successful solution. As the same issue is occurring with multiple...
Hardware & Devices
PCI device, SM Bus Controller and two unknown devices not downloaded
Hello, whenever I go onto device manager and then into "other devices" there are 4 devices that havent had a driver downloaded. The PCI device, the SM bus Controller and two "unknown" devices. What should I do? Please tell me if you need more information about my computer, ill be happy to provide.
Drivers
Unknown Device in Device Manager/Show Hidden Devices
I have a Toshiba laptop, model L505-ES5018. I had Windows 7 Home Premium 64 bit installed on here, but decided to reformat my hard drive using Windows 7 Ultimate 64 bit. After the reformat was finished, I ran Windows Update and it found several items to download and install for me. I noticed...
Drivers
Imaging Win7 Pro SP1 onto 25 Identical Devices
Morning, my name is Chauncey and I've got 25 identical Motion CL900 tablets to set up for field use. I was wondering if it was possible to image one device after it's been setup and re-image the other 24 tablets with the created image. I know its *possible* but will there be issues with the...
Backup and Restore
base system device, video controller and unknown device missing
hie i have just installed window 7 and this devices are missing, any help will be very much appreciated. base system device device id PCI\VEN_1217&DEV_7110&SUBSYS_117C10&PEV_00 PCI\VEN_1217&DEV_7110&SUBSYS_117C10CF PCI\VEN_1217&DEV_7110&CC_088000 PCI\VEN_1217&DEV_7110&CC_0880 UNKNOWN...
Drivers


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 20:02.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App