Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Query re PCI slots

08 Mar 2014   #21
Britton30
Microsoft MVP

Windows 7 Ultimate X64 SP1
 
 

Sorry you are having so much trouble John. The blue card may be dead on arrival mate.

Try this if you haven't.
Power off and put either card in the white slot, boot it up and check in Device manager for Unknown Device or something under USB with the yellow triangle .

If you have either, right click it/Update Drivers and see if it will work.
If not, run Windows Update manually to see if it will be picked up. Try it with both cards.


My System SpecsSystem Spec
.
08 Mar 2014   #22
ICIT2LOL

Desk1 7 Home Prem / Desk2 10 Pro / Main lap Asus ROG 10 Pro 2 laptop Toshiba 7 Pro Asus P2520 7 & 10
 
 

Yep Gary did all that mate and I even tried them both again in the small top slot and also the balck slot under the sound card - there was a triangle on the two port one - at least I think it was for it and it did light up but I think only because of the Molex power supply.
The four port one I think is as you say DOA and frankly the excessive slop in the sideways movement of both cards is in my mind indicative now not of the board slot fittings but the shoddy Astrotek cards. I can move them side to side at least half and inch east / west of centre.
As you will know cards are usually quite snug when you insert them and these just fell in.

I have now bought a powered external hub (3.0) off Ebay from an Aussie dealer and will use one of the through cable ports to connect it - to be honest it will be easier to access and for that matter a third of the cost of the other pieces of rubbish that I am going to return to PCCG.

Never again will I buy Astrotek products if this sort of garbage is put out by them.
My System SpecsSystem Spec
08 Mar 2014   #23
Britton30
Microsoft MVP

Windows 7 Ultimate X64 SP1
 
 

You might clean the slots with your card and alcohol as you've told people to clean RAM slots.
They won't be held really solid being an X1 slot. The slot isn't designed to be the mount, rather the screw on the back bracket. A GPU has 5 times the length and may seem somewhat snugger. You should be able to return the Astrocrap card for a refund or exchange for a different one.

In the folders on that driver disk, did you find something with an .exe extension? Ergo, setup.exe or install.exe?
My System SpecsSystem Spec
.

08 Mar 2014   #24
ICIT2LOL

Desk1 7 Home Prem / Desk2 10 Pro / Main lap Asus ROG 10 Pro 2 laptop Toshiba 7 Pro Asus P2520 7 & 10
 
 

Well tried it once more and it has been detected and the driver installed but it is not showing up in Computer as a drive

At least I think it is the card I have arrowed in pic.


Attached Thumbnails
Query re PCI slots-ren1.png   Query re PCI slots-ren2.png  
My System SpecsSystem Spec
08 Mar 2014   #25
Lady Fitzgerald

Win 7 Ultimate 64 bit
 
 

Quote   Quote: Originally Posted by ICit2lol View Post
Well tried it once more and it has been detected and the driver installed but it is not showing up in Computer as a drive

At least I think it is the card I have arrowed in pic.
Are you sure it's supposed to show up as a drive. I'm thinkin' it will show up as a drive only if you have an external drive plugged into one of the ports
My System SpecsSystem Spec
08 Mar 2014   #26
ICIT2LOL

Desk1 7 Home Prem / Desk2 10 Pro / Main lap Asus ROG 10 Pro 2 laptop Toshiba 7 Pro Asus P2520 7 & 10
 
 

Yep Jeannie I have a WD Passport 500GB external plugged into one of the ports. That is the one with the small power LED in it so I know it is connected.
My System SpecsSystem Spec
08 Mar 2014   #27
ICIT2LOL

Desk1 7 Home Prem / Desk2 10 Pro / Main lap Asus ROG 10 Pro 2 laptop Toshiba 7 Pro Asus P2520 7 & 10
 
 

Found the problem - my 500GB Seagate in the front dock is not being detected or is dead or the dock is defunct. So am going to install it into the main drive bay area.
My System SpecsSystem Spec
08 Mar 2014   #28
Britton30
Microsoft MVP

Windows 7 Ultimate X64 SP1
 
 

Progress at least. Check all of your cables inside John. Since you been "messing about" in there you may have pulled a SATA, eSATA, or power connector loose. You should disconnect and reconnect each one to confirm it is indeed plugged in.
My System SpecsSystem Spec
08 Mar 2014   #29
ICIT2LOL

Desk1 7 Home Prem / Desk2 10 Pro / Main lap Asus ROG 10 Pro 2 laptop Toshiba 7 Pro Asus P2520 7 & 10
 
 

Ok mate will do later as I have to dash to you know where now but I do think the pressure of pushing the dock drive in has done something to the small PCB at the back which holds the SATA and power connections.

never mind that drive can go into the internal bays I have five spare

John
My System SpecsSystem Spec
08 Mar 2014   #30
Britton30
Microsoft MVP

Windows 7 Ultimate X64 SP1
 
 

It all takes a deft hand mate, it's not plumbing.
My System SpecsSystem Spec
Reply

 Query re PCI slots




Thread Tools Search this Thread
Search this Thread:

Advanced Search




Similar help and support threads
Thread Forum
RAM 4 slots or 2?
Hey all, What is generally considered better and why? I'm considering a RAM upgrade to 16GB for my Asus Maximus Hero VI motherboard. It has 4 memory slots for dual channel. My local supplier only has the memory I want in 2x4GB modules. If I purchase 2 kits to make up the 16GB is this less...
Hardware & Devices
RAM slots
Hi, Is there any impact on the performance of a laptop under the following scenarios: 1) 6GB of toal RAM - 2GB in one slot and 4GB in another slot OR 2) 8GB of toal RAM - 4GB in one slot and 4GB in another slot. (ofcourse 8GB is larger than 6GB ........... but ......... I cannot...
Hardware & Devices
What slots are these?
My brother brought home a computer that his college was going to trash, and there's no model printed anywhere on it. What slots are those available?
Hardware & Devices
Need More SATA Slots
I have been looking at the prices for a SSD. I had planned on keeping my other two HD as they both have a function. == I checked my Motherboard today and was surprised to find I only have two SATA slots which are both being used. My Motherboard was purchased when I had a PC built in 2006. It...
Hardware & Devices
How can you tell if your RAM slots are bad?
I've come to a conclusion that I think my RAM slots are bad,as my computer keeps crashing and i've run out of other ideas..
Performance & Maintenance
RAM in all the slots is a bad thing??
I have an ASUS P6T Deluxe Ver. 2 with (now), 6gb of RAM. Recently, while ordering another machine, I asked for 12 GB in all the slots and the salesman talked me against it. He said it's not good to fill all the slots. This is on another ASUS P6T and using Corsair Dominator 12800 @ 1600 mHz. Can...
Hardware & Devices


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 10:44.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App