Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Missing Hardrive, Windows won't boot?

14 Mar 2014   #1
TJGOA

Windows 7 Home Premium 64-bit SP1
 
 
Missing Hardrive, Windows won't boot?

I have a asus p5n-e sli windows 7 with two hard drives each with 500gb. I have windows installed on HD 1 and it isn't showing up in bios setup or select boot device so windows won't boot. I had a power outage in my area and afterwards seems like the computer can't find hd that windows is installed on?? Any help with this would be very much appreciated..

I don't think its MBR because in the setup bios there should be two WD Hard drives showing up but only one is. I assume the missing one is where windows 7 is installed cause when I try to boot from the other drive just a bleeping cursor shows then reboots. Even if the MBR is missing shouldn't the HD still show up as a boot option and show is the bios HD menu? Sometimes when I boot up and go to boot selection menu the missing one shows up but without any other info, the other hd shows the type ie WD with alot of numbers etc..... while the other one is just blank?

I just made sure both sata were connected right and swapped connections and still won't boot. The only thing that changed was at first two drives were listed and the top one had no other info and after swap the bottom one was the one with no info from the boot menu after pressing f8. It didn't work so I decided to just switch them back the way they were connected before just in case.on the hard drives there were two cables connected to each drive, one that says sata and was wider and a smaller one right next to it, I just swapped both cables from both hd's.

Ok just checked and noticed that the smaller cables from each drive are connected to the mobo and right next to each other, should I disconnect this and swap as well? Is this the psu?


My System SpecsSystem Spec
.
14 Mar 2014   #2
ICIT2LOL

Desk1 7 Home Prem / Desk2 10 Pro / Main lap Asus ROG 10 Pro 2 laptop Toshiba 7 Pro Asus P2520 7 & 10
 
 

TJGOA Mate sounds like the power outage may have wrecked the drive. It does spin up I am assuming? and you should try the disconnecting the secondary drive and try booting using the one with Windows on it.

Any chance of some pics of the cabling as I don't understand what you mean by there is is smaller cable next to the SATA data one there should be one about twice the width of the SATA plug which is the power cable. see pic


Attached Images
Missing Hardrive, Windows won't boot?-sata.png 
My System SpecsSystem Spec
14 Mar 2014   #3
Layback Bear

Windows 7 Pro. 64/SP-1
 
 

I have never had a power outage hurt anything but I do use surge protectors.
I have had power outages make me reset the cmos again on older systems. Using the instruction from the motherboard manual is the best way to reset cmos but here are some other methods.

How To Clear CMOS (Reset BIOS)
My System SpecsSystem Spec
.

14 Mar 2014   #4
TJGOA

Windows 7 Home Premium 64-bit SP1
 
 

Quote   Quote: Originally Posted by ICit2lol View Post
TJGOA Mate sounds like the power outage may have wrecked the drive. It does spin up I am assuming? and you should try the disconnecting the secondary drive and try booting using the one with Windows on it.

Any chance of some pics of the cabling as I don't understand what you mean by there is is smaller cable next to the SATA data one there should be one about twice the width of the SATA plug which is the power cable. see pic
Your pic clears everything up thanks. Is there some software that I can boot from usb to see if it reads the hd with windows on it and check for errors, I want to make sure now that it isn't an MBR issue? Just in case I might want to install windows again on the other HD, hopefully I can salvage the files from the other drive but if windows isn't booting from the drive maybe that's a no go? Is there some other way to boot into the system to get my files from it?
My System SpecsSystem Spec
14 Mar 2014   #5
ICIT2LOL

Desk1 7 Home Prem / Desk2 10 Pro / Main lap Asus ROG 10 Pro 2 laptop Toshiba 7 Pro Asus P2520 7 & 10
 
 

Hum Layback I was thinking more of the controller on the drive not the physical drive itself.

Well I don't know about checking for errors but you can certainly recover data with this.

BOOTABLE UBUNTU

Make a bootable Ubuntu disk http://www.ubuntu.com/download

Set the BIOS to boot from theoptical when the machine boots it will show you a screen with TRY or INSTALL> select TRYnot INSTALL

When it is finished - it takes verylittle time you will get a screen like in the pic .

Open the drive you want > Userand dig down until you get to the data / settings you may be able to copy /paste the material you want to an external source or other installed drive doingthis.

I am not sure if it will but I haverecovered tons of data etc using this method both on "dead" or justplain drives that you cannot get data from using Windows.
You can still access the net with this too as in my pic.

For a reinstall if you have to use this. Clean Reinstall - Factory OEM Windows 7


Attached Thumbnails
Missing Hardrive, Windows won't boot?-ubuntu-screen.png  
My System SpecsSystem Spec
14 Mar 2014   #6
TJGOA

Windows 7 Home Premium 64-bit SP1
 
 

Thanks will try ubuntu right now and see if that works, How do I make it bootable from usb though, should I try poweriso make bootable usb option or is there another way for ubuntu?
Just found this, http://www.ubuntu.com/download/deskt...ick-on-windows
will i be able to use the try now function using this method?
My System SpecsSystem Spec
14 Mar 2014   #7
ICIT2LOL

Desk1 7 Home Prem / Desk2 10 Pro / Main lap Asus ROG 10 Pro 2 laptop Toshiba 7 Pro Asus P2520 7 & 10
 
 

Download the boot disk from Unbuntu onto the stick - set the BIOS to boot from the USB and power up.

I use Imgburn for making my stuff but you can use what you like
The Official ImgBurn Website
My System SpecsSystem Spec
14 Mar 2014   #8
jumanji

Windows 7 Home Premium 32 bit
 
 

Hi TJGOA,

You can create bootable USB pen drives easily with Rufus Rufus - Create bootable USB drives the easy way
My System SpecsSystem Spec
15 Mar 2014   #9
TJGOA

Windows 7 Home Premium 64-bit SP1
 
 

Thanks Ubuntu works like a charm and I was able to salvage all the data from the drive which is just awesome. Seeing that I was able to salvage the data doesn't this mean the drive still works, so why can't windows boot up? Maybe I'm missing the boot files after all? Maybe a partition is marked as inactive where the windows is installed to? Funny thing is that in ubuntu only one drive shows up, the one with the windows installed and the other isn't showing up, but from the bios menu the exact opposite is happening. Anybody have any idea what could be going on here? Would anyone recomend some software I could run in ubuntu to solve this, maybe partition software, disk repair, disk management,, etc??
My System SpecsSystem Spec
15 Mar 2014   #10
jumanji

Windows 7 Home Premium 32 bit
 
 

Check whether you can see the system drive and the second drive with Partition Wizard booting from the pen drive.

Download the bootable CD version of the Partition Wizard and create your bootable pen drive again with Rufus.

If Partition Wizard can see it take a snapshot and post it.

Let us see what its status is.

Downloadable Bootable CD version of the Partition Wizard Home Edition 8.1.1 : Free download Magic Partition Manager Software, partition magic alternative, free partition magic, partition magic Windows 7 and server partition software - Partition Wizard Online
You already have the link for Rufus.

EDIT: I do not know why Ubuntu does not see the other drive. May be ICit2 can throw some light on it.
Usually in Linux there is a process to mount the drives.
My System SpecsSystem Spec
Reply

 Missing Hardrive, Windows won't boot?




Thread Tools Search this Thread
Search this Thread:

Advanced Search




Similar help and support threads
Thread Forum
Bootmgr.exe missing... mpio.sys missing or corrupted. Unable to boot
I just got a computer for free, a Dell Studio 1555. When I got it, it would try to boot, then come to a screen that said that bootmgr.exe was missing. Sometimes I got a message that said something like mpio.sys was corrupted or missing. I have a Win 7 disk, so I put it in and tried to repair the...
General Discussion
Missing drivers /Troubleshoot hardrive issue
Hi, I have a nagging issue that is an irritation rather than a fault I guess. A while ago i had a HP photosmart B110 rev.A wireless printer that had a reknowned software issue where windows would not see it and you had to reinstall the software again ...and again and again... In the end I...
Drivers
Cannot boot my laptop, windows can't find any hardrive to boot OS..
Today when I was surfing on my laptop (G74S Series) I wanted to restart the laptop because the internet crashed and it usually helps to restart. But I restarted it holding down the power button thing. So, I restarted it and while I was waiting, staring in to the screen, the blinking "_" thing when...
Hardware & Devices
Restore points missing from windows 7 after i boot in Xp(dual boot)
I have dual boot with Xp and windows 7.when i log into my Xp all the restore points being deleted from windows 7. when i check the disk management information in 7 it shows windows 7 create a logical drive with my Xp primary drive.even i am hide the drive from both windows means Xp drive from...
Performance & Maintenance
boot manager missing windows 7
hello everyone i have accidentally deleted boot file from my OS and after the restart my laptop says "boot mgr is missing" i even tried to reinstall windows 7 home premium by a c-r-a-c-k software ! i even tried it with my USB pen drive ... nothing seems to work .. i even changed the BIOS boot...
Installation & Setup
Windows 7 boot logo missing
Hey everyone, this may sound as some standard thread but i really tried everything to fix this. I got two problems: - Windows 7 logo is missing ( using Vista standard ) - bootrec can't find a windows installation (/scanos) which prevents me from using the /rebuildbcd command. What I've...
Installation & Setup


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 15:58.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App