Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Thumb drive not recognized in two of three ports

18 Mar 2014   #21
Torah Lishmah

Windows 7 Enterprise SP1 x64
 
 

I have read through this entire thread, and I have a quick suggestion to make before the OP attempts a BIOS update. Have you checked all the settings in the BIOS to make sure that all the USB ports are enabled? I've encountered this problem many times while working on customer computers. If I'm stepping on your toes at all Maxie, just say the word and I'll keep my suggestions to myself.


Sometimes desktop PC's will even have the USB header jumpers closed/open for certain USB ports that need to be enabled/disabled manually.


My System SpecsSystem Spec
.
18 Mar 2014   #22
mrbookend

Windows 7 Home Premium 64bit
 
 

Hi Torah, Thanks for the suggestion and please keep them coming. I am a real novice at diagnostics so please bear with me.
As need to get over apprehension of making changes as always worried I'll make a fatal error.I will google how to check bios settings and let you know what I find.Thanks so much,Randy
; Some other things I have done (with trepidation) which has NOT fixed problem:Uninstalled all Host Controllers in Device Manager then rebooted to reinstallDeleted all unused drivers (must have been 50 to 75 of themWent to my computers website to update all drivers then verified with Intel download site for their components Can't remember exactly how I did it but set power to be always on to USB ports</p>
My System SpecsSystem Spec
18 Mar 2014   #23
mrbookend

Windows 7 Home Premium 64bit
 
 

Entered Bios but under Advanced was no mention of USB. So used REGEDIT to make sure setting value was 3 in services USBSTOR which should enable the USB ports.

May be resigned that this is a hardware problem rather than software. Also checked in DevMgr to make sure that the root hubs were all enabled.
My System SpecsSystem Spec
.

18 Mar 2014   #24
maxie

windows 7 home 64bit
 
 

Quote   Quote: Originally Posted by Torah Lishmah View Post
I have read through this entire thread, and I have a quick suggestion to make before the OP attempts a BIOS update. Have you checked all the settings in the BIOS to make sure that all the USB ports are enabled? I've encountered this problem many times while working on customer computers. If I'm stepping on your toes at all Maxie, just say the word and I'll keep my suggestions to myself.


Sometimes desktop PC's will even have the USB header jumpers closed/open for certain USB ports that need to be enabled/disabled manually.
Hi Torah I welcome any ones help Just wish a solution could be found for the OP .. Personally i think the Ports are dead ..
My System SpecsSystem Spec
19 Mar 2014   #25
Torah Lishmah

Windows 7 Enterprise SP1 x64
 
 

Quote   Quote: Originally Posted by mrbookend View Post
Entered Bios but under Advanced was no mention of USB.
Enabling those USB ports may not be under "Advanced" though. Go through the entire BIOS thoroughly to make sure all USB ports are enabled. It may be in the "Integrated peripherals" settings. That is usually the case. Let me know if you find some USB settings that are disabled. If so, go ahead and enable them.

Quote   Quote: Originally Posted by mrbookend View Post
So used REGEDIT to make sure setting value was 3 in services USBSTOR which should enable the USB ports.
I would discourage you from messing around with the Windows registry unless you know exactly what you are doing. There is nothing in the registry that is relevant to this problem anyway.

Quote   Quote: Originally Posted by mrbookend View Post
May be resigned that this is a hardware problem rather than software. Also checked in DevMgr to make sure that the root hubs were all enabled.
Were they enabled? Don't give up yet, we just started the diagnostics. Have a little patience, we will get it figured out.
My System SpecsSystem Spec
19 Mar 2014   #26
Torah Lishmah

Windows 7 Enterprise SP1 x64
 
 

Quote   Quote: Originally Posted by maxie View Post
Hi Torah I welcome any ones help
Okay, thanks. Just wanted to check and make sure you were cool with some additional help. I ran into a guy the other day that got offended at me for having a difference in opinion. I need to argue with people over IT issues like I need a hole in my head....LOL
My System SpecsSystem Spec
19 Mar 2014   #27
mrbookend

Windows 7 Home Premium 64bit
 
 
Pretty sure Dead Ports

In a last final effort to ensure that I have dead ports, I downloaded UBUNTU and ran from USB stick on my one good USB port. Ubuntu also wouldn't recognize a device plugged into the two ports on left side. Guess I'll live with one port. Hopefully, it doesn't die. Thanks for help..
My System SpecsSystem Spec
19 Mar 2014   #28
maxie

windows 7 home 64bit
 
 

We where not of much help but at least you where able to determine what the problem is .. That was a good idea to use Ubuntu
My System SpecsSystem Spec
19 Mar 2014   #29
mrbookend

Windows 7 Home Premium 64bit
 
 

Don't sell yourself short: Solving what is working was as important as figuring out what wasn't working. Thanks for helping me and others.
My System SpecsSystem Spec
19 Mar 2014   #30
maxie

windows 7 home 64bit
 
 

Most welcome
My System SpecsSystem Spec
Reply

 Thumb drive not recognized in two of three ports




Thread Tools Search this Thread
Search this Thread:

Advanced Search




Similar help and support threads
Thread Forum
Thumb drive not recognized
I have both a desktop and a laptop running Win7. I use a password manager on my desktop and decided to copy the password manager to a thumb drive to use on the laptop. I copied the folder to the thumb drive and checked it's operation on the desktop and it worked fine. I plugged the thumb drive into...
Hardware & Devices
ASUS A78M-A, front USB 3 ports, not recognized
Hi, ive just bought in a batch of ASUS A78M-A motherboards for some customers, fully installed with the latest chipset drivers from AMD, thought I should check the front USB 3 ports to find it comes up with anything plugged in (USB3 WD external drive + 16Gb Sandisk dongle) as "Not Recognized". ...
Hardware & Devices
All USB ports don't recognized usb drives but do see other devices
I can't remember exactly how this happened because it's been a cascading disaster. It started with my efforts to uninstall Crashplan. In the course of this I unplugged one usb drive (I have 6) from a hub while it was on. At the time everything seemed ok, but it was not the case once I shut down...
Hardware & Devices
Flash/SD no longer recognized by Win7, but USB ports work
I have a new system based on ASUS SABERTOOTH X58 running Win 7 x64. The system includes support for USB3 and I recently started using 2 WD Passport 1T external USB3 drives for backup. I've encountered 2 problems since I started using these drives, I don't know if they are related. One is a boot...
Hardware & Devices
USB device not recognized, only at 4/12 ports
Hello I have Kingston 2GB DataTraveler (DT) and windows 7 RTM 64bit does not recognize it when pluged into 2 front usb ports or 2 top back usb ports. Other 6 lower back ports work. I have Gigabyte GA-EP35-DS3 mobo. This mobo has 8 usb on the back and 2 usb headers. One header is used for Codegen...
Drivers
Nothing is recognized thru USB Ports Win7rc 7100
Can anyone help me i'm running win7rc build 7100 and none of my usb ports are properly working.external drive lights up but will not show up in explorer.no flash drives not even PCMCIA card with usb ports.PCMCIA card drivers install but usb ports don't work (WTF MS).In device mng. there is no...
Hardware & Devices


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 10:10.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App