Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: 1TB WD external hard disk not initialized

20 Mar 2014   #1
kaufmann

Windows 7 Home Premium 64bit.
 
 
1TB WD external hard disk not initialized

I have an WD 1TB hard disk which failed to initialize recently. It gives me an I/O error message. I found a few old threads here with similar problem and tried out the suggested steps. I ran WD diagnostic tool and passed the Quick test and Extended test(Screenshot attached). I would like to avoid the zero test and formatting of my data if possible. The hard disk is almost full and recovering them after formatting would be really painful. I would be really grateful if someone could please help me out?




Attached Thumbnails
1TB WD external hard disk not initialized-untitled.jpg  
My System SpecsSystem Spec
.
22 Mar 2014   #2
HarriePateman

Windows 7 Ultimate 64-bit
 
 

Is you have a empty hard drive kicking about or somewhere to store you data, move it all to there.
Then format you drive, see if that works.
My System SpecsSystem Spec
22 Mar 2014   #3
sygnus21

Windows 10 Pro
 
 

Hi kaufmann,

For some reason sometimes a drive may lose it's drive letter? I've had this issue a few times with my WD Passport drive at times. Anyway....

- Can you see it in Disk Management?

- If so, does it have a drive letter assigned?

- If not, right click the drive and assign a letter to it.

- Is it working now?

You might also try swapping cables, or if possible, use a shorter one.

Let us know.
My System SpecsSystem Spec
.

22 Mar 2014   #4
kaufmann

Windows 7 Home Premium 64bit.
 
 

Hi guys.. Thank you for your replies! I really appreciate it!!!

As for my issue, the hard disk does not get initialized. It appears as an virtual CD in My computer(screenshot attached). When i try to initialize it, I get an I/O error(screenshot attached).

To find the problem, I ran the WD diagnostic tool and it passed both the tests, as you may have noticed from the screenshot of my earlier post.

I am not sure what the problem is... Any suggestions?


Attached Thumbnails
1TB WD external hard disk not initialized-untitled1.jpg   1TB WD external hard disk not initialized-untitled.jpg  
My System SpecsSystem Spec
22 Mar 2014   #5
jumanji

Windows 7 Home Premium 32 bit
 
 

1. What is the exact model Number of your Western Digital Passport?

2. Did it come with Smartware and did you install it?

3. Have you at anytime used a virtual CDROM drive? If so when and for what purpose?

4. From when did this problem crop up?

5. Can you recollect anything that you did to your PC after which this problem cropped up? - such as installing a new software, playing a new Game etc.,
My System SpecsSystem Spec
22 Mar 2014   #6
kaufmann

Windows 7 Home Premium 64bit.
 
 

Hi Jumanji...

1. The exact model number is 0748
2. Yes, it did come with an smartware and I did install it.
3. I use virtual CDROM to install games using Daemon tools Lite. I guess the last time I used it was probably last month.
4. From last Sunday.
5. The last thing I did was transfer a few files to my friend's laptop. It worked fine. Ever since then, it's not detecting either in my laptop or any other laptop.

I have already tried uninstalling and reinstalling the drivers from disk management, it was of no use.

Also, I tried updating the WD firmware, but it fails and gives me an error.
My System SpecsSystem Spec
22 Mar 2014   #7
jumanji

Windows 7 Home Premium 32 bit
 
 

Quote   Quote: Originally Posted by kaufmann View Post
.........5. The last thing I did was transfer a few files to my friend's laptop. It worked fine. Ever since then, it's not detecting either in my laptop or any other laptop.........
Not even on your friend's laptop where you used it last time?

Is the same friend's same laptop within your reach now? If so connect to it again and if you can access your drive, copy all the contents to another drive. That would be the first thing I would do before I venture on to do anything else.

EDIT: Is it WDBBEP0010BBK? Check the label on the drive and confirm. Is it USB3?
My System SpecsSystem Spec
23 Mar 2014   #8
kaufmann

Windows 7 Home Premium 64bit.
 
 

I tried it on my friend's laptop too... It's the same result.
And yes... It's the same P/N code. It is USB 3.0.
My System SpecsSystem Spec
23 Mar 2014   #9
jumanji

Windows 7 Home Premium 32 bit
 
 

OK. Now do the following.

1. Get into Daemon Tools Settings. Some where in the Settings, there may be a means to disable virtual drives. Disable creation of Virtual drives. Done? leave it at that till your HDD problem is resolved.

2. Remove all external drives/ pen drives/ card readers/USB hubs etc., from your PC.

3. Do a drive cleanup to remove all non-present devices, drive letters and registry entries associated with those.

Download v 0.8.1 of the drivecleanup.zip from Drive Tools for Windows.

Unzip it to a folder, say drivecleanup.

You will have two folders Win32 and x64 each containing DriveCleanup.exe for 32 bit and 64 bit respectively.

Remove all USB storage devices from your system (except your Keyboard and mouse) and reboot.

Right click on the DriveCleanup.exe and run as administrator. (Use the *.exe file appropriate for your bit version of Windows.).

After the clean up act, reboot.

Now connect your 1TB external drive. The drivers will be loaded afresh.

Check whether your drive shows up. If not post a screenshot of Windows Disk Management - Full screen including CD/DVD ROM drives. Also check and tell whether any virtual CDROM drive is present in My Computer.

Now further questions: Are you using Smartware? Are you using a Password? Have you changed the settings in it recently? ( Unfortunately I don't know much about Smartware except that it has always been problematic.)
My System SpecsSystem Spec
24 Mar 2014   #10
kaufmann

Windows 7 Home Premium 64bit.
 
 

I am sorry, we were running on backup power and had no internet access yesterday. Hence the delayed update.

To sygnus21==>

A mutual friend of mine has the same hard drive, so I tried it with his cable. The result was same.
I tried it with my cable in his laptop, and his cable in his laptop. It was of no use.
Also, I am able to detect his hard drive with my cable, in my laptop.
So, I assume that there's nothing with my pc or cable.

To jumanji==>

As i couldn't find the settings to disable virtual drive creation, I have uninstalled it in advanced mode using revo uninstaller pro. Hope this will do for time being.

I tried running the drive clean up and it loaded fresh drivers when I plugged it in after booting the machine!!! But I am afraid there was no improvement in the result.
I have included the screenshots of My computer and diskmgmt.


As for the other part, Yes!!! I had set a password for drive lock and No I did not change the settings recently. The auto drive unlock was enabled for my laptop, hence it would load up automatically without the prompt for password.


Attached Thumbnails
1TB WD external hard disk not initialized-1.jpg   1TB WD external hard disk not initialized-2.jpg  
My System SpecsSystem Spec
Reply

 1TB WD external hard disk not initialized




Thread Tools Search this Thread
Search this Thread:

Advanced Search




Similar help and support threads
Thread Forum
1TWD external hard disk unknown,not initialized,unallocated,i/o error
This quick new hard disk. So sad I cant access it anymore? why this happen? You can see from the photo MY computer cant even see this driver anymore, so I check on the - Disk management it said unknown no driver letter too ,Not initialized. -Click Initialized it said i/o device error I...
Hardware & Devices
WD EXTERNAL HARD DISK 1TB suddenly "unallocated" and "not initialized"
Hi guys. I'm new here. I've tried to read all the discussion about how to fix the unallocated hard drive but I just can't understand it as the cases were pretty much different than I'm facing of. Here's my problem. Yesterday my external hard drive seems normal, everything is fine, until...
Hardware & Devices
Unknown - Not Initialized Disk (External HD)
Hi, i'm new on this forum. I was searching for an answer to this issue in a lot of threads but i didn't find something to fix it. I built an external hd using the hard disk of my old laptop (Fujitsu MHV2120AH PL) and a Woxter i-Case 240. When i connected it via USB i went to the Disk Manager...
Hardware & Devices
Disk 1 unknown not initialized - an external HDD
Hi i would like to ask why this happen. My external hard disk is detected by computer but doesn't appear in hard disk panel , it only appears on Devices. When i go to computer management. This is the output. Same when i use it to other computers. please help. im just new here and no good at...
Installation & Setup
External Hard Disk, Unknown, Not Initialized ! No Unallocated Space.
Hi, I'm new to this forum. My external hard disk (Seagate) is detected in the task bar after connecting, but not visible in "My Computer". It is visible in Device manager under Disk Drives but not under USB. There are few threads in this forum which are similar to mine, except that...
Hardware & Devices
Unaccessible External Hard Drive: Disk 1 Unknown, Not Initialized
Hello. Through the power of google, I have come here to see If I can get any help recovering data. Essentially found this thread: http://www.sevenforums.com/hardware-devices/288692-disk-1-unknown-not-initialized-unallocated.html and just having really similar issues. Issue is with my sisters...
Hardware & Devices


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 11:30.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App