Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Windows Boot stalls when adding additional Sata Drives

13 Apr 2014   #1
SirTenTea

Windows 7 Home Premium 64Bit
 
 
Windows Boot stalls when adding additional Sata Drives

I've recently reinstalled Win7 64bit to my Mushkin enhanced Deluxe 240gb SSD. This drive had a missing MBR. I was finally able to reformat it and install Windows after changing the boot to Legacy Only in the Gigabyte BIOS. After installing all the updated drivers and video drivers in the new install I turned to re-connecting all the other HDs in my build that were there before the original problem occurred. These drives are a combination of SATA II and SATA III and worked fine on this build before my MBR problem. That's when the boot of windows stalled. I the tried connecting one at a time (There are 7 additional internal HDS) with the same results. The BIOS did see the one additional drive I reconnected on the second try. When I go back to the single drve everything is fine at boot. I even changed the boot back to UEFI and Legacy, thinking that was the cause of the problem. I'm at a loss to understand why these drives don't function in this, my second installation of Windows in this build.

Some System Info:

Operating System
Microsoft Windows 7 Home Premium 64-bit SP1
CPU
AMD A8/A10 39 C
Trinity 32nm Technology
RAM
16.0GB Dual-Channel DDR3 @ 800MHz (11-11-12-28)
Motherboard
Gigabyte Technology Co., Ltd. F2A85X-UP4 (P0) 21 C
Graphics
ASUS VS228 (1920x1080@60Hz)
768MB AMD Radeon HD 8670D + 6570 Dual Graphics (ATI)
2048MB AMD Radeon HD 6570 (XFX Pine Group)
CrossFire Disabled
Hard Drives
224GB TOSHIBA MKNSSDCR 240GB-DX SATA Disk Device (SSD) 24 C
Optical Drives
TSSTcorp CDDVDW SH-S243N SATA CdRom Device
Audio
Realtek High Definition Audio

I also have two External drives connected with no problems at boot. If the BIOS saw one of those drives how come even that one additional drive causes Windows to flake out?


My System SpecsSystem Spec
.
14 Apr 2014   #2
ICIT2LOL

Desk1 7 Home Prem / Desk2 10 Pro / Main lap Asus ROG 10 Pro 2 laptop Toshiba 7 Pro Asus P2520 7 & 10
 
 

Well mate the only thing I can think of at the moment is to check the Device Manager and see if they are there and any error triangles alongside.

Perhaps you need to update the driver s these particular drives and personally I use the manufacturers for that as I am not a fan of the Windows feature.
My System SpecsSystem Spec
14 Apr 2014   #3
SirTenTea

Windows 7 Home Premium 64Bit
 
 

Quote   Quote: Originally Posted by ICit2lol View Post
Well mate the only thing I can think of at the moment is to check the Device Manager and see if they are there and any error triangles alongside.

Perhaps you need to update the driver s these particular drives and personally I use the manufacturers for that as I am not a fan of the Windows feature.
No error triangles in Device Manager to be found. How does one use an updated driver for a Hard Drive that's not connected to the system? Yes, I don't find Windows to be very efficient in finding updated drivers for much of anything.
My System SpecsSystem Spec
.

Reply

 Windows Boot stalls when adding additional Sata Drives




Thread Tools Search this Thread
Search this Thread:

Advanced Search




Similar help and support threads
Thread Forum
Acer Aspire X1301 - adding SSD as additional hard drive but no room!
Hi there, I have an Acer Aspire X1301 desktop pc which is running so slowly. I was advised that installing an SSD would speed it up and give it a new lease of life ...so I purchased one! Sadly however, upon opening the pc case, I realised that there was no spare space inside for me to be able to...
Hardware & Devices
Windows won't boot - stalls before login/welcome screen
A short intro (skip if you like): Hi everyone, this system has been running close to 24/7 since roughly two years ago. A custom RT7Lite disc was used and a lot of tweaking has been done, so the system is well in need of a fresh format. Unfortunately, this was planned for after the holidays, and...
General Discussion
AHCI mode no boot from sata optical drives
A strange problem, nothing critical, but I found it annoying that my optical sata drives will not boot from a bootable disk when in AHCI mode in Bios. If I switch the drive mode to native IDE then I can boot just fine from either of the Opitcal Sata drives. I have done some searching and found...
Hardware & Devices
windows 7 will not boot and/or login when adding hard drives
this is the second round for me on this, the O/S gets lost when you add drives to the system, for what its worth, it freezes at /windows/system32/classpnp.sys when using safemode to try and boot in at first i thought it was related to my add in card and array, but i just proved that wrong...
Hardware & Devices
Very slow boot, stalls at starting windows
Hi there, I recently upgraded my windows 7 from the release candidate to an oem version that was supplied with a new computer, I completely wiped the old win 7 os and installed on a clean partition, dual boot with xp, install was great, went fast and no errors, but now it takes up to 20 min to...
Performance & Maintenance
Flash drives stalls and freezes
ive had this flash drive for a bit actually, but i just noticed that when i have it formatted in ntfs the speed for the first 1/2 or 3/4 is like 25megs a second but then drops to like 19 and then eventually will like stay there, like it looks like it does nothing, like its stalling or freezing,...
Hardware & Devices


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 23:44.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App