Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Windows 7: "Device driver software was not successfully installed"

18 Apr 2014   #11
MARKTONE

Windows 7 Home Premium 32bit
 
 

Hi everyone. I'm brand new to this forum, so hopefully I'm going about posting my problem the right way. If I'm not, please excuse the error, and let me know what I should do instead.

So the reason I'm posting in this thread is because I seem to be having the exact same problem as Wonder Reece. None of my USB ports work and I cannot install any of the optional Windows updates. For example, when I plug in one of my flash drives, I get a message saying that the driver for the device failed to install. The same thing happens with other devices. So I go out on the internet to try to solve the problem, but curiously, my NVIDIA network adapter controller is missing, so I can't get on the internet. (I'm using a different computer to post this). I previously downloaded the driver from NVIDIA's website, and it's sitting on my desktop, but it fails to reinstall every time. So bottom line, I can't install any non-Windows drivers, and nothing that I plug into a USB port works because the drivers won't install. Seems like the two issues must be related, but for the life of me, I can't figure out how.

Hopefully I'm not confusing the issue here. It just seemed so uncannily similar, that I thought I might add to the conversation. If I'm confusing matters, please tell me what the best process is to get my issue resolved, and I'll do it. Thanks!


My System SpecsSystem Spec
.
19 Apr 2014   #12
NoelDP

Microsoft Community Contributor Award Recipient

Win 7 x64 Home Premium (and x86 VirtualBox VM)/Win10
 
 

Quote   Quote: Originally Posted by MARKTONE View Post
Hi everyone. I'm brand new to this forum, so hopefully I'm going about posting my problem the right way. If I'm not, please excuse the error, and let me know what I should do instead.
Please start a NEW thread of your own, and followthe WindowsUpdate Posting Instructions and post the requested data there.
My System SpecsSystem Spec
19 Apr 2014   #13
ICIT2LOL

Desk1 7 Home Prem / Desk2 10 Pro / Main lap Asus ROG 10 Pro 2 laptop Toshiba 7 Pro Asus P2520 7 & 10
 
 

Well my 2 cents for what it is worth the Tecknet site does not give any drivers for this device - that I can see only ones for two mice and I am just wondering if the device came with a install software maybe it or the device itself is bad.
It also seems to be quite a medium priced product as opposed to some of the higher end stuff and I am in no way criticising the thing re quality but perhaps a different brand even if it is slightly higher priced might be the go.

I am also wondering if the device works on another machine?? It would certainly be worth trying that or it is something that I would personally have bash at. If it does work on another machine it could point the finger at the machine itself??
My System SpecsSystem Spec
.

19 Apr 2014   #14
Wonder Reece

Windows 7 Home Premium 64-bit
 
 

Thanks a lot to both of you for replying.

@NoelDP: I tried the program three times, but every time it gave me the following:

Quote:
Some updates were not installed

The following updates were not installed:
Hotfix for Windows (KB947821)
@ComputerGeek: I don't have the aforementioned memory stick any more, but I do have another one that doesn't work. So it may as well be the same. Here:

Quote:
TeckNet USB\VID_058F&PID_3832\5&30AC598D&0&1 The drivers for this device are not installed.
USB DISK 2.0 USB\VID_13FE&PID_3600\07BA19013A4DE38B This device is not configured correctly.
My System SpecsSystem Spec
19 Apr 2014   #15
NoelDP

Microsoft Community Contributor Award Recipient

Win 7 x64 Home Premium (and x86 VirtualBox VM)/Win10
 
 

You appear to have some major problems.
Please upload your entire CBS folder (see section 4 of the post I linked to)
My System SpecsSystem Spec
19 Apr 2014   #16
ComputerGeek

Desk 1: Win 7 Pro x32; Desk 2: Windows 10 x64
 
 

Your result indicates possible Windows driver corruption

Control Panel->Folder Options->View. Uncheck "Hide extensions for known file types". Click OK

Now, check if each of the files below exist. Tell me if any are missing.
For each .sys file, right click->Properties->Details and report the File Version of each

C:\windows\inf\usbstor.inf
C:\windows\inf\usbstor.pnf
C:\windows\system32\drivers\usbstor.sys

C:\windows\inf\usb.inf
C:\windows\inf\usb.pnf
C:\windows\system32\drivers\usbccgp.sys

/* EDIT */
p.s. "Access denied" on the Composite device could also be why the Teknet USB won't install/has no driver. (your flash drive is still a different matter). Also, try right click on the installer and run as Admin
My System SpecsSystem Spec
21 Apr 2014   #17
Wonder Reece

Windows 7 Home Premium 64-bit
 
 

@ICit2lol: Sorry I missed your reply in my last comment. I have tested the webcam on my parents' computer and it installs first time.

Not that it matters now we know it's my PC at fault, but I've only just noticed that the installation disc says "Driver (720.V6.2)" on it. So I may be incorrect in my original post, and this disc is more of a requirement than I thought. It is odd that they don't offer these drivers on the website, though. The product is 4.5/5 stars on Amazon, and while I'm sure there are better alternatives, this is still meant to be a decent (and most importantly, working) product.

@NoelDP: I can't seem to upload it here, I keep getting server errors (my ZIP folder exceeded the upload size limit, but I also tried splitting it into two folders, tried RAR format, etc and still "server error"). So I have uploaded it here: https://www.dropbox.com/s/ewueluzr2okvaaz/CBS.zip

@ComputerGeek: I can confirm that all of those files exist on my computer. Here is the File Version info:

Quote:
USBSTOR.SYS: 6.1.7601.17577
usbccgp.sys: 6.1.7601.18328
Also, I've tried running the installer using "Run as Administrator" before (and again just now to double-check), and the result is the same.
My System SpecsSystem Spec
21 Apr 2014   #18
ICIT2LOL

Desk1 7 Home Prem / Desk2 10 Pro / Main lap Asus ROG 10 Pro 2 laptop Toshiba 7 Pro Asus P2520 7 & 10
 
 

My System SpecsSystem Spec
21 Apr 2014   #19
ComputerGeek

Desk 1: Win 7 Pro x32; Desk 2: Windows 10 x64
 
 

If I might also add this:

Re: your flash drive problem. See How to Cleanup and Remove old USB Mass Storage Drivers. Follow the instructions and try re-connecting your flash drive

Re: Your web cam issue / Composite Device Access Denied
Let's go back and check the access permissions on these 3 files
> C:\windows\inf\usb.inf
> C:\windows\inf\usb.pnf
> C:\windows\system32\drivers\usbccgp.sys

For each file, right click->Properties->Security tab. (You'll see a snap shot for each below).
  1. For usb.inf; Select on SYSTEM and then Administrators. For each selection, verify you see the 5 check marks under Allow and nothing under Deny for each selection. (We don't care about Users)
  2. Check the same for usb.pnf: Select on SYSTEM and then Administrators, verify the 5 check marks under Allow and nothing under Deny. (We don't care about Users)
  3. For usbccgp.sys, select TrustedInstaller. verify the 5 check marks under Allow and nothing under Deny


Attached Thumbnails
Windows 7: "Device driver software was not successfully installed"-properties.jpg  
My System SpecsSystem Spec
22 Apr 2014   #20
FRJanD

Windows 7 Ultimate x64
 
 

Bonjour,

I had exactly the same problem with a HP Webcam HD 2300 and struggled a few weeks.
Bingo ICit2lol gave the right answer after passing the 3 spy/mal/ad ware removal tools I could install the driver
without any problem and the webcam works!

Thanks a lot.
My System SpecsSystem Spec
Reply

 Windows 7: "Device driver software was not successfully installed"




Thread Tools Search this Thread
Search this Thread:

Advanced Search




Similar help and support threads
Thread Forum
Device driver software was not successfully installed.
Screenshot I installed windows 7 Ult on my Toshiba satellite l50 laptop (which had no operating systems installed at the time). No programs were installed and 7 drivers weren't recognised. I used the same installation CD to install Windows 7 on VMware (on my desktop) and the drivers were...
Drivers
Error: Device driver software was not successfully installed
Most times when I start my machine or just turn on my monitors (the Windows Display setting is set to turn off at 20 minutes, sleep is set to Never), I find that Windows is installing software. Sometimes it's successful, sometimes it fails. I see others have had this issue, but the offered...
General Discussion
Device driver software was not successfully installed (fresh install)
Hey guys, Just made a thread a short while ago regarding file associations being messed up after an SSD clone in the file associations forum. Long story short, formatted the SSD and did a fresh install of win7 home premium 64bit. Install completes with no apparent problems, but upon...
Drivers
Device driver software was not successfully installed, Daemon T, more
Yesterday I upgraded hardware from: AMD Athlon X2 4600+ & Mobo to: Core i5 3570K and Asus P8H77-I mobo. I think it's since then, that I can't install some drivers. I first noticed when I was going to use Daemon Tools Lite, there weren't any drives so i clicked "Add device" in D-tools...
Drivers
Device Driver Software was not Successfully Installed for Cable Modem
Hello everyone, When trying to install my USB cable modem (Scientific Atlanta DPC2100R2), I'm always getting a popup message that says "Device Driver Software was not Successfully Installed." I don't even get a "Found New Hardware" message beforehand. I just switched over to Windows 7...
Drivers
When plugging in iPod "Device driver software was not successfully ins
When I plug in my ipod to any of the USB ports I get "Device driver software was not successfully installed." I followed all the itunes / ipod troubleshooting and no luck. I updated drivers and unintalled them and still no luck. I am getting this error with two seperate ipods, i restored...
Drivers


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 04:45.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App