Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: [Help] Mapped File using half my 8GB RAM, CPU usage by unknown progs

14 May 2014   #1
NeitanDoreiku

Windows 7 Professional SP1
 
 
[Help] Mapped File using half my 8GB RAM, CPU usage by unknown progs

Hello all,
I built this PC a few months back, and reinstalled Windows 7 on 05-13-14 due to weirdness going on. The problems seem to be happening again, even hours after running.

Everything was great on this system, up until I installed my Samsung SSD's drivers, and it changed to AHCI, as well as changed some services to "Maximum Performance" settings.

My CPU seems to be being used by something. Kaspersky used 25% of the CPU during the install of my Asus drivers, for example. But at most other times, the fan just runs loud and alternates speeds. Secondly, when I open my Task Manager, I find about 40-50% of it used, but a second later it drops to below 10%... but my CPU fan is unaffected.

50% of my RAM is filled by the Mapped File cache, Kaspersky is having constant hard faults, harddisk drivers are failing.... I don't know where to start. Any help would be appreciated. Even a pointer to something that could help would be nice... Thank you.

Here is a complete system log:
GetSystemInfo Parser 2.96
(Click on the expert link to view my system information, processes, event viewer logs, and the like.)


My System SpecsSystem Spec
.
15 May 2014   #2
Computer0304

Windows 7 Professional 32-bit/Windows 8 64-bit/Win7 Pro64-bit
 
 

Do a threat scan with https://www.malwarebytes.org/getmbam and if it finds something, do a custom scan on all hard drives too to double check.
My System SpecsSystem Spec
15 May 2014   #3
Layback Bear

Windows 7 Pro. 64/SP-1
 
 

Could you post these?

[Help] Mapped File using half my 8GB RAM, CPU usage by unknown progs-new-ram-picture.png

[Help] Mapped File using half my 8GB RAM, CPU usage by unknown progs-boot-advanced-options..png


My System SpecsSystem Spec
.

15 May 2014   #4
NeitanDoreiku

Windows 7 Professional SP1
 
 

Quote   Quote: Originally Posted by Layback Bear View Post
Could you post these?
Sure.

[Help] Mapped File using half my 8GB RAM, CPU usage by unknown progs-resource_monitor_2014-05-15_09-52-35.png

[Help] Mapped File using half my 8GB RAM, CPU usage by unknown progs-boot_advanced_options_2014-05-15_14-48-53.png

Also, hard faults on the Malwarebytes scan.

[Help] Mapped File using half my 8GB RAM, CPU usage by unknown progs-resource_monitor_2014-05-15_14-54-27.png

Seems to me that the HardDisk driver errors in the Event Logs might be related to this...

Quote   Quote: Originally Posted by Computer0304 View Post
Do a threat scan with https://www.malwarebytes.org/getmbam and if it finds something, do a custom scan on all hard drives too to double check.
Nothing found. I figured as much. Installed Kaspersky immediately after reinstall. Plus I rarely get viruses, because I know where to go on the internet. (And Adblock)

[Help] Mapped File using half my 8GB RAM, CPU usage by unknown progs-malwarebytes_anti-malware_-free-_2.0.1.1004_2014-05-15_14-58-31.png


My System SpecsSystem Spec
17 May 2014   #5
Layback Bear

Windows 7 Pro. 64/SP-1
 
 

I would suggest using Windows 7 built in defrag tool and see what happens.

I found that Windows 7 defrag worked as good as 3rd party defrag tool just without all the little lines and squares jumping around.
Some 3rd party defrag tool have also been reported to remove your restore points.
My System SpecsSystem Spec
17 May 2014   #6
derekimo

Microsoft Community Contributor Award Recipient

 
 

Why is disk defrag being run on an SSD anyway?
My System SpecsSystem Spec
17 May 2014   #7
Layback Bear

Windows 7 Pro. 64/SP-1
 
 

Good catch Derek. I didn't notice that.

NeitanDoreiku no manufacture of a ssd recommends defragging a ssd that I'm aware of.
My System SpecsSystem Spec
18 May 2014   #8
NeitanDoreiku

Windows 7 Professional SP1
 
 

I don't run defrags on my SSD. I have 4 other drives plugged into this computer. One of them is used for all my user files. I like them to be defragged. Also, Auslogics is smart...very smart... and fast.

Could some of my problems be related to Microsoft incorrectly using generic drivers for some of my custom build hardware?

[Help] Mapped File using half my 8GB RAM, CPU usage by unknown progs-auslogics_disk_defrag_professional_2014-05-18_13-46-42.png


My System SpecsSystem Spec
20 May 2014   #9
NeitanDoreiku

Windows 7 Professional SP1
 
 

So I just found this...

[Help] Mapped File using half my 8GB RAM, CPU usage by unknown progs-rammap_-_sysinternals_www.sysinternals.com_2014-05-20_17-34-15.png

My drivers DO seem to be out of whack. I found the video below, and I'm currently working on debugging this.

http://channel9.msdn.com/Shows/Defra...-Analysis-Pool

Edit: On a freshly rebooted system with everything resource-heavy closed:

[Help] Mapped File using half my 8GB RAM, CPU usage by unknown progs-rammap_-_sysinternals_www.sysinternals.com_2014-05-20_17-41-25.png


My System SpecsSystem Spec
20 May 2014   #10
NeitanDoreiku

Windows 7 Professional SP1
 
 

So I believe I may have found the problem, and it was my SSD driver as suspected, among many other things. Proof:
[Help] Mapped File using half my 8GB RAM, CPU usage by unknown progs-2014-05-20_18-29-02.png

I found how to do this, with instructions, here.

You'd need the WDK (Windows Driver Kit) in order to obtain the poolmon executable. This is sad because the poolmon executable doesn't have any dependencies, so you can copy it to any computer, by itself, and it will work.

Details on what the "SamsungRapidDiskFilter.sys" driver is can be found here. (Most noteably page 5) It is not a leak, but rather related to the "RAPID Mode" option that can be enabled/disabled in the Samsung Magician software. (Samsung's SSD management interface)

Also, the Broadcom wireless driver has a memory leak, which it is reported to have often, based on what I'm finding.


My System SpecsSystem Spec
Reply

 [Help] Mapped File using half my 8GB RAM, CPU usage by unknown progs




Thread Tools Search this Thread
Search this Thread:

Advanced Search




Similar help and support threads
Thread Forum
Ram Issue / Half Usage
Hello, I posted over at Tom's and no one has a clue what is wrong with my PC, so I thought I would try here. A few nights ago I was playing my modded Skyrim, something I been doing for 2 years on this rig and at one point I looked over at my Task Manager and seen my CPU was at 100% and my ram...
Hardware & Devices
Winsxs file already consumes half of my disk space...
I recently replaced a 60GB SSD because my winsxs file was using over 25GB and I was down to about 8GB of usable space. I went out and bought an 80GB SSD and after my install it was already half full before I put any application on it. The winsxs file is already at 11GB and I really do not want to...
Installation & Setup
Display File Extension on Unknown File Types
Hello :o I dont know if Im on the right section to post this. I just want to ask to our fellow members and gurus here, I dont know what went wrong but suddenly the unknown file types in my Windows 7 PRO x64bit doesnt display its file extensions anymore.. How can i restore it to default? to...
General Discussion
Unknown CPU Usage Causing Stuttering Audio
Hey there. So I've been having this problem where my CPU is constantly hovering at around 30% usage, and after investigating with ProcessExplorer and Task Manager, I've found that the process responsible for most of it is the "System" process in \system32 (the description says "NT Kernel &...
General Discussion
7 and XP file share though mapped drive
On my 7 machine I have a shared root drive with only read priviledges and a sub directory in this drive that has shared read/write priviledges for a specific account The account name is JOE and has a Passwork JOES_PW I an XP machine I have the same JOE account with same JOES_PW. IF I map...
Network & Sharing
high cpu usage - unknown cause
Hi, I get regularly high CPU usage without any visible reason in task manager. A desktop gadget shows the CPU usage between 50 - 70 % but in the task manager there are two or three processes with 1 % each. I see also higher power consumption. In normal idle state I have some 18 W, with the CPU...
Performance & Maintenance


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 21:28.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App