Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: External Hard Drive: detected but does not show up in folder

27 May 2014   #1
chelsi001

Windows 8
 
 
External Hard Drive: detected but does not show up in folder

My external hard drive (WD Passport 0748) can be detected, but doesn't show up in My Computer.
I tried everything I saw on the internet but to no avail. I need these files so badly! Help

It shows up in my Device Manager. Right clicked it and uninstalled it, plugged it back. It gets detected (again) but still, it doesnt show up in My Computer.

I went to Disk Management. It's unknown, not initialized and unallocated with black line on top. What does that mean? (See jpg 1)

It shows up in Devices and Printers but it has a yellow triangle mark on it with "!". (See jpg 2) So I click troubleshoot. It says "The driver for WD SES Device USB Device is not installed. Install the latest driver for the device." Then I click "Apply this fix." Then it says "WD SES Device USB Device doesn't have a driver. Not fixed" (See jpg 3).

I plugged my external hard drive to my other computer. I did the same thing, but still it didn't work. It gets detected but won't show up in My Computer.




Attached Thumbnails
External Hard Drive: detected but does not show up in folder-1.jpg   External Hard Drive: detected but does not show up in folder-2.jpg  
Attached Images
External Hard Drive: detected but does not show up in folder-3.jpg 
My System SpecsSystem Spec
.
27 May 2014   #2
jumanji

Windows 7 Home Premium 32 bit
 
 

I have no clue but just curious.

Did it happen after you installed Daemon Tools?
My System SpecsSystem Spec
27 May 2014   #3
chelsi001

Windows 8
 
 

Quote   Quote: Originally Posted by jumanji View Post
I have no clue but just curious.

Did it happen after you installed Daemon Tools?
Nope
My System SpecsSystem Spec
.

27 May 2014   #4
jumanji

Windows 7 Home Premium 32 bit
 
 

1.Do you have any other Virtual CDROM drive showing up in My Computer (Other than the one from Daemon Tools)?

2. What is the exact model Number of your Passport drive? If you can show it to me in the WD website all the more better.

3. Did your drive come with Smartware backup software and did you ever install it and played around with it, today, yesterday, the day before or anytime?

4. Have you installed the SES driver anytime before? Especially when you plugged it in for the first time after you purchased?

5. How old is the drive?

6. From when did this problem arise?

7. Do you remember anything you did - even anything which you may think is remotely connected with this - after which this problem has cropped up?

Answer to all these questions may perhaps bring someone else having the same drive as yours if they can help. You may not expect anything off-the-cuff on this problem and I shall come in only if I can get something flashing in my mind as I sleep over it.

EDIT: Before I go to sleep I can't but throw some cold water - however much I don't like to say that, I have to pull myself up - if your drive did not come with a Virtual CD, if your drive did not come with smartware, if you hadn't installed an SES driver anytime before, and it has been functional till this day , this happened all of a sudden, it wouldn't show up on any other computer too, it is quite likely that it is dead. Try to initialise it but do not initialise. If it throws up any error message like I/O error - confirmed.
My System SpecsSystem Spec
27 May 2014   #5
chelsi001

Windows 8
 
 

1.I'm sorry, I'm not really a techie person. What is a Virtual CDROM drive? I dont think I have other than Daemon Tools.

2. WD Support / Installation / My Passport / My Passport WDBBEP0010BSL-01

3. Yes it did come with a smartware but I never played with it cause I know nothing about it so I didnt do anything.

4. I dont remember if I did. But I just downloaded WD_SES_Driver_Setup_x64 for my hard drive and after I installed it, the yellow triangle with "!" in my hard drive's gone (when I went to Devices and Printers). I clicked troubleshoot and it says its fine.

5. I guess I got this a year ago maybe

6. This problem occurred yesterday. Last time I used my hard drive was last week and it was perfectly fine.

7. Nope, I dont think I did anything
My System SpecsSystem Spec
27 May 2014   #6
chelsi001

Windows 8
 
 

So I opened my WD Smartware and this came up. What does "No writable WD SmartWare partition found"?


Attached Thumbnails
External Hard Drive: detected but does not show up in folder-1.jpg  
My System SpecsSystem Spec
27 May 2014   #7
chelsi001

Windows 8
 
 

When I go to Disk Management, this pops up. What should I do? "You must initialize the disk before logical disk manager can access it." What will happen if I initialize it? Will my files be deleted?


Attached Thumbnails
External Hard Drive: detected but does not show up in folder-1.jpg  
My System SpecsSystem Spec
27 May 2014   #8
jumanji

Windows 7 Home Premium 32 bit
 
 

OK, It came with Smartware and you did install Smartware but never got into it. Am I right?

Now you installed the SES driver and apparently that requirement has been satisfied,

Are you able to access your drive now? If not describe what happens when you try to access the drive.

If your drive is visible now, please post a screenshot of how it appears in Windows Disk Management

Disk Management - Post a Screen Capture Image

( Do not do anything with Smartware. There is a manual in WD website about Smartware and long back I had read it but remember nothing now.)
My System SpecsSystem Spec
27 May 2014   #9
jumanji

Windows 7 Home Premium 32 bit
 
 

OK our posts crossed.

Don't initialise now. Just cancel.

Let me think and come back after a while.

EDIT: Please post a full screenshot doing away the Console Tree and Action Pane by clicking on the Show/Hide buttons in the toolbar
My System SpecsSystem Spec
16 Oct 2014   #10
stargks

Windows 7 Ultimate x64
 
 
Me too!

I have the exactly the same probleme.
But the different is the situation.
in the evening, i try to download some file in my DDE. In the mind time i fell to sleep.
When i wake up i found my computer is on sleep mode.
And my DDE ......
like the you. I try to initialize but there a some error.
What can i do? i have important documents ....
My System SpecsSystem Spec
Reply

 External Hard Drive: detected but does not show up in folder




Thread Tools Search this Thread
Search this Thread:

Advanced Search




Similar help and support threads
Thread Forum
External Hard Drive Not Detected
I have a western digital mybook (WD5000C032-002) that for some reason is not being detected by Windows 7 RC. It is a USB connection straight from the mybook to one of the motherboard's usb ports. All my device drivers are up-to-date. If I go into "Devices and Printers" and click on "Add a...
Hardware & Devices
External Hard Drive not Detected
I have a small 50gb HHD powered from USB It will connect to my laptop running windows 7 home premium but not my pc running windows 7 professional When plugged into my pc by usb the Disk does not power up and spin (the light does come on) There is no recognition of it in my computer, device...
Hardware & Devices
External hard drive not detected---again
I have an 1T external drive plugged into esata port. It used to work and now it doesn't? When I boot up bios correctly identifies the drive as a seagate sata drive. When I look at device manager is says its a seagate SCSI drive and therefore the system doesn't recognize it at all? In device manager...
Hardware & Devices
External hard drive not detected
Hi guys, My computer cannot detect my 250GB external hard drive and I'm having a hard time fixing this issue, and I've been searching for the problem to be fixed in the internet, unfortunately nothing was found. Before this issue happened, there was no problem, it was working fine until I did...
Hardware & Devices
External hard drive not being detected
Hi, I have been using my Iomega HDD for a while now and have never had any problems before today. It worked fine when connected to my Acer Netbook running windows 7 starter 32 bit. I connected to a friends laptop and it said to access it it must be formatted, so i bought it home and it said the...
Hardware & Devices
USB Hard drive gets detected/installs but doesn't show up.
Continuation from this. I've tried all steps but I can't seem to get to my hard drive. Windows 7 Professional 64x. Drivers Updated. Plugged in properly. Installed and uninstalled device driver. Gave the drive a letter and changed the letter many times. Hard drive is still working because...
General Discussion


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 15:49.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App