Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Mouse / Keyboard stop working after switch user

08 Jun 2014   #1
alov1258

Windows 7 Ultimate x64
 
 
Mouse / Keyboard stop working after switch user

I have a rather annoying issue when I switch user, the mouse and keyboard stop working. I have to remove and reinsert each time to get them working again. Happens immediately after switch user, and then again once logged in as the new user. Some details on the hardware.

Mouse: Logitech M305
Keyboard :Logitech diNovo Edge with BT receiver
Motherboard: Asus Z87 Plus
OS: W7 Ultimate x64

These are USB 2 devices plugged into a USB3 port. Latest USB 3 driver is installed.

I have the PC setup to auto login after reboot and the mouse / keyboard work fine.

Any ideas or suggestions on why this is happening and how to fix it?


My System SpecsSystem Spec
.
08 Jun 2014   #2
msgerbs

Windows 7 Professional x64
 
 

Can you plug them into USB2 ports? There's no real reason to plug them in to USB3 ports, and it's better to have mouse and keyboard in USB2 ports because they don't require drivers like USB3 does, which can cause issues like this.
My System SpecsSystem Spec
08 Jun 2014   #3
alov1258

Windows 7 Ultimate x64
 
 

Motherboard only has USB3 ports pre-installed. I'd need to get and install a USB2 set of ports.
My System SpecsSystem Spec
.

08 Jun 2014   #4
Ranger4

Windows 7 Home Premium 64 bit sp1
 
 

Both these units are connected by wireless, is that correct?. Perhaps you could try a wire connected mouse & keyboard to see if the problem still exists.
This Logitech website may help you.

My M305 mouse is not working - Logitech FAQ
My System SpecsSystem Spec
08 Jun 2014   #5
alov1258

Windows 7 Ultimate x64
 
 

I suspect it is the USB2 / 3 issue mentioned. I recently upgraded my HTPC and these devices worked fine on the old motherboard which only had USB 2. They also work fine once the receivers are removed and reinserted into the USB port.
My System SpecsSystem Spec
29 Jul 2014   #6
alov1258

Windows 7 Ultimate x64
 
 

Well, it's not the USB3 issue. I added a USB2 ports and the same thing happens when they are plugged into the USB ports. Going to try the wired mouse next.
My System SpecsSystem Spec
29 Jul 2014   #7
Layback Bear

Windows 7 Pro. 64/SP-1
 
 

Is this your motherboard?

Do you have the motherboard manual?

Motherboards - Z87-PLUS - ASUS


Quote:
Intel® Z87 chipset :
4 x USB 3.0/2.0 port(s) (2 at back panel, blue, 2 at mid-board)
ASMedia® USB 3.0 controller :
4 x USB 3.0/2.0 port(s) (4 at back panel, blue)
Intel® Z87 chipset :
8 x USB 2.0/1.1 port(s)
8 x USB 2.0/1.1 port
My System SpecsSystem Spec
29 Jul 2014   #8
alov1258

Windows 7 Ultimate x64
 
 

Quote   Quote: Originally Posted by Layback Bear View Post
Is this your motherboard?

Do you have the motherboard manual?
Yes and yes
My System SpecsSystem Spec
29 Jul 2014   #9
Layback Bear

Windows 7 Pro. 64/SP-1
 
 

Then I don't understand post #3.

Quote:
Motherboard only has USB3 ports pre-installed. I'd need to get and install a USB2 set of ports.
My System SpecsSystem Spec
29 Jul 2014   #10
alov1258

Windows 7 Ultimate x64
 
 

There are 6 x USB 3.0/2.0 ports on the rear panel (see page xii of the manual) which are the only ports supplied. These now have the USB 3.0 drivers applied and are running as such. There are 4 additional 9 pin USB 2.0/1.0 on the motherboard into which I have plugged a computer host case MainBoard 4 port USB 2.0 expansion bracket. The mouse and keyboard receivers are now plugged into these ports, and the problem persists.

However, I just ran the Windows USB Diagnostic remotely which detected some filter range errors which I allowed it to fix, but have not been able to test. Will update with the result tonight.
My System SpecsSystem Spec
Reply

 Mouse / Keyboard stop working after switch user




Thread Tools Search this Thread
Search this Thread:

Advanced Search




Similar help and support threads
Thread Forum
Mouse scroll and keyboard stop working until left click of mouse
After about 1 minute the mouse scroll and keyboard stop working until I left click mouse. Tool bar on browser also greys out but comes back after left click. Video and sound also are choppy. Not sure if this is related. Flash keeps crashing. Any ideas whats wrong? Windows 7 pro. Asus desktop. This...
General Discussion
Mouse and Keyboard stop working during games.
Hi, this is my first thread and i'm a bit inexperienced with computers but bear with me here. Ok so yesterday whilst i was playing a game my keyboard and mouse stopped working. The keyboards lights started flashing and the mouse just stopped responding (even though the mouse light was still on). I...
Hardware & Devices
7 x64 mouse and keyboard randomly stop working.
As of lately my mouse and keyboard sometimes just stop working. It seems to happen more often while I'm playing games (but that's mostly what I do so not sure if that has anything to do with it :p). Usually before it happens I'll hear the usb sound and the mouse will disconnect and reconnect and...
Hardware & Devices
Keyboard and mouse randomly stop working
My PC won't go into sleep mode either automatically or manually so I just leave it on all day (the screen will go off at the pre-determined time though). However, that's not my issue as I've learned to live with it. I'm just mentioning it because it could be related to the following issue that just...
BSOD Help and Support
Keyboard and mouse stop working.
Hi. Sorry for my English. I have dell optiplex 390 computer. I used it for 6 month without having problem. But now i have problem on keyboard and mouse. Every time turn on the computer it work correctly for 2 or 3 minutes. After that it stop responding. First I thought it have problem with OS....
Hardware & Devices
My Mouse And Keyboard Stop Working
Well my mouse and keyboard stop working on the start up,when it says windows in starting when i comes to logging on i cant my mouse and KB is just Locked how do i fix this :mad:
BSOD Help and Support


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 17:28.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App