Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: My Hitachi hdd is not working in Windows but works in TV.

26 Jun 2014   #1
cariojophel

Windows 7 Ultimate x86
 
 
My Hitachi hdd is not working in Windows but works in TV.

Hello Good morning! I really need help on this. My hitachi hdd cannot be detected by my windows but I can play it smoothly in my tv. I bet my hdd is faulty and I just wanna recover my files.

What do I need to do to recover my files?


My System SpecsSystem Spec
.
26 Jun 2014   #2
HarriePateman

Windows 7 Ultimate 64-bit
 
 

Do you have the latest Hitachi drivers? (https://www2.hgst.com/hdd/support/drivers.htm)

Have you tried plugging the SATA cable into a different slot. (could be a dead connector, try a different lead)

Also, have a look in device manager and see if there are any "Yellow Error Marks"

another good way to check would be to boot in to the bios, and see if it is registering anything plugged into the sata ports.
My System SpecsSystem Spec
27 Jun 2014   #3
Boozad

W7 Pro x64 SP1 | W10 Pro IP x64 | W8.1 Pro x64 VM | Linux Mint VM
 
 

Considering he's got a laptop and is plugging the drive into his TV I'm presuming he's connecting via USB and that it's an external drive, although I could be wrong. It is hard to make that call though when the OP fails to provide all the relevant information, mind reading isn't one of our strong suits.
My System SpecsSystem Spec
.

27 Jun 2014   #4
cariojophel

Windows 7 Ultimate x86
 
 

Quote   Quote: Originally Posted by HLPTech View Post
Do you have the latest Hitachi drivers? (https://www2.hgst.com/hdd/support/drivers.htm)

Have you tried plugging the SATA cable into a different slot. (could be a dead connector, try a different lead)

Also, have a look in device manager and see if there are any "Yellow Error Marks"

another good way to check would be to boot in to the bios, and see if it is registering anything plugged into the sata ports.
Thanks for this. Let me discuss how did it all began..

Im using a Toshiba Laptop Satellite L640. After repaired my cpu fan, and keyboard, the hard disk went wrong. Boot error logo 0xc000000f. I managed to fix this with a bootable windows 7 installer I learned from this site.

However after a few minutes, it went to a BSOD. And when I restarted my laptop, all I can see is a BLACK SCREEN after the BIOS, sometimes, some lucky times, after several restarts, it is able to continue to the windows logo but then, will restart again.

I bought an external hard disk enclosure, hoping I can recover my files inside. I was assuming my hdd only needs formatting. But when I plugged it in, everything hangs. Even the device manager can detect it and the disk management, but I really hangs. sometimes yes I can open it, but after a short period of time, the pc will hang again and will be unable to detec my hdd.

So, to test and confirm if my hdd is really dead, I plugged it in my TV and in my surprise, I can open my files! I can play movies SMOOTHLY! Without any lags or whatever.

I think I have a similar problem as what this thread is discussing. Seagate 2TB Hard Drive not responding, stops programs from working

Will be starting to create a bootable linux later and see if I can recover my files.

I need some of your suggestions. If recovering thru linux fails. Thanks!
My System SpecsSystem Spec
27 Jun 2014   #5
cariojophel

Windows 7 Ultimate x86
 
 

Quote   Quote: Originally Posted by Boozad View Post
Considering he's got a laptop and is plugging the drive into his TV I'm presuming he's connecting via USB and that it's an external drive, although I could be wrong. It is hard to make that call though when the OP fails to provide all the relevant information, mind reading isn't one of our strong suits.
Apologies sir. Please refer to my earlier post. Thanks!
My System SpecsSystem Spec
27 Jun 2014   #6
cariojophel

Windows 7 Ultimate x86
 
 

Up this post!
My System SpecsSystem Spec
27 Jun 2014   #7
cariojophel

Windows 7 Ultimate x86
 
 

Below are the screenies of what happened. I can now see my first partition mounted on Linux but still I cant see my other partition. The partition is the one broken not the hard disk I can say. What should I do to retrieve my files?


Attached Thumbnails
My Hitachi hdd is not working in Windows but works in TV.-screenshot.png   My Hitachi hdd is not working in Windows but works in TV.-screenshot-1.png  
My System SpecsSystem Spec
28 Jun 2014   #8
cariojophel

Windows 7 Ultimate x86
 
 

Up up up up!
My System SpecsSystem Spec
28 Jun 2014   #9
HarriePateman

Windows 7 Ultimate 64-bit
 
 

however to recover your files on the HDD you will need a working computer of some sort. That is the only way i know of recovering.


Quote:
General rules:

2) No useless posts, e.g., thread bumping, useless one liners, junk posting to increase post count, and identical multi-postings in different forums.
Just so you know for the future friend.

Windows 7 Help Forums - Forum Rules
My System SpecsSystem Spec
28 Jun 2014   #10
cariojophel

Windows 7 Ultimate x86
 
 

Thanks! Ill try inserting and reinserting my drive to recover my files. Ive already recovered some files that way. Hope it works again.
My System SpecsSystem Spec
Reply

 My Hitachi hdd is not working in Windows but works in TV.




Thread Tools Search this Thread
Search this Thread:

Advanced Search




Similar help and support threads
Thread Forum
Microsoft Works 9 not working properly on Windows 7 computer
I hope that I put this in the right place. So here goes. I have two identical HP Compaq computers I bought after one computer running XP died and another computer running Vista had HD problems. My problem. I installed Microsoft Works 9 on both new computers. On one computer it works...
Software
Hitachi 4TB deskstar only shows 1.7TB in Windows 7
as the title really, I have just installed a deskstar 4TB but disk management only shows it as 1.7TB is this issue sortable? Thanks
Hardware & Devices
Unable to install windows to Hitachi hard drive
Hi all. Looking for a bit of advice. Originally got message - Disk read error occurred press ctl alt del to restart. Then tried plugging this drive using a USB connector into my desktop PC to see if I could run some chkdsk. Then my desktop PC displayed messages telling me my firewall and virus...
Hardware & Devices
Website not working on my PC, works elsewhere.
Hey to all, I was updating my wallpapers from netcarshow.com a few days ago when the connection suddenly went down. I thought it was due to maintenance from their end, however, I could use the site from another location. It also doesn't work on my WiFi connection at this location also. I am...
Browsers & Mail
Overclocking not working in windows but works on bios startup.
Ok I have a Asus M4A88TD-V EVO/USB3 Motherboard and it has a Turbo Key 2 switch on it that automatically overclocks the CPU. And a AMD Phenom 2 X6 Black Edition 1055T Processor 2.80GHz Now here's my problem after activating it, on system startup it says my CPU is 3.24 GHz :D but when Windows...
PC Custom Builds and Overclocking
Hitachi FX DUO 77 Windows 7 software
Hello everybody! I have to get for school the drivers or/and software kit for a Hitachi FX DUO 77 board at school. I don't know the serial number or details for registration form (not even our teacher knows because he lost the documentation and instalation cd..damn). We need that board up and...
Drivers


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 11:39.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App