Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: External Hard Drive issue cannot stay detected

25 Jul 2014   #1
kufr

Windows 7 Ultimate x64
 
 
External Hard Drive issue cannot stay detected

I have an external 2 TB WD Green Craviar HD. Well it used to work without any problem in my older pc where I had Winxp. Now I have a different pc details are

Operating System
Windows 7 Ultimate 64-bit SP1
CPU
Intel Xeon E5410 @ 2.33GHz 63 C
Harpertown 45nm Technology
Intel Xeon E5410 @ 2.33GHz 65 C
Harpertown 45nm Technology
RAM
8.00GB FB-DDR2 @ 333MHz (5-5-5-15)
Motherboard
Hewlett-Packard 0A9Ch (XU1 PROCESSOR) 39 C
Graphics
Acer X163H (1366x768@60Hz)
Generic Non-PnP Monitor (1024x768@29Hz)
256MB ATI Radeon HD 2400 (Dell) 46 C
Storage
931GB Western Digital WDC WD1002FAEX-00Z3A0 (SATA) 30 C
1863GB Western Digital WDC WD2002FAEX-007BA0 (SATA) 34 C
148GB Western Digital WDC WD1600BB-56GUC0 ATA Device (ATA) 33 C
2794GB Western Digital WD My Book 1140 USB Device (USB (SATA)) 33 C
2794GB Western Digital WD My Book 1140 USB Device (USB (SATA)) 32 C
931GB SAMSUNG HD103UI USB Device (USB)
2794GB Western Digital WD My Book 1140 USB Device (USB (SATA)) 31 C
2794GB Western Digital WD My Book 1140 USB Device (USB (SATA)) 35 C
Optical Drives
ASUS DRW-24B3ST
HP DVD Writer 1260t
Audio
Creative X-Fi Audio Processor (WDM)

The problem started when I first connected my external drive to the above mentioned system at first it gave me an error for the disk being Dynamic and I had to convert it to basic so i attached the external HD via an enclosure to an old laptop copied all the data 1.78 TB just to be on the safe side then converted the Dynamic disc to basic disk via a software Easeus Partition Master Edition. Everything worked out fine I copied all the data back i attached it to the Intel Xeon E5410 and it was instantly detected. After a few days i started noticing something strange sometimes I has to replug the HD to be seen as a drive via the USB. I even attached with a SATA cable to the motherboard but the problem was still there.
Now the issue is I am completely unable to detect access the HD i attach the HD with the sata cable it is not recognized as a drive and when use the USB cable if is shown for a few secs that drive X (yes that is the name as I have assigned all the rest of the letters to my other external already attached HD's) is attached and then it again shows HD removed without a warning all on its own.

I have read the forums here and tried almost anything I have important data on that drive which I have hardly used it was bought 3 months back I am attaching two screen shots the drive shows up in the Disk managment section for a few secs and then vanished I took a screen shot here



I have marked the drive in the screenshot although the screenshot shows the drive is online but you can see in the right corner I instantly got the message that the drive has been removed I am unable to stop this I connect the drive it says drive connected and is instantly followed by the drive has been removed

After all this I even used the software mentioned here in the forums called "MiniTool Partition Wizard Home Edition 8.1.1" although it was very difficult to get the drive to stay long enough for other softwares to detect it I was able to to use MiniTool Partition Wizard Home Edition only once to scan the HD. It was being shown there as a Bad Disk I tried the partition recovery wizard but even after scanning it showed it as Bad Disk
see screenshot below



Now I just dont know what else should I do so I am writing in vain that someone can help me out here please like I said I have important data in the drive can someone please please please help me to recover my disk or atleast my data


My System SpecsSystem Spec
.
27 Jul 2014   #2
raymondwd

 
 

Hi kufr, noted on the difficulty you're facing on the WD external hard disk. I strongly recommend you to try out the Data Lifeguard Diagnostics test first for the drive which might help to detect any errors on the drive itself. Here is the link for the test accordingly.

How to test a drive for problems using Data Lifeguard Diagnostics for Windows

Hope it helps.
My System SpecsSystem Spec
30 Jul 2014   #3
kufr

Windows 7 Ultimate x64
 
 

Quote   Quote: Originally Posted by raymondwd View Post
Hi kufr, noted on the difficulty you're facing on the WD external hard disk. I strongly recommend you to try out the Data Lifeguard Diagnostics test first for the drive which might help to detect any errors on the drive itself. Here is the link for the test accordingly.

How to test a drive for problems using Data Lifeguard Diagnostics for Windows

Hope it helps.

Have already tried it the drive is not listed .. like I said in my post "I am unable to stop this I connect the drive it says drive connected and is instantly followed by the drive has been removed" hence the drive is not seen in the list of drives of Data Lifeguard Diagnostics .. I just do not know what to do. Anyone know of something else for me to access my drive make it workable and let me copy my data to another drive so that I can format it once and for all and then re-copy my data back to get rid of all the errors if any on the drive ....
My System SpecsSystem Spec
.

30 Jul 2014   #4
Layback Bear

Windows 7 Pro. 64/SP-1
 
 

I don't know what all your problems but I think I found one of them by reading your system specs.

Quote:
Antivirus Emsisoft Anti-Malware, Eset Smart Security, MSE
Browser Chrome
Emsisoft and/or Eset could be stopping thing from entering the compurter including another hard drive.

You should only use one anti virus program on one computer at one time.
My System SpecsSystem Spec
30 Jul 2014   #5
Mellon Head

Win 7 Pro x64/Win 10 Pro x64 dual boot
 
 

I noticed that you said the drive was only three months old. It sounds to me like the drive is failing.

Have you tried it in different USB ports? Have you tried booting up with the drive plugged in? Not plugged in? Those things probably won't make a difference, but it's worth a shot.

I would just return the drive under warranty and get a new one. If it won't work under USB or SATA, and keeps going on and off line, it's probably a bad drive. It happens. At least you have your data backed up.
My System SpecsSystem Spec
31 Jul 2014   #6
kufr

Windows 7 Ultimate x64
 
 

Quote   Quote: Originally Posted by Layback Bear View Post
I don't know what all your problems but I think I found one of them by reading your system specs.

Quote:
Antivirus Emsisoft Anti-Malware, Eset Smart Security, MSE
Browser Chrome
Emsisoft and/or Eset could be stopping thing from entering the compurter including another hard drive.

You should only use one anti virus program on one computer at one time.
That is not the case I have tried the drive in other pc even pc's without any antivirus installed the issue is drive related.

Quote   Quote: Originally Posted by Mellon Head View Post
I noticed that you said the drive was only three months old. It sounds to me like the drive is failing.

Have you tried it in different USB ports? Have you tried booting up with the drive plugged in? Not plugged in? Those things probably won't make a difference, but it's worth a shot.

I would just return the drive under warranty and get a new one. If it won't work under USB or SATA, and keeps going on and off line, it's probably a bad drive. It happens. At least you have your data backed up.
Yep yep yep been there done that have tried everything booted plugged in via sata also tried the external ensloure with the usb botted without plugged in then plugged in via both sata and usb same issue ... I have sent the drive with the warranty card to the shop they are having a look at it lets see what they say they will get back to me by Monday ... im keeping my fingers crossed even if they say the drive is A OK I will ask them to replace it with another drive.
My System SpecsSystem Spec
09 Aug 2014   #7
kufr

Windows 7 Ultimate x64
 
 

Got my drive back after I sent it in with my warranty card and they said everything was ok with the drive .... Plugged my drive in it was detected I instantly copied all my data to other HD's thank God it was still all there ... Then I formatted the drive and also now the drive is empty as u can see in the screenshot below.



My device manager also started showing it in the Hard drive list



I went in to the drive properties via device manager and changed the policies from quick removal (recommended) to better performance



This way the drive stayed detected for more then a few hours. Now the funny thing is after a few hours it was again not listed



I had to unplug the USB and Re-plug it and it was detected again I am so sick of this the vendor and the Western Digital people whom I got in touch with are saying the drive is ok there is nothing wrong with it they have checked it again and again.

I was trying to copy large amount data back to it the one i reallocated to the existing drives while doing that the drive again stopped being detected. RE plugged in was being shown as Drive X again I went it using EaseUs Partition Master and tried to wipe the partition which never finished the EaseUs stopped responding stuck said wiping data on 5% for over half and hour so i replugged it again and using the windows option from right mouse click reformatted the drive. Now after reformatted it. It is still there and I am copying about 100+ GB data to it to see if its still being detected or would vanish again from the disk list



So far so good 54 Gb data copied and the disk drive is still there being in my drive list without any problem I am keeping my fingers crossed



Because I am on the last straw here and have pulled out enough of my hair due to this problem. If I again face the issue i'll beback in the meantime please feel free to comment or advise if u guys think of anything else.

ONE MORE THINK IS THAT SHOULD I SET THIS DRIVE AS ACTIVE OR LEAVE IT AS IT IS
My System SpecsSystem Spec
10 Aug 2014   #8
gigagiggles

Windows 7 Home Premium x64
 
 

A shot in the dark: Your problem exists when the drive has your valued data?

When formatted and mostly empty, the drive does not exhibit any problems?

If that is the case, then it may be the way your valued data is organized.

I had a folder in an external drive where I would offload into webpages for future reading. These webpages had long titles and the folder had in excess of 500, likely closer to 1000. I had gotten lazy and kept offloading. At some threshold, the drive began misbehaving. During the troubleshooting process, I tried to save the data on the drive. While moving the data to another drive, I ended up organizing these offloads. When I moved the reorganized files back to the drive, the problem(s) never reappeared.

A shot in the dark.
My System SpecsSystem Spec
11 Aug 2014   #9
kufr

Windows 7 Ultimate x64
 
 

Quote   Quote: Originally Posted by gigagiggles View Post
A shot in the dark: Your problem exists when the drive has your valued data?

When formatted and mostly empty, the drive does not exhibit any problems?

If that is the case, then it may be the way your valued data is organized.

I had a folder in an external drive where I would offload into webpages for future reading. These webpages had long titles and the folder had in excess of 500, likely closer to 1000. I had gotten lazy and kept offloading. At some threshold, the drive began misbehaving. During the troubleshooting process, I tried to save the data on the drive. While moving the data to another drive, I ended up organizing these offloads. When I moved the reorganized files back to the drive, the problem(s) never reappeared.

A shot in the dark.
Thanks for the post. At the moment the drive is working I formatted it twice via windows and connected it via a SATA cable transferred over 200+GB data and no issues it has been full 24 hours and i'm praying that it behaves. Also showing up in my WD Data Lifeguard Diagnostic software and checked the drive and it came out ok no errors or problems so i guess that now its ok to copy data to this drive ???
My System SpecsSystem Spec
11 Aug 2014   #10
ComputerGeek

Desk 1: Win 7 Pro x32; Desk 2: Windows 10 x64
 
 

I just skimmed your thread so apologies if i overlooked any detail but here are some thoughts
  1. Have you tried the drive on a different PC? Determine if it's truly a drive problem or PC may be part of the problem
  2. Have you tried the drive while other USB devices (other then mouse/keyboard) are disconneted. Some USB issues can be power related
  3. Have you checked for any BIOS updates for your machine?
  4. Any chipset driver updates? You can reinstall them as well
  5. I'd also go into device manager, right click each ROOT hub, go to Power Management tab. Don't allow the computer to turn off this device to save power
My System SpecsSystem Spec
Reply

 External Hard Drive issue cannot stay detected




Thread Tools Search this Thread
Search this Thread:

Advanced Search




Similar help and support threads
Thread Forum
External Hard Drive Not Detected
I have a western digital mybook (WD5000C032-002) that for some reason is not being detected by Windows 7 RC. It is a USB connection straight from the mybook to one of the motherboard's usb ports. All my device drivers are up-to-date. If I go into "Devices and Printers" and click on "Add a...
Hardware & Devices
External Hard Drive not Detected
I have a small 50gb HHD powered from USB It will connect to my laptop running windows 7 home premium but not my pc running windows 7 professional When plugged into my pc by usb the Disk does not power up and spin (the light does come on) There is no recognition of it in my computer, device...
Hardware & Devices
External hard drive not detected---again
I have an 1T external drive plugged into esata port. It used to work and now it doesn't? When I boot up bios correctly identifies the drive as a seagate sata drive. When I look at device manager is says its a seagate SCSI drive and therefore the system doesn't recognize it at all? In device manager...
Hardware & Devices
External hard drive not detected
Hi guys, My computer cannot detect my 250GB external hard drive and I'm having a hard time fixing this issue, and I've been searching for the problem to be fixed in the internet, unfortunately nothing was found. Before this issue happened, there was no problem, it was working fine until I did...
Hardware & Devices
External Hard Drive Detected but not Accessible
Hello, I have windows 7 32 bit on a toshiba laptop. I am posting becuase this is a strange situation. I have a goflex exteral terrabyte. The computer recognizes it, lists it in the device manager and claims that it is working properly. However, I can't access it, I can't save anything to it, or...
Hardware & Devices
External hard drive not being detected
Hi, I have been using my Iomega HDD for a while now and have never had any problems before today. It worked fine when connected to my Acer Netbook running windows 7 starter 32 bit. I connected to a friends laptop and it said to access it it must be formatted, so i bought it home and it said the...
Hardware & Devices


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 03:33.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App