Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Problem with PCI Expansion Ports

30 Aug 2014   #1
dbtmellis

Windows 7 Home Premuim 64 Bit
 
 
Problem with PCI Expansion Ports

I have run into a problem with my PCI Expansion Ports

I have been using a 3 port USB PCI Card. The other day, any device plugged into the card quit working.

Did some troubleshooting, and found out that the card is receiving power only, and is not transmitting any data. Some of the USB Devices I have - Printer, Flash Drive, USB Hdd, USB Wifi Adapter, Mouse, keyboard, Sidewinder Control stick, webcam, and a UPS.

I plugged each one into the card, and they all received power, but no data. Windows is not detecting that the device is plugged in, but the device does light up the LED's

I do not have any other PCI cards to test to see if it is the Card, or the ports that are bad. It is doing the same thing on both of the PCI slots on my Motherboard.

All of the other USB ports are working fine.


My System SpecsSystem Spec
.
30 Aug 2014   #2
Berton

Windows 7 Ultimate 64-bit, Windows 8.1 64-bit, Mac OS X 10.10, Linux Mint 17, Windows 10 Pro TP
 
 

Quote   Quote: Originally Posted by dbtmellis View Post
It is doing the same thing on both of the PCI slots on my Motherboard.
Without testing in another computer I'd assume the card is bad. I went a different way, put a 4-port USB Hub in the floppy drive bracket on the front of the computer, connects to the internal power supply and the data cable plugs into a USB port on the back. I do have a couple of the PCI Add-in cards salvaged from other computers but like the front ports for accessibility.
CablesToGo Model # 30564 but replacement is Model # 30567
4-port USB 2.0 High Speed Front-Bay Hub - Black
My System SpecsSystem Spec
30 Aug 2014   #3
dbtmellis

Windows 7 Home Premuim 64 Bit
 
 

I will try to find me a new USB card.
My System SpecsSystem Spec
.

30 Aug 2014   #4
dbtmellis

Windows 7 Home Premuim 64 Bit
 
 

With that USB hub, is there any way to connect internally to the motherboard? I don't want to tie up an existing USB port.
My System SpecsSystem Spec
Reply

 Problem with PCI Expansion Ports




Thread Tools Search this Thread
Search this Thread:

Advanced Search




Similar help and support threads
Thread Forum
Problem with USB Ports
I'm facing too slow internet speed say 3-5 KBPS. But my normal speed is 50-60 KBPS. Type of Connection :2.G Dial up connection with Nokia USB Modem(Cable Connection) with nokia mobile(Asha series). There is no problem with internet while surfing in mobile,but with dial up connection with...
General Discussion
Problem with SATA ports
I have an Asus P8Z77-V board and my front dock has just stopped working. Thinking it was a problem with the PCB of the dock I slipped the 500GB drive into an internal slot and still it did not show up in Computer using the ports indicated in the pic with the red arrow. Hooked up the SATA lead to...
Hardware & Devices
Problem with USB ports working
I am new to this site so I may not ask the right questions. Basically I have a Compaq Presario CQ62 Laptop. I've had it for probably 4-5 years. I have put various softwares on it. At some point, I don't know when, all 3 USB ports started screwing up. The two on the left side don't work. The...
Hardware & Devices
Ports problem
Hello, I'm having a strange problem. I'm trying to install Sophos and there fore the following ports need to be open: 8192, 8193 and 8194. All firewalls are disabled. But when I do telnet ipaddress 8192 (where ipaddress is the ip address of the problem pc) from the server I'm getting the...
Network & Sharing
USB Ports Problem
Ok here's the situation, evrything I plug into a usb port on my machine gets put into the devices/printers section. I have a flash disk and a sata docking station but can't use them as they aren't showing as generic drives. Any ideas as to what's wrong.
Hardware & Devices
USB ports problem
A few days ago, my portable hard drive (USB) was not recognized. But it was OK on other computers in the office using Windows 7. I tried various ports, but the computer is new and in any case, this didn't help. I am wondering if it is safe to delete all the USB connections from the "Device...
General Discussion


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 18:53.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App