Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: 4 Port USB Problem Stopped Working

05 Sep 2014   #1
ellellell1

Windows 7 64-bit SP1 (VM)
 
 
4 Port USB Problem Stopped Working

Hi Everyone

I have recently discovered that my 4 USB port splitter has stopped working suddenly. It is about 4 years old and I am pretty sure it only supports USB devices up to 2.0


I am not exactly sure what caused it to stop working suddenly but I have two possible ideas.

A few days ago when I had it plugged in, the notification area displayed a message saying "This device can perform faster if connected to a 2.0 port". I am guessing this may have mucked up my USB device because my 4 Port USB is plugged into my computer via 3.0 USB and devices connected to it are all 2.0

Also I seem to have noticed quite a lot of USB drivers when I open device manager under "Universal Serial Bus controllers' and I am wondering if I need to disable one of them to allow my USB 4 port to work? (This is what happened with my sound utility)
4 Port USB Problem Stopped Working-capture.jpg


I know that is should probably be plugged in to one of my other USB 2.0 ports on my computer but nothing happens there either. I think it needs to be reconised by the computer then it needs to install a driver called "MTT USB 2.0 Hub" or something.

Any help would be greatly appreciated




My System SpecsSystem Spec
.
05 Sep 2014   #2
Ranger4

Windows 7 Home Premium 64 bit sp1
 
 

Disconnect one of the USB devices you have connected to your 4 port splitter, remove the 4 port from the computer & plug the USB device directly into the USB port, thereby by passing the 4 port device. If it now works then the 4 port is probably faulty.
My System SpecsSystem Spec
05 Sep 2014   #3
ellellell1

Windows 7 64-bit SP1 (VM)
 
 

Yes, that works. You are probably right it is quite old after all. Although when I was mucking around with the drivers yesterday it suddenly recognised it but then it disappeared. I also have a USB fan and when I plugged it into the 4 port usb splitter I tested all of the 4 ports and all of them worked.
My System SpecsSystem Spec
.

05 Sep 2014   #4
Berton

Windows 7 Ultimate 64-bit, Windows 8.1 64-bit, Mac OS X 10.10, Linux Mint 17, Windows 10 Pro TP
 
 

A lot depends upon how much power the USB devices draw, the USB ports on the computer are somewhat limited. I use a 4-port self-powered Hub just for that reason.
My System SpecsSystem Spec
05 Sep 2014   #5
Ranger4

Windows 7 Home Premium 64 bit sp1
 
 

Quote   Quote: Originally Posted by ellellell1 View Post
Yes, that works. You are probably right it is quite old after all. Although when I was mucking around with the drivers yesterday it suddenly recognised it but then it disappeared. I also have a USB fan and when I plugged it into the 4 port usb splitter I tested all of the 4 ports and all of them worked.
The fan may work as it's only drawing power. Other USB device may or may not use power but they rely on other circuits through the USB connection that the fan would not use.

Berton's suggestion of a powered USB hub might be worth considering, if your USB devices need power from the USB to work.
My System SpecsSystem Spec
05 Sep 2014   #6
ellellell1

Windows 7 64-bit SP1 (VM)
 
 

Okay, Thanks i will look into that. I'm just wondering why it would have stopped working. It worked perfectly well before
My System SpecsSystem Spec
05 Sep 2014   #7
Ranger4

Windows 7 Home Premium 64 bit sp1
 
 

Quote   Quote: Originally Posted by ellellell1 View Post
Okay, Thanks i will look into that. I'm just wondering why it would have stopped working. It worked perfectly well before
Just about everything we buy & use eventually fails. It could have failed due to a broken wire inside, a bad connection or many other reasons.
My System SpecsSystem Spec
Reply

 4 Port USB Problem Stopped Working




Thread Tools Search this Thread
Search this Thread:

Advanced Search




Similar help and support threads
Thread Forum
USB 3.0 port stopped working
Hello, History: I have had a similar issue in the past with my last PC (which had serious issues and was replaced with this one that is only a few months old now) and got help from these forums, the problem was completely fixed but following the same steps does not work for me this time. ...
Hardware & Devices
USB Port Stopped Working after Power Surge
Hi After a power surge on hub port when attaching a card reader to a front USB port one of my external hard drives disappeared. The drive works fine and is now on another USB port. The non functioning rear USB port has the following properties (image 1) and the location address looks...
Hardware & Devices
AC4BFSP.exe has stopped working problem
Hello all, I was playing the game Assassin's Creed on a 7 32-bit machine and passed first stage. When starting second stage of this game I faced this problem "AC4BFSP.exe has stopped working" and game crashed. I did some search and found that I should install these three Download Visual C++...
Gaming
Windows installer has stopped working or setup.exe has stopped working
HI, I'VE INSTTALED WINDOWS 7 PROF.ON MY PC. I M TRYING TO INSTALL WINDOWS7ULTIMATE BY CLICKING ON SETUP.EXE AN ERROR MASSAGE APPEARED SAYING: THEN I TRIED TO INSTALL WINDOWS 8 ON MY PC.. BUT THE ERROR MASSAGE APPEARED SAYING SAME THING AND ALL OTHER SETUP IN THAT DRIVE ARE SAYING SAME...
General Discussion
Usb port for wired mouse stopped working, says exceeded power level
I never had a problem before but one of my usb ports stopped working. I just get a message saying that i exceeded the power level. When i tried it on other ports that particular mouse doesn't work in any of them, however my other mouse which is wireless works. Any ideas Thanks
Hardware & Devices
BSOD after USB port stopped working.
Hi, I use windows 7 64 os laptop . Today while working all of a sudden all usb ports stopped working, I restarted the machine , but the pc couldn't shutdown properly. While shutting down I observed an BSOD. I have attached the dump file, also I'm using latest drivers. Can you please...
BSOD Help and Support


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 08:21.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App