Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Boot some how switched to GRUB and bios won't load

05 Sep 2014   #1
Thornton

windows 7 Professional
 
 
Boot some how switched to GRUB and bios won't load

I would like to start by saying, I already had been looking to buy a new mobo and CPU, so I did. But to insure that this isnt a problem that has been heard of and to cover the off chance that a new mobo and CPU wont fix it, I want to ask.

Earlier today, I was playing a game that I keep on a second hard drive. Suddenly the game crashes. I go back to start it. "Cannot find files." I go to explorer, the partitions are gone. I go to partition editor, drive is missing. I, at this point, am thinking, maybe an update ran in the background and it temporarily kicked the drive out, Im gonna restart. I restart, but this time, instead of loading windows, it starts searching for raid connections, then says grub failed to find any bootable hard disks. You know whats funny about that, though? I haven't installed ubuntu on this had drive.... EVER. Why, or how grub is installed is beyond me. I think, ok, lets hit the bios and check the boot order. The bios wont load. I pull the slave hard drive. Nothing. I pull the master. Not only does the bios not load, the whole CMOS boot screen completely locks up. I switch the sata connector from the slave to the master, and this time the bios loads right up But, my arrow and escape keys dont work... I try restarting and loading the bios, but its locked up, again. I try the same process with the slave drive, and it makes this weird buzzzzzz-beep buzzzzzzzz-beep (repeat) until the cmos boot screen finally loads, then stops, but is still running. Stll, the bios wont load.

-Bios wont load...
-Boot menu wont load...
-Windows wont load...
-Somehow I ended up replacing the windows bootloader with GRUB.... not even GRUB2...

I did google the problem with the HDD, by model (segate barracuda 1tb). From what I read, on boot, this CAN be normal and if it stops after boot, should not immediately be believed to be corrupted, yet. However, considering it straight up dissipated from windows all together, I wont know till I can at least get my master working.

Anyone ever hear of any of this? Do you think this is all one issue? could it be a box car kindof thing, where one thing breaks, thus breaking the next thing which breaks the next? or do you think its just the perfect storm and is a lot of smaller issues happening all at once that have no relation to each other?

More than if you all have ever heard of it, anyone know how to diagnose or repair any of these issues? Like I said, I ordered a new mobo and cpu that I hope will fix these issues, but in case it persists, and really more out of curiosity, any thoughts?


My System SpecsSystem Spec
.
06 Sep 2014   #2
3D Jed

Windows 7 pro x64 SP1
 
 

'bios won't load' - try resetting the bios by removing + replacing the mobo cell battery (might even need a new battery). Then reboot with bare minimum hardware ie 1 stick of ram, 1 drive, just onboard gfx (if present). If that works, gradually put stuff back.

grub ? doesn't install itself. If you've never used Linux, maybe you've experimented with an activation hack in the past. These often use grub. (no accusation or insult intended)

BTW master + slave are terms from back in the days of IDE drives and big blue cables, when you had to set jumpers on HDDs to slave etc. You prob use SATA. Never liked those words myself . . .
My System SpecsSystem Spec
06 Sep 2014   #3
Thornton

windows 7 Professional
 
 

Quote   Quote: Originally Posted by 3D Jed View Post
'bios won't load' - try resetting the bios by removing + replacing the mobo cell battery (might even need a new battery). Then reboot with bare minimum hardware ie 1 stick of ram, 1 drive, just onboard gfx (if present). If that works, gradually put stuff back.

grub ? doesn't install itself. If you've never used Linux, maybe you've experimented with an activation hack in the past. These often use grub. (no accusation or insult intended)

BTW master + slave are terms from back in the days of IDE drives and big blue cables, when you had to set jumpers on HDDs to slave etc. You prob use SATA. Never liked those words myself . . .
I'll give that a try. I did pull the battery and replaced it with a brand new one already, so I'll take the caps off the dvi port on the mobo and try onboard, now, I guess...

I have installed Linux......... But on my secondary drive.... Not my primary. I did use easy BCD, however, on my primary, but only to add a backup partition to the boot menu using the windows boot menu. I know very well HOW I would have gotten it..... Its why I have it that's confusing. Really, your guess is as good as mine, on that one.

As for the master/slave thing. I call them primary and secondary, also. They are just terms I grew up with when I first started building computers with fat ribbon cables and 4pin molex was standard... I am now running full sata 6 and give or take a few things that still use 4 pins, like case lights, etc.
My System SpecsSystem Spec
.

Reply

 Boot some how switched to GRUB and bios won't load




Thread Tools Search this Thread
Search this Thread:

Advanced Search




Similar help and support threads
Thread Forum
GRUB does not load
I have Ubuntu 12.10 and Windows 7 Home Basic in one machine. After I put my Windows 7 to hibernate and then when I press the power button, instead of loading the Boot options menu or GRUB screen it directly boots Windows 7. I've read in some forum that continuously pressing ESC after you press the...
General Discussion
Dual Boot W7/XP using Grub - Can grub assign letters to partitions?
Hi I am looking at Grub4dos since my recent foray into all things bootloaders. I am gaining a little footing with what I can and can't do (practically!) Although it was definitely trickier than I thought (or I just don't have the same time like I used to... ) Anyhow, I am looking at Grub because...
Installation & Setup
switched HDD from one PC to another now wont boot
Hey, I just switched my old HDD to my Gateway computer and I'm getting BSOD when starting up Windows. I know it has something to do with the drivers and Windows 7 from the HDD being in a new Computer, but how do I reformat without losing some of my old files like music and such? I tried...
General Discussion
Accidently installed grub onto windows 7 boot partiton. Unable to boot
Hi. I accidently installed grub onto the seven boot partition. I can't boot into seven. It loads the ubuntu select os screen, I select WIndows 7 (Loader), and it justs goes back to the ubuntu select os. Please can someone help? I still have windows 7 installed, and I have full access to...
General Discussion
Recover Windows 7 boot on dual boot system with GRUB masterboot
Hi, I have a dual-boot system Ubuntu/Windows 7. The Master boot loader is GRUB. It worked fine until yesterday when, for some reason, Windows 7 refused to load anymore. I tried to repair with chkdsk, found and repaired some disk errors, but now the boot loader is damaged. The problem I have is...
General Discussion
GRUB Shows at boot up
When ever i try to turn my pc on it shows GRUB on a black screen i have installed WUBI 9.04 ubantu linux now i cant log in to any os :( Sorry if in wrong section
General Discussion


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 05:47.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App